How to Prohibit users from playing CDA format CD

I have a windows XP Sp1 machine and I wanted to see if there was a way were I can Restrict a User or a group from playing either Audio Cds or anything of a CDA format. I tried to look for a specific folder but I was unable to find one. Also I do not want to remove windows media player because we do need to play video files if nessacery. I want to prohibit a user from being able to pop in a CD and listening to the music on it. Also Looked through GPO and didnt find much.
kissmecatAsked:
Who is Participating?
 
RomModCommented:
Question closed - 300 points refunded.

Best regards,
RomMod
Experts Exchange
Community Support Moderator
0
 
mjcoyneCommented:
You might be able to do this by uninstalling the audio codec used to play music CDs -- you'd likely have to also stop Windows from just downloading another copy, perhaps using a firewall (why are you only running SP1, BTW?).  Another option might be to diasble the MIDI device that plays the music.  I don't know if either of these changes will affect your ability to play (or at least hear) video files -- I guess it would depend on the video format and its audio encoding.
0
 
kissmecatAuthor Commented:
how i remove the codec
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
kissmecatAuthor Commented:
???? I tried to remove the windows media option to let it play CDA in its options but if i want i can just have a CDA open with the Windows media player and it will still play.
0
 
mjcoyneCommented:
Go to Control Panel -> Sounds and Audio Devices.  Click on the Hardware tab. Select the Audio Codecs item. Click on the Properties button.  In the Audio Codecs Properties dialog box, click on the Properties tab.  Select the codec you want to disable, and click on the Properties button.  Select the "Do not use this audio codec" option.

Similarly, you can disable the MIDI device in Control Panel -> Sounds and Audio Devices.  Click on the Hardware tab. Select the MIDI device, and click on Properties.  In the device Properties dialog box, set the "Device usage:" drop-down box to "Do not use this device (disable)".

Disabling the codecs and MIDI devices is probably better than removing them because it'll allow you to find the right combination that will allow you to still view the videos you need to, but make music CDs not work (perhaps).  Plus, if the codec is present but disabled, Windows won't try to download another one, so that problem goes away.  Additionally, and perhaps most importantly, disabling these things is easily reversible, should you go wrong and screw up your ability to view video, which is something you said was important.
0
 
markandrew21Commented:
Change your security policy for user in the MMC.  This works on XP pro.
Go to your start menu
Click on Run
Type in MMC
Hit OK
Add/Remove Snap in
Add "Local security Policy"
explore software rights
right click to add new policy
restrict the path to your media player for limited users.

If you need to watch a video, switch to an administrator account or set up a new permission group and just restrict the users in your new group.


0
 
kissmecatAuthor Commented:
Ok i see the list of Uadio codecs... the only issue it to figuere out which codec is for the CDA or audio cd format. Here is the list I have avalible to me:
IMA ADPCM Audio Codec
MS ADPCM Audio Codec
MS CCITT G.711 Audio Codec
MS GSM 6.10 Audio Codec
DSP Group TrueSpeech(TM) Audio Codec
msg723.acm
Windows Media Audio Codec
Sipro Lab Telecom Audio Codec
Fraunhofer IIS MPEG Layer-3 Codec
Indeo Auudio Software
MS PCM Converter
0
 
McKnifeCommented:
Maybe you could restrict it for everyone?
To listen to CDs, one needs
A a cable connecting the cd drive to the sound card - remove it
or
B the option "enable digital cd audio plyback for this CD-Rom device" via the properties of the drive in device manager. Only admins could reenable that.
0
 
kissmecatAuthor Commented:
Yep, I disable is and I was still able to go to program list and ask it to open with windows media player. :-(
0
 
kissmecatAuthor Commented:
if I remove the cable then when user tries to listen to a video file ... they will not be able to. Theres has to be a way to accomplish my goal.
0
 
McKnifeCommented:
I am unsure now myself. As far as I knew, that would do it so I tried it myself on my own machine now and it still works although no cable and disabled option n device manager. Sorry.
0
 
mjcoyneCommented:
I would start with disabling the Windows Media Audio Codec, see how it goes.  If that's inadequate, I would go the other wasy -- find out what codec the video you need to be able to hear uses for its audio stream, and disable everything else.  To find out your video's codec requirements, you can use a tool like AVICodec (see http://avicodec.duby.info/).
0
 
kissmecatAuthor Commented:
Ok i disable all the codecs but still not working.
0
 
kissmecatAuthor Commented:
Any Other suggestions please!
0
 
kissmecatAuthor Commented:
Never Mind, I figuered it out on my own. The dll file named mcicda.dll is the file i needed to disable. Thanks for trying though.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.