DHCP Server Down

I am running Windows 2003 Server Enterprise. The server act as DNS and DHCP, Active directory is also installed on the server. My DHCP server is down or not working. If I go the DHCP snap in it displays the folowing message: (Cannot find the dhcp server. The dhcp server you specified cannot be located. The DHCP server might be down, there might be network problems, or the DHCP service might not be installed.

The error was: The DHCP Server service is not running on the target computer.

To retry the connection, either press F5, or on the Action menu, click refresh.

For more information aout trubleshooting a DHCP server, see online help.)

If i go to services DHCP the startup type is automatic and the status shows starting.

It was working fine just this morning it showed the error please help a.s.a.p.
gnoble786Asked:
Who is Participating?
 
Mad_JasperConnect With a Mentor Commented:
I don't know the size of you network, but is it feasible to remove DHCP and reinstall it? Even for my network with 300 nodes, it can be done in 10 - 15 minutes, including the DHCP options.

It may save you time and headaches if you rebuild.
0
 
simonlimbCommented:
have you tried to stop the DHCP Service, then start it again?  I would do this first.
0
 
gnoble786Author Commented:
It cannot be stopped or started those options are grey, it just shows starting.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
jhanceCommented:
Anything in the event logs?  Tried restarting the server?
0
 
gnoble786Author Commented:
restarting does not help. Nothing is in the event log
0
 
SSG_HillCommented:
Are you logged on as the enterprise admin?
0
 
mikefalconeCommented:
I had this problem once and did what Mad Jasper suggests, and it fixed the problem.
0
 
rickyclourencoCommented:
Restart!!
0
 
SunBowCommented:
Reinstall.

The subnet(s) are in a data file that should be protected, but back them up if you want to.

Sometimes MS gets hosed if you change the configuration too much.

Not as drastic is trying to boot to safe mode without networking. Configure to manual start. Then restart the computer and when it settles down start DHCP manually. My guess is slim chance of that working, but worth a try.

ditto mikefalcone & Mad_Jasper
0
 
rickyclourencoCommented:
I agree with Uninstalling DHCP and Re-installing it, but still, before all that, bounce the box if you are having that much trouble.....its worth a shot
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.