• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 731
  • Last Modified:

Sparc Solaris 10: Installed packages not found in default PATH !!

I'm trying to install FreeRADIUS on Solaris 10 (Sparc, Sunfire v100), which requires following packages on OS:
gcc, gmake, glibc, binutils, gawk

All these packages were installed by default when installing solaris 10
but while installing FreeRADIUS it can't see these packages when I run the commands

no gcc
no gmake
found in default path.

I even downloaded & installed these packages from sunfreeware.com
I'm a beginner to Sun OS, but it seems to me that it has something to do with setting the right path.

0
lagooy
Asked:
lagooy
1 Solution
 
arthurjbCommented:
Yes, the path to those should be /opt/sfw/bin

type "echo $SHELL" (without the quotes)
this should tell you the shell that you are using.

If its sh or ksh then these are the commands;
PATH=$PATH:/opt/sfw/bin
export PATH

For csh it is;
set path = ($path /opt/sfw/bin)
0
 
lagooyAuthor Commented:
Thanks arthurjb,
PATH=$PATH:/opt/sfw/bin
export PATH
it worked ... just one more concern with setting the path
everytime I reboot the sun machine ... the exported path returns back to default ...
how can I save the PATH for every user as well as root so that PATH remains same even after reboot.
Thanks in advance....
0
 
arthurjbCommented:
You can edit /etc/profile  there will be a path statement just add a colon and your path to it.

Also take note that the path is looked at in order so if you have the same named command in 2 different places in the path, only the first one will be executed.
So if you notice a command behaving a little differently. it could be that you are executing a slightly different version.
0
 
wesly_chenCommented:
> everytime I reboot the sun machine ... the exported path returns back to default
I would recommend that you change the path setting for your personal environment instead of system wide (/etc/profile)

for Csh
~/.cshrc (or ~/.login)
set path = ($PATH /opt/sfw/bin /usr/local/bin)

For sh
~/.profile
export PATH=$PATH:/opt/sfw/bin:/usr/local

for bash
~/.bashrc (or ~/.profile)
export PATH=$PATH:/opt/sfw/bin:/usr/local
0
 
NopiusCommented:
I aggree with arthurjb, it's preferrable (in this case) to change system wide /etc/profile than user-local profiles.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now