• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 673
  • Last Modified:

Server 2003 with Multiple IP address

I have a server with 2 NICs both with IP addresses. When i PING the server i want it to return with the address of the first NIC.

Basically it is a host server for a virtual machine. I will be adding more virtaul machines later with more addresses, but whenever i want the host pinged i want it to return with the 192.168.1.92 address.

i checked the advanced NIC settings and the adapter with .92 is at the top

How do i go about this? do i need to change the metric of the route?

Here is the route

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
      169.254.0.0      255.255.0.0  169.254.189.224  169.254.189.224     10
  169.254.189.224  255.255.255.255        127.0.0.1        127.0.0.1     10
  169.254.255.255  255.255.255.255  169.254.189.224  169.254.189.224     10
      192.168.1.0    255.255.255.0     192.168.1.92     192.168.1.92     10
      192.168.1.0    255.255.255.0     192.168.1.94     192.168.1.94     10
     192.168.1.92  255.255.255.255        127.0.0.1        127.0.0.1     10
     192.168.1.94  255.255.255.255        127.0.0.1        127.0.0.1     10
    192.168.1.255  255.255.255.255     192.168.1.92     192.168.1.92     10
    192.168.1.255  255.255.255.255     192.168.1.94     192.168.1.94     10
        224.0.0.0        240.0.0.0  169.254.189.224  169.254.189.224     10
        224.0.0.0        240.0.0.0     192.168.1.92     192.168.1.92     10
        224.0.0.0        240.0.0.0     192.168.1.94     192.168.1.94     10
  255.255.255.255  255.255.255.255  169.254.189.224  169.254.189.224      1
  255.255.255.255  255.255.255.255     192.168.1.92     192.168.1.92      1
  255.255.255.255  255.255.255.255     192.168.1.94     192.168.1.94      1
===========================================================================
0
Avatar261
Asked:
Avatar261
  • 2
1 Solution
 
jar3817Commented:
Why would you want that?  If you ping 192.168.1.94, .94 should reply. If you ping 192.168.1.92, 92 should reply. Maybe I'm missing the point.
0
 
Mad_JasperCommented:
Do you have a host (A) record in DNS for both adapters?

If you binding order is set correctly and you have entries for both adapters in DNS, DNS should resolve the name to .92 adapter.
0
 
Mad_JasperCommented:
Pulled the trigger to soon.

If you do not have DNS records for both adapers, you can manually create a host record or go to the Advanced TCP/IP settings, choose the DNS tab, and ensure the "Register this connections addresses in DNS" tick box. Or, if you so not want a specific interface register in DNS, uncheck it.

Hope this helps.

MJ
0
 
nprignanoCommented:
each vitrual machine can be assigned a unique host name and a unique virtual IP address.  you do not need anything special other than the virtual server software properly configured to have the host server respond to replies to the hostname it is assigned.  virtual machines will not respond to the ping requests made to the host machine name, only to their own unique name.

and in dns you should have a host record for each virtual machine hosted on the server running the vitrual server software.



nprignano
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now