[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 657
  • Last Modified:

Installing new versions of applications using rpm

Hi, not sure if this is the right place to ask the question. I'm using SUSE 10.0 I need to upgrade my version of php (currently using php 4.4 and need to move to php 5). The problem that I'm experiencing is as follows every time I attempt to rpm -Uvh php5-5.1.2-3.i586.rpm I get

error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by php5-5.1.2-3
        libmm.so.14 is needed by php5-5.1.2-3

Which I didn't think was such a big deal, so I found an rpm version of glibc 2.4 and ran rpm -Uvh glibc-2.4-31.0.20060508.i586.rpm. This resulted in the following:

error: Failed dependencies:
        glibc = 2.3.5 is needed by (installed) glibc-locale-2.3.5-39

Again fair enough so I fugred well I'll install glibc-locale-2.4x so I ran the following command:

rpm -Uvh glibc-locale-2.4-22.0.i686.rpm

 error: Failed dependencies:
        glibc = 2.4 is needed by glibc-locale-2.4-22.0

Obviously this brings me full circle...how in the world does one install a package that has dependencies that rely on each other. Any ideas?
0
mark_dh
Asked:
mark_dh
  • 5
  • 2
1 Solution
 
Cyclops3590Commented:
2 things
1) why can't you use the yast update program to upgrade your software
2) if you can't use the yast, the do this
rpm -Uvh php5-5.1.2-3.i586.rpm glibc-2.4-31.0.20060508.i586.rpm glibc-locale-2.4-22.0.i686.rpm
just list them all at once instead of doing them seperately and it will pass the dependcy test
0
 
Cyclops3590Commented:
but I would highly recommend upgrading software thru the OSs package manager though. if at all possible
0
 
mark_dhAuthor Commented:
I haven't been able to get Yast working with external data sources.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
Cyclops3590Commented:
gotcha, then you should be able to just list all of the rpms at once and get it to work
0
 
Cyclops3590Commented:
just out of curiousity, why did my answer receive a B rating.  did my suggestion not work?  just curious
0
 
mark_dhAuthor Commented:
It's nothing personal however it didn't work completely, while i tried what you suggested i was simply prompted by another dependency that needed to be installed. So I appended that on to the command, then it was another and another and another...i was hoping for a simipliar (sp?) solution...
0
 
Cyclops3590Commented:
thanks for for clarifying...it is very much appreciated

I understand the disgust, but unfortunately unless yast does it for you, you have to do the rpm dance for a while
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now