Web Portal, external connection issues, wrong IP address in ICA launch file

Posted on 2006-05-12
Last Modified: 2008-10-20
I have a mixed xpe, fp3, fp4 Metaframe farm running on 2000 and 2003 servers.  We have a internal network on a 10.1.x.x.  My Web Interface works internally with no problems.  But no one can access the applications from the outside, they can access the webinterface, but when launching a application it dies in the connection stage, saying No Citrix Metaframe server exists on the specified address.  We have a 2003 server running IIS that  has the web portal installed on it at, our firewall guy has published a external address to our internal web portal server, including port forwarding of 80, 443, and 1494.  I rebuilt the 191 server without presentation server installed and just IIS and the webconsole from a FP4 disk.   I’ve saved the ICA file on the desktop of a remote PC and its showing the internal address of the published applications server in the connection information.  How do I change the ICA file to give the external ip address??  If I manually change the ip in the file it launch's the application correctly.  
Question by:District51
    LVL 5

    Accepted Solution

    Check to make sure you have the alternate address configured on the server.  

    from command line


    It should be set to the pulic IP address that is being forwarded to your citrix server.  

    If it is not set you can altaddr /? for the correct syntax
    I think it is just altaddr /set

    You need to also make sure that the web interface is set to use the alternate address for external subnets.  

    If published applications work but the web interface doesn't it will be the config in the web interface.  If you cannot run published apps externally than it will be the alternate address.

    Hope this helps

    LVL 18

    Expert Comment

    if it runs when changing the launch.ica file then you've probably got everything configured correctly expect the web interface.

    You just need to change this:

    in the Access Suite Console (web interface admin tool) click "Manage Secure Client Access" > Edit DMZ Settings

    Change the default connection to "Alternate"

    If you want the internal connections to work then create additional rules for those subnets such as:

    Author Comment

    Thank you both.  I accepted the first question thinking I could divide the points or award both as correct as it took both setting the altaddr and the default connection to Alternate, then it worked.  Still have some connection issues relating rights and so forth but my newly rebuilt 2003 server with applications is working well.  Some issues with my 2000 server and XPe builds, but at least I can connect some!   Thanks again.

    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    Join & Write a Comment

    Suggested Solutions

    Citrix XenDesktop 7.6 Citrix Policies Disable Peripherals
    Citrix XenDesktop 7.6 Citrix Policies Graphics
    How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now