Unable to reset Read Only Attribute on site files - Please Help

Posted on 2006-05-12
Last Modified: 2013-12-24
Hey Everyone, Please read and help if possible. Thanks in Advance.

I am a network Administrator working in conjunction with our Web Designer. I know computers, she knows web design.

An XP Home workstation with all OS updates and Frontpage 2002 experienced a HDD failure. New drive installed, OS and FP02 re-installed.

Local web site files were lost. Used the Import feature in FP02 to import files from the web domain. There were some problems, but the big problem is this: The imported files are marked "Read Only". According to our Web Designer this is preventing her from saving changes to the site, among other things.

Resetting the attribute is allowed, but it doesn't stick. When the Read Only attribute is unchecked for the folder holding the local files for the site, there is no error. The change is applied to all subfolders and files with no error. However, when the Properties are viewed immediately after changing the attribute, Read Only shows as checked. Specifically, it is grey, indicating some contents are read only.

The Web Designer imported the files from the domain to another system at her home office. There she was able to work with the files. She published the updated web site to the domain, then imported them to the system in question. There we are still unable to work with the files due to the above described problem.

What I have tried so far:
Using "Takeownership.exe". The process states that Protection was removed successfully. However, the above described problem remains.

Manually setting Security settings on the folder so that Everyone, Administrators, System and the current user have full priviledges on the folder, and security settings are NOT inherited from the parent object. And giving the Administrator ownership. The above described problem remains.

Using a command window to reset the attributes using the Attrib command. Appears to run successfully, but does NOT stick.

As I write this it occurs to me that I could try using a Safe Mode command prompt to perform the Attrib command. Is there any reason to think this might work?

Your knowledge and experience is much appreciated. Grade of A to the solution provider.


Question by:westone
    LVL 29

    Accepted Solution

    >>Local web site files were lost. Used the Import feature in FP02 to import files from the web domain.
    Don't use the import feature.  This can cause problems.  

    Create a folder on the local computer where she want the web.  Now try to open with ti FP.  FP will ask you if you want to make it a FP web.  Choose yes.  Close that.  Now go to File - Open web -  This will open the website up on the server.  Go to file - Publish.  Choose the location on your local computer and publish all the files.  Now you can close that and open the local copy

    LVL 6

    Assisted Solution

    When file attributes and rights aren't getting set the way you expect, you can try running Check Disk. In the process you will also be rebooting the server, which also fixes some rights problems.

    This may have to be scheduled since the server will be unavailable for one to four hours or more, depending on the size of the hard drive in question. These are the steps for Windows XP, but the procedure is similar for other versions of Windows. Use Windows Explorer to explore the hard drive in question, right click on the drive and choose Properties, on the Tools tab run error checking, and check the option to Automatically fix file system errors. If you have more time available to take the server off line, you can also check Scan for and attempt recovery of bad sectors. When you click Start you will get a message to the effect that the scan will occur the next time you restart the server. Restart the server and let the scan run. I have found that some errors like this are caused by problems in the file system that Check Disk will fix.

    The second thing to check is who has rights to the folder. In the case of webs hosted using IIS, The following users also need rights to the web:
    ASPNET (full rights) for ASP to work
    INTERACTIVE (almost full rights - but you can set full rights to see if it solves your problem)
    NETWORK (almost full rights - but you can set full rights to see if it solves your problem)
    SYSTEM (full control)
    IUSR_machinename (almost full rights - but you can set full rights to see if it solves your problem) needed so IIS can access the folders for Anonymous access. machine name is the name of the computer on which IIS is running.
    OWS_random number_groupname (various rights depending on the groups defined for the web such as Administrator or Browser. You can find out the random number and which groups are defined by looking at all the groups in USER MANAGER.

    There is a lot of information on the MS website regarding IIS permissions, such as the article on this page
    There is also a tool called AUTHDIAG.EXE that is supposed to help you sort out rights problems, although I admit I haven't found it that useful. (Just google AUTHDIAG.MSI and it takes you to the download page).

    One tip. Make changes to Anonymous Access via FrontPage Site Administration, not using Directory Security in the IIS Console snap in. When you use FrontPage Site Administration, then it gives rights to the appropriate users on the folders for you. If you used the IIS Console to grant annonymous access, fix it by opening FrontPage Site Administration, turn off anonymous access, and then turn it on again.

    Author Comment

    I created a new folder for the site, then in FP went to File > Open and browsed to it, but FP simply browses into it without asking anything. Was I supposed to use another method to get FP to prompt about my intentions for the folder?

    The machine automatically reboots and runs chkdsk /f weekly, and chkdsk /f /r monthly.
    This is just a workstation where the site is edited, not the hosting server.

    LVL 6

    Expert Comment

    Sorry for the misleading information. Westone(Bill) had indicated that he had given permissions to the folder to SYSTEM, so I had assumed that they are using IIS to host the site. With FrontPage you can open the folder that a site is in directly, or you can use IIS to host the site on a computer (including the development computer), and then open the site as if it were on the WWW. When you use the latter way of maintaining and using the local copy of your site, you have to worry about giving IIS the proper access to the site. IIS, in turn, lets you specify permissions for users of the site.

    Another idea. Is "Check in Check out" enabled for the web? Go to Tools, Web Settings, and uncheck Use document check-in and check-out.

    Another, more radical idea. I have not tested it, but I am assuming that since FrontPage keeps making the pages read-only there is a directive somewhere that tells it to make the files read-only, and this is stored in the "metadata" (data about the data) for the web.
    First copy the entire web to another folder, so that your original folder will be a "backup" in case this makes things worse instead of better.
    In the new folder structure, delete all the folders named _vti_cnf, which contain some of the the metadata. Then open the new folder in FrontPage and run the site summary report. Running the report will recreate all the _vti_cnf folders with "fresh" metadata files. You will lose all information relating to when the files were last published, so the next time you publish the site to your real web it will want to publish everything. You will also lose other information about your web such as Do Not Publish, when each page was last updated and by who, when last published, etc.

    However, if this fixes the problem you now will know where to look. You may be able to look at one of the files in the _vti_cnf folders in your oroginal folder (you kept it as a backup!) corresponding to the files that keep getting set back to read only, and then you can try to edit those files in Notepad to see if that fixes the problem. Again, do this test in a copy of the site folder.

    LVL 29

    Expert Comment

    >>Was I supposed to use another method to get FP to prompt about my intentions for the folder?
    If Frontpage does not ask you - it means this feature has been turned off for some reason or another.

    I cannot remember how to fix this.    But you might try to go to File - New Web and one page website.  And then it will create a web for you.


    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Join & Write a Comment

    Suggested Solutions

    Turn A Profile Picture Into A Cartoon Using Photoshop And Illustrator This tutorial will teach you how to make a cartoon style image out of a regular picture. I have tried to keep the tutorial as simple as possible. I used Adobe CS4 for this tuto…
    Objective of This Article In 1990’s, when I was a budding software professional, I had a lot of confusion about which stream or technology, I had to choose to build my career. In those days, I had lot of confusion like whether to choose System so…
    The purpose of this video is to demonstrate how to automatically show related posts at the bottom of a blog post in WordPress. This will be demonstrated using a Windows 8 PC. Plugin “Yet Another Related Posts Plugin” will be used. Go to your…
    The purpose of this video is to demonstrate how to Test the speed of a WordPress Website. Site Speed is an important metric of a site’s health. Slow site speed can result in viewers leaving your site quickly and not seeing your content. This…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now