• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

RPC error message while connected through VPN

I am connecting to a Windows domain using a VPN client.  While connected I am trying to access administrative tools to perform administrative tasks, but I am receiving an 'RPC server is unavailable' message.  I modified my HOST and LMHOST files, the computer I am using to connect to the domain is listed as an authorized domain computer, but I am still receiving this message.  Could someone tell me what I am missing?
0
jahhan
Asked:
jahhan
  • 7
  • 5
  • 2
1 Solution
 
Jay_Jay70Commented:
Hi jahhan,

can you confirm that your computer browser service is started and also that you can ping the machines in question by name
0
 
jahhanAuthor Commented:
My computer browser services is running, and I can ping the machine in question.
0
 
Jay_Jay70Commented:
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
jahhanAuthor Commented:
I actually checked out that site before posting.
0
 
Rob WilliamsCommented:
You could try connecting by the IP address, this works much better over a VPN, however if you configured your LMHosts file correctly this should not be an issue.
RPC can also be being blocked by a software firewall on the computer to which you are connecting, such as the Windows firewall or Norton, McAfee, Zone Alarme....etc.
0
 
jahhanAuthor Commented:
I tried to access the domain controller using the ip address and it gives me the same error message.   Below is the settings I have in my LMHosts file.
x.x.x.x   PDC01   #PRE #DOM:TEST-Domain
x.x.x.x   "TEST-Domain    \0x1b"  #PRE  
0
 
Rob WilliamsCommented:
If you cannot connect with the IP, then the error may well not be related to the LMHsts file.

For the record if using the LMHosts file there are some "funky" rules:
If adding a domain;
10.0.0.1       "DOMAIN-NAME     \0x1b"   #PRE
To quote lrmoore  there has to be 20 characters between " " and the last 5 characters must be "\0x1b"
A typical host entry would be;
10.0.0.2       Server1      #PRE
-PRE has to be capitalized, however you do not need it, though should give you faster resolution where it is "pre-loaded".
-you must hit the return key after entering a line, before saving
-and #'s are comment lines
-after adding entries to the LMHosts file, save it without an extension. Has a .sam (sample) extension prior to this. To be sure it saves without an extension save in quotations "lmhosts"

To check your LMHosts file entries are accepted, at a command prompt enter
  nbtstat  -R
to purge and reload the local name cache
then enter
  nbtstat  -c
to display the current name cache which should include your LMHosts file entries.
Note; the nbtstat "switches" R & c are case sensitive.

As for the RPC error;
-verify on the server the RPC services are started
-can you use the admin tools in the same mannor while on the same LAN
-a software firewall on the computer that you are trying to control can block RPC requests, can you disable, if there is one, for test purposes
0
 
jahhanAuthor Commented:
Everything you suggested I did try.  I verified my settings took by using the nbstat commands.  
The domain controllers does have RPC services running, but I did not try to use my laptop on the same LAN.  The PC I use on the LAN is able to utilize the administrative tools on the LAN.  Should I bring my laptop in the office and add it as a trusted computer?
0
 
Rob WilliamsCommented:
>>"Should I bring my laptop in the office and add it as a trusted computer?"
Is the laptop not a member of the domain? Seems to me for most remote administration tools using RPC it needs to be.
0
 
jahhanAuthor Commented:
thank you I will add my laptop to the domain when I get back to the office.
0
 
Rob WilliamsCommented:
Out of curiosity, try running the admin tool at the office with the laptop, before joining the domain, to see if it works. If it does that is not the problem. Let us know how you make out.
0
 
jahhanAuthor Commented:
will do..thank you so much
0
 
jahhanAuthor Commented:
while in the office I tried to access the domain computers and users applet and encountered the same error message.  Once I added by laptop to the domain I was able to access this applet.  The final test was to access the same utility through the VPN once I was out of the office.  I first attempt was connecting to the program using the domain controller name.  This returned an RPC error message,  I then tried with the IP address and that allowed me to access the network.
0
 
Rob WilliamsCommented:
Thanks jahhan. Glad to hear you were able to get it working. If you 'play' with the LMHosts file a little you should be able to resolve the name issue as well, even if you ignore the domain statement and just add the IP and server name.
--Rob
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 7
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now