Unable to reset Read Only attribute

Posted on 2006-05-12
Last Modified: 2013-12-04
Hey Everyone, Please read and help if possible. Thanks in Advance.

I am a network Administrator working in conjunction with our Web Designer. I know computers, she knows web design.

An XP Home workstation with all OS updates and Frontpage 2002 experienced a HDD failure. New drive installed, OS and FP02 re-installed.

Local web site files were lost. Used the Import feature in FP02 to import files from the web domain. There were some problems, but the big problem is this: The imported files are marked "Read Only". According to our Web Designer this is preventing her from saving changes to the site, among other things.

Resetting the attribute is allowed, but it doesn't stick. When the Read Only attribute is unchecked for the folder holding the local files for the site, there is no error. The change is applied to all subfolders and files with no error. However, when the Properties are viewed immediately after changing the attribute, Read Only shows as checked. Specifically, it is grey, indicating some contents are read only.

The Web Designer imported the files from the domain to another system at her home office. There she was able to work with the files. She published the updated web site to the domain, then imported them to the system in question. There we are still unable to work with the files due to the above described problem.

What I have tried so far:
Using "Takeownership.exe". The process states that Protection was removed successfully. However, the above described problem remains.

Manually setting Security settings on the folder so that Everyone, Administrators, System and the current user have full priviledges on the folder, and security settings are NOT inherited from the parent object. And giving the Administrator ownership. The above described problem remains.

Using a command window to reset the attributes using the Attrib command. Appears to run successfully, but does NOT stick.

As I write this it occurs to me that I could try using a Safe Mode command prompt to perform the Attrib command. Is there any reason to think this might work?

Your knowledge and experience is much appreciated. Grade of A to the solution provider.

Question by:westone
    LVL 17

    Accepted Solution

    Did you tried with attrib command?

    attrib file_dir  +R /S /D

    Try to manipulate  properly, the parameters in the attrib command.

    BR Dushan
    LVL 35

    Expert Comment

    Do not trust explorer, as it caches data and information. Have you tried to use a text editor to check, if you can save the files?

    Also, you said, that you can edit the files on a different system, this would point to me, that you have a problem with the single machine? The files, you download from a web-site, which is not part of your own domain, usually do not tranfer file attibutes, and especially no NTFS attributes.

    Check, if you can change any file attributes in a different folder.
    If you have setup XP again, make sure, you have proper permissions to this machine.

    If you have problems only within frontpage, this may have other reasons.

    Author Comment

    Gee Whiz, I'm starting to feel like people are responding without reading my post.
    LVL 35

    Expert Comment

    Do you mean something special? If you allow me to comment this, such comments do not really motivate others to go into your thread.

    Back to your question, let me tell you what the happenstance brings yesterday to me...

    If just had a folder, extracted from a RAR archive with R-Attribute set. I tried to delete the folder, but windows denied it. Tried to change the file attributes, windows does it, but denied to delete it again. R-Attribute is still shown.

    Overnight, the system rebooted and what happened? On one folder, the R-Attribute was away, on a second folder, the R-Attribute was still there, but I can delete both folders without the usual confirmation message (which comes up, if you try to delete a folder or file with R-Attribute set).

    As I said, don't belive explorer. Another option may be (as long as there is not a gernal problem on the machine). Copy the content of your web to a different drive (must be a second physical drive or a network drive). Try to change the file attributes there.
    Delete the root folder of this web site and recreate it and copy th content back. Maybe its an idea to reboot your machine aber each step.


    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    As I write this article, I am finishing cleanup from the Qakbot virus variant found in the wild on April 18, 2011.  It was a messy beast that had varying levels of infection, speculated as being dependent on how long it resided on the infected syste…
    Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now