ASUS P4P800-E Deluxe not detecting SATA 150 drive

Okay, so I put together a new computer with the following specs:

-ASUS P4P800-E DELUXE Socket 478 Intel 865PE ATX Intel Motherboard
-ASUS A9550/TD/128 Radeon 9550 128MB DDR AGP 4X/8X Video Card
-Intel Pentium 4 3.0E Prescott 800MHz FSB Socket 478 Processor Model BX80546PG3000E
-Western Digital Caviar RE WD3200SD 320GB 7200 RPM Serial ATA150 Hard Drive
-SONY 16X DVD±R DVD Burner Black IDE Model DWQ120AB2

Originally, I had an ASUS P4P800-MX MB installed and it would detect my SATA drive as the Third Primary Master and my DVD±R as my First Primary Master. Eveything was fine until I realized I couldn't overclock that MB. After spending a good chunk of money on cooling equipment I wasn't going to have it. So, I got the new MB listed above.

I put the new MB in and go into my BIOS to notice that it has only detected my IDE DVD±R as First Primary Master and it can't find my SATA drive. I made sure all my wires were acurate and snugly fit into their respective spots.

The P4P800-E Deluxe has a BIOS option to run SATA as RAID. After much frustration, I know next to nothing about RAID. It has a start feature were you can press Ctrl+F to run a hardware app, FastTrack, to build an array of your HD. I tried doing this and reconfigured the BIOS, but it would still not detect my HD. I'd prefer just to run SATA as SATA. The "User's Manual" doesn't say anything more about SATA than plugging SATA wire to the MB. It has a lot about the SATA as RAID feature.

Can anyone help me out on this? Until then I'm stuck booting off a live linux CD... thanks!
LVL 1
damijimAsked:
Who is Participating?
 
shaharidzalConnect With a Mentor Commented:
Hi damijim

I am using the same mobo as you are and currently running on WDC 80GB SATA drive.
Check the following;

1. You are connecting to the normal SATA-1 connector and not the SATA-RAID connector.
2. As what 'mjcoyne' point out, the IDE configuration has to be 'Enhanced-mode.

"Hot plug" means that you can plug/unplug the drive in Windows just like USB. This is mainly for RAID but the mobo does not support for this feature.
0
 
mjcoyneCommented:
Have you installed the OS yet?  When installing Windows XP, you have to hit F6 right at the beginning of the install (watch the messages at the bottom left of the screen) to install the SATA driver.
0
 
damijimAuthor Commented:
Yes, I have tried that, but Windows still says there is not a HD on this computer.

Also, I intend on install Fedora on the computer, so I really need the BIOS to be aware of the SATA drive.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
mjcoyneConnect With a Mentor Commented:
Ok, that motherboard has native SATA support.  Let's check a few BIOS settings:  On the first screen of your BIOS, there is a selection called IDE Configuration.  When you select it, a sub-menu appears.  Set "Onboard IDE Operate Mode" to "Enhanced Mode", and "Enhanced Mode Support On" to "S-ATA", and Configure S-ATA as RAID to "No".
0
 
damijimAuthor Commented:
That's how I've got it configured right now. :)
0
 
damijimAuthor Commented:
Just as a reminder, my old MB P4P800-MX detected it. My new MB P4P800-E Deluxe doesn't not. The P4P800-E Deluxe is an upgraded version of the P4P800-MX. So, in theory, it should detect it. Thanks for your time!
0
 
damijimAuthor Commented:
Reading through the MV's manual, there's a note that says, "Hot plug support for Serial ATA and connections are not avaliable in this motherboard."  I'm not sure what "hot plug" is, but do you think I need to setup my SATA drive manually in the BIOS?
0
 
damijimAuthor Commented:
lol, 9 hours and it was because I had it plugged into the SATA-RAID connector. Thank you both!

shaharidzal - in the box w/ my MB, there's a power connector with some weird adapters on them. The user's manual doesn't mention it... do you know what it is used for? Here's a picture at http://digital-expression.org/images/cable.jpg .

Thanks again!
0
 
damijimAuthor Commented:
shaharidzal or mjcoyne, I asked the aove question in a new thread if you want to answer it there. I assigned it at 250 point value. Thanks for your help again!

http://www.experts-exchange.com/Hardware/Q_21849798.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.