Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 139
  • Last Modified:

How to password protect a workstation on the network?

What I want to do is to still be able to be seen by others in the workgroup of this network, but if anyone on the network wants to access me through the network then a user name and password will be required.
I had this set up in Win 2000 but can't figure out how to do this in XP Pro?

Any ideas?
0
t_tronicz
Asked:
t_tronicz
  • 3
  • 3
  • 3
  • +2
1 Solution
 
BembiCEOCommented:
Exactly the same. But XP has some assistants, which may overlay the dialogs, which are included in the same way than in W2K. If you have installed XP in that way, that NTFS is selected as file system during Installation, the setup protects your PC as long as you have not left the Admin Password empty or used the same Password as on another system. You can change the Admin Password later in the same way than on W2K.
0
 
t_troniczAuthor Commented:
Can I get a refresher on how to set it up?
0
 
samb39Commented:
Open the User Accounts item in Control Panel and add a password to your account on the XP machine.  That should stop others from accessing it without that password.
0
2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

 
t_troniczAuthor Commented:
done that does nothing, they can just double click my system icon and their in!
0
 
r-kCommented:
Do the following (on your XP Pro station)

 Windows Explorer -> Tools -> Folder Options -> View

then scroll down to the item that reads "Use simple file sharing..." and UN-CHECK the box next to it.

Then click OK etc. and you should be able to do files ahring as you want after that.
0
 
samb39Commented:
In a workgroup, all network connections authenticate as Guest.  So go into Control Panel, and use User Accounts to disable the Guest account.  That should force them to sign in before accessing shared resources.
0
 
JackOfPHCommented:
listening
0
 
JackOfPHCommented:
does this work if i have domain?
0
 
samb39Commented:
If you have a domain, network connections authenticate with the correct domain accounts, and the Guest account is not normally used.  So disabling the guest account won't have any effect.  To control shared resources on a domain, adjust the access control list on the Sharing and Security tabs of a shared object's properties sheet.  If you share it with "Authenticated Users" that will let everybody into it who has a domain account.
0
 
BembiCEOCommented:
The guest account is usually disabled by default (WinXP).
The administrator account should have a password, which is unknown to others.

If you setup a client within a domain, the Domain-Admins are added to the Administrators groups and the Domain-Users group is member of the local Users group. That means, that Domain-Admins have access to your machine and any user, which have NTFS permissions in your system.

Just right click - properties your C drive or one of the subfolders like programms --> security to see, who has access to your machine. You can also create a new folder (something like a data folder), set the security settings to your account and to system and also set the ownership for this folder (tab owner) to your account. In that way, nobody can view this folder, but the admins can make maintenance on your machine.

Nevertheless, within a domain, an administrator is able to take over the ownership and then view the folder, if he wants to do that.
0
 
t_troniczAuthor Commented:
Ok, here is what I have now, when I try to access the main pc through one of the other work stations it gives me a username password window. The user name has writing in it the name of the main system/guest this box is grayed out. Password is empty, I enter the password for the main system and nothing, i tried no pass word and still nothing. What could cause this? What is the password? How might i find out what the password is, should be. I'm lost now.

Thanks for all your help, so far Bembi has it!
0
 
r-kCommented:
Have you tried my suggestion above of un-checking the "simple file sharing" ?
0
 
BembiCEOCommented:
Jepp, do what r-k said, you will get a little bit more control.

If you connect to a foreign machine, the system checks, if the user, who tries to get access, can be authenticated in any way. If there is no valid authentication (your current login name and Password / guest account), the system asks for a user account and Password (the Box you get). In that way, you can connect to any system, if your now the correct credentials. And vice versa, if not, you get no access.

The guest account do not have a password by default (as I know, I always disable this, if enabled). You can set / change the password within the local user administration (where you may have changed the admin password). Or Start - system setting - accounts...
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 3
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now