• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 429
  • Last Modified:

PC slow - dull rumbling noise from HDD ?



dealing with a Dell Dimension System here with a 40 GB Hitachi IDE drive...

Even though the computer is Virus and Malware free - it is terribly slow.

The only usual thing about this pc is that when you open any applicaiton a dull
rumbling noise happens from the HDD that goes on for a couple of minutes...

I test the HDD 3 times using the Hitachi Drive Diagnostic and it gives the all clear.

0
jetsonx
Asked:
jetsonx
  • 8
  • 4
  • 3
  • +5
2 Solutions
 
Will SzymkowskiSenior Solution ArchitectCommented:
Hello there,

Have you tried to do a scan disk? Also might want to run a Defrag. See if that helps
0
 
jetsonxAuthor Commented:
spec, it's and XP system - do you mean chkdsk ?

Defrag was one of the first things I tried. Any more suggestions ?
0
 
SteveG00000Commented:
Go into a dos prompt and type dir /s c: and listen to the drive, it should be a normal noise and you should see everything fly past, if it is very noisey then it is possible the drive might be about to pack up.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
jetsonxAuthor Commented:
steve, I ran that command and it flew trough it for about 5mins.
0
 
myfootsmellsCommented:
you might have a bad drive if it's making funny noises.  http://www.ontrack.com/freesoftware/

download their trial software, there is a utliity that can scan your disk to see if it's going to fail.

if you suspect that it's going to fail due to a mechanical problem, i would backup your data immediately as continuous use could scratch up the disk inside.

michael
myfootsmells
0
 
myfootsmellsCommented:
oh and the defragging software that comes with Winxp is horrible.  try www.diskeeper.com for a good defragging program that i highly recommend.

michael
myfootsmells
0
 
jetsonxAuthor Commented:
mfs, i've used Seatools on it also which proved negative.

(Seatools is just Ontrack repackaged)
0
 
myfootsmellsCommented:
did you run the tool that checked to see if you had a bad hard drive?  what does it sound like? clicking? gurggling?  any of those sounds not a good sign.

if it were me, i'd backup my data asap and get a new drive.

michael
myfootsmells
0
 
jetsonxAuthor Commented:
michael, no clicking, just like a very very dull gurggling noise.

all the HDD test done on it show it to be ok.
0
 
garycaseCommented:
Hi jetsonix,

First, IMAGE the drive to another drive !!   That way you don't need to reload the OS, data, etc. and you won't lose anything no matter what else happens.

Second, since it seems excessively slow, check both the BIOS and Windows to confirm the drive is being accessed in DMA mode.   If it's reverted to PIO accesses that would easily explain the slow access speed.   In the BIOS it should show this in the area where the detected drives are shown.   In XP you look at the IDE/ATA/ATAPI controllers in Device Manager; then on the Advanced Settings tab of the Properties page for each of the IDE channels.
0
 
scrathcyboyCommented:
Most likely the seek head is going - the "dull rumbling noise" is most probably the heads trying to re-read data from the sectors, sometimes up to 10 times.  Just backup the drive to another disk, and call it quits, if it is a 40GB, it is at the end of its life.  You can get an 80 GB Hitachi (which are excellent drives) on www.pricewatch.com for only $45.  What are you waiting for?
0
 
rindiCommented:
You said you did a defrag as one of the first things. What did the picture show? A full Disk? Large red areas? Did that clear up after the defrag? If those areas stayed red, defrag didn't help much. A full disk won't help. Delete some old stuff and run the defrag again. Don't forget to empty the recycler before defragmenting!

Also make sure your Disk is running in DMA and not PIO mode.

http://support.microsoft.com/default.aspx?scid=kb;en-us;158873
0
 
jetsonxAuthor Commented:


Ok - I am just after checking the memory on this system - its a mere 128 MB of RAM.

I rememvber reading somewhere before that when you go so little memory your HDD
gets uses as a swap file ? Would this make sense, is this why the HDD is making gurgling
noises all the time ?


rindi, I checked the transfer mode - its DMA.
0
 
IPKON_NetworksCommented:
Go into the properties of the My Computer and check out the Performance tab. Look at the paging file settings. It shows what it needs and how much is pre-allocated.

Might be worth checking to see if these are as they should be (allocate initial size to the recommended size).

Also, what has been installed recently? If this is recent then it means something is using up memory and the pagin file is being thrashed.

HIGHLY recommend adding more memory. At current prices, this would be a cheap and immediate benefit. 128MB is barely enough to load the OS (not quite that bad but it is considered low by todays standards)!!!

Barny
0
 
jetsonxAuthor Commented:
barney, ok another 256MB was put in - bringing RAM up to 384 (thats all that is clocked in DM)

page file settings are as follows:

 set to custom
initiatl = 192
max =    384
0
 
rindiCommented:
Set the pagefile to one static size. Now that you have 384 MB set it to min=max=512MB or more. If possible, I'd put the pagefile on a separate dedicated partition or drive. And yes, 128MB isn't enough if you want to work properly with XP, it really slows you down a lot.
0
 
jetsonxAuthor Commented:
so I will set initial to 512MB
and then set the max to 512MB ?
0
 
rindiCommented:
Yes, this makes sure that it will stay at one definite size. This is much better than having an allways changing size.
0
 
IPKON_NetworksCommented:
Rindi is correct unless you are expecting applications that use extremely large amounts of memory, then release it later. Then you would want the paging file to dynamically increase. A big problem with Windows is their use of paging files. It is based upon an old arhcitecture used in IBM's OS/2 kernel (and still is as far as I am aware). Basically, the system creates a file (paging.sys) upon boot up. The size is allocated as per your settings above.
This is not used at all (or very little) until you exceed the physical memory. Then parts of memory are paged out to the file for temporary storage while the processor services the online memory.
If you allow dynamic expansion, then the file will add chunks of disk to the file as it exceeds the paging file size. However, this is where the problem lies. They are fragmented chucks and not only does the system need memory and processor power to manage a swap file, it also needs to manage the fragmentation as well. This is where a lot of resources go (on an already strapped machine).

Therefore, if you find a swap file size that works, then create a static one and leave it alone. Word of caution. Don't be tempted to create a huge file (5GB) as this will then need to be managed in online memory as well as may take up more resources than you have, thus making the PC even slower.

Hope this helps
Barny
0
 
jetsonxAuthor Commented:
Thanks to everyone who responded.

At last, the system with new memory added and paging file set - is running alot faster.

0
 
rindiCommented:
your welcome
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 4
  • 3
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now