?
Solved

Help with the error: The Full-Text Service (msftesql) failed to logon

Posted on 2006-05-13
13
Medium Priority
?
1,425 Views
Last Modified: 2008-01-09
Hi I am trying to do a simple drop catalog command which is:

DROP FULLTEXT CATALOG <CATALOG_NAME> ;
GO

But I keep getting this error:

Msg 9956, Level 16, State 2, Line 4aThe Full-Text Service (msftesql) failed to logon. The system administrator must use a valid service account and password for the service.

Any ideas on what to do?
0
Comment
Question by:eecosmo01
  • 6
  • 6
13 Comments
 
LVL 75

Expert Comment

by:Aneesh Retnakaran
ID: 16676300
I think you have a incalid username -password problem. Check the username/password fpr  the service msftesql, by default the username and password is that of the service 'SQL Server Database Engine'.

0
 

Author Comment

by:eecosmo01
ID: 16676503
I do not see this service in the the list of services nor do I see this user in list of logins under in my sql management app. How do I change this password?
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16678036
>>I do not see this service in the the list of services<<
It is called Microsoft Search.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:eecosmo01
ID: 16678874
I have searched for the solution already and have not come up with anything. This is why I am asking here. Try it yourself, there are NO results if you search for this error on goog/yahoo/live
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16679220
Questions for you:
Which edition of SQL Server 2005 are your using?
Have you managed to find the Full-Text Service?
If you have, is the startup account a local administrator account?
0
 

Author Comment

by:eecosmo01
ID: 16679284
>>Which edition of SQL Server 2005 are your using?

I am using the Standard Edition.

>>Have you managed to find the Full-Text Service?

What do you mean by this? I am simply executing SQL commands such as:

DROP FULLTEXT CATALOG [TestCat] ;
GO

execute sp_fulltext_catalog 'TestCat','create'
GO

>>If you have, is the startup account a local administrator account?

Yes I startup using the local admin account which is why I am so confused by this error =(
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16679365
>>Yes I startup using the local admin account<<
Aside from the fact that this for security reasons is not recommended, have you restarted the service since installing SQL Server or changing the account?
0
 

Author Comment

by:eecosmo01
ID: 16679384
I do agree that the security setting is not ideal but I do not have any sensitive data on this computer...

Anyhow so I change the 'SQL Server FullText Search (MSSQLSERVER)' service to be logged in as 'Local System' it works!

So how do I make it so that the ./Administrator user works?

0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16679395
Unfortunately you have to use a System Account.
0
 

Author Comment

by:eecosmo01
ID: 16679402
Serious? Then why does the service by defualt start as ./Administrator? Are there any problems by leaving it as a local system user? Thanks!
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16679457
>>Are there any problems by leaving it as a local system user?<<
From the SQL Server Help:

<quote>
For the Full-Text Search service account, we strongly recommend using a low-privileged domain user account with only User rights and permissions on the local computer. Also, to ensure you are running the service with the lowest possible privileges, each instance of Full-Text Search should have a dedicated service account.

For security considerations, do not use LOCAL SYSTEM, LOCAL SERVICE, or NETWORK SERVICE as the service account to run MSFTESQL. This could provide an elevation of privileges for the Full-Text Search service.
</quote>
0
 

Author Comment

by:eecosmo01
ID: 16679504
Thanks, so if I use a Local System account it works, if I use anything else (I was using ./Administrator) then it doesnt.... I can create another account but how do I give it the permissions to do index'ing? I can't seem to find an option in the SQL Management Studio, better yet is there a way I can do this via a SQL Query?
0
 
LVL 75

Accepted Solution

by:
Anthony Perkins earned 1000 total points
ID: 16687167
>>but how do I give it the permissions to do index'ing?<<
In order to create a catalog (and unrelated to the Full-Text service startup account) this is what Books Online has to say about using the sp_fulltext_catalog extended stored procedure:

<quote>
Permissions
The caller is required to be member of the db_owner role. Depending on the action requested, the caller should not be denied ALTER or CONTROL permissions (which db_owner has) on the target full-text catalog.
</quote>
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ready to get certified? Check out some courses that help you prepare for third-party exams.
Microsoft Access has a limit of 255 columns in a single table; SQL Server allows tables with over 255 columns, but reading that data is not necessarily simple.  The final solution for this task involved creating a custom text parser and then reading…
Via a live example, show how to set up a backup for SQL Server using a Maintenance Plan and how to schedule the job into SQL Server Agent.
Via a live example, show how to setup several different housekeeping processes for a SQL Server.
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question