Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 552
  • Last Modified:

2003 OWA re-prompts user with HTTP header host name\username after installing KB916803

Prior to installing KB916803, we had 2003 OWA and IIS set to redirect to SSL then prompt the user for a username and password and ASSUME the domain name.  After installing this fix, the user enters his/her username and password and IIS re-prompts with the host name used in the URL header implied as the domain, not the actual organizational domain we had set as the default.  Any ideas would be appreciated.
0
dsrumer
Asked:
dsrumer
1 Solution
 
llefebureCommented:
What if you re-define the default domain name and realm in the properties in IIS? Maybe you just setting that info again will update the IIS metabase to use the correct info.
0
 
dsrumerAuthor Commented:
Tried that prior to posting question and just tried again with no luck.  Also tried modifying the settings in Exchange System Manager/Servers/Protocols/HTTP.

The thing I can't figure out is why IIS is prompting with the Internet name of the host and not the actual domain or IIS host name domain i.e. webmail.domain.com versus hostname.domain.com.  The way it WAS working, the internal domain name "COMPANY" was defaulted and all the user had to do was enter their username.  Now, it seems like IIS is trying to validate their profile on a non-existant domain.
0
 
dsrumerAuthor Commented:
However, when I enter COMPANY\username and password, login is successful.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
amaheshwariCommented:
Try this:

Title: Exchange 2003 OWA - Don't want to type domain\username at prompt
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21501308.html
0
 
dsrumerAuthor Commented:
Amaheshwari, thanks for the link, which I studied.  I really do not want to change the way users log on at this time.

Vasant, thank you too for the link.  I had already studied article 903924 but had not followed the instructions to the letter.  I unchecked Integrated Windows Authentication in the properties of the Exchange Virtual Server and it began working as before.

What confuses me is that the previous setting had worked for at least a year AND I have the previous setting functioning on other servers for other customers and it is working fine.  I can only assume that KB916803 made a change to how this functions and I have not applied the fix to the other servers.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now