Free/Busy sometimes not showing more than 2 months ahead

Posted on 2006-05-14
Last Modified: 2009-12-16

I'm hoping someone can help me with a problem we're experiencing with Free/Busy.
We have our Outlook clients set (through a group policy) to publish 24 months of free/busy data.
However, sometimes the free/busy data is reset to the default 3 months.
When this happens, it often requires "outlook /cleanfreebusy" to get it to 24 months again, though sometimes it's enough if the user logs on to their mailbox with Outlook.

Since this happens mostly with Blackberry and/or PDA users, we expect CDO may be the problem.
I found articles stating that CDO defaults to 3 months, but can be programmatically set to publish more. I do not see any options for this in our Blackberry Enterprise Server.

Any idea how I can assure that all my applications (and especially the BES) publish the same amount of free/busy?

Is it also possible that OWA messes things up? I know that OWA uses a different method to publish the data, but I'm not sure if it could cause this problem.

Any thoughts are appreciated.

Question by:MNH1966
    LVL 12

    Expert Comment

    What is the version of store.exe on your box? is your blackberry updated with all updates available?
    what is the version of cdo.dll on Exchange and Blackberry?

    OWA should not be doing anything in this case. Its most probably the Blackberry, which is resetting it back.

    Amit Aggarwal.
    LVL 12

    Accepted Solution

    Do you have this registry key in place?

    This is the number of months of FB data you'd like to publish.

    if not, add this key on the Exchange server. stop and restart IIS Admin and System Attendant.
    re-publish Free/Busy using outlook. (outlook.exe /cleanfreebusy) and then republish it ( send a test meeting request and make someone to accept that).
    login through OWA and check the blackberry also.

    see, if it works.

    Amit Aggarwal.
    LVL 9

    Author Comment

    Unfortunately, not all problems are fixed, but I think the change fixed most of them, so Thanks!

    The problem that's left differs from the rest. One user's free/busy disappears completely. After /cleanfreebusy the information is visible, but after a while, no free/busy (not even 3 months) is visible... Any ideas? Or should I post a new question?


    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    Join & Write a Comment

    Find out how to use dynamic social media in email signatures with this top 10 DOs & DON’Ts.
    Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
    In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
    In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now