Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 732
  • Last Modified:

Help setting up networking for SuSE linux 10.1--

Request assistance setting up internet connection on SuSE linux 10.1

I have a belkin router, with an XP laptop set up (working fine) and I've just installed SuSE linux on another computer.  While running the initial install, the SuSE linux box fails the internet connection test.

I log into the router (192.168.2.1) and I can see BOTH computers.  The SuSE linux box was assigned (192.168.2.2) and the XP laptop was assigned (192.168.2.3).

After attempting to connect to the internet on the SuSE linux box, here is the Internet Connection Test Log:

logger:  BEGIN OF YAST@ INTERNET TEST
ifup:      eth0   device:  nVidia Corporation nForce2 Ethernet Controller (rev a1)
ifup:      eth0   configuration: eth-id-00:01:80:40:3c:91
ifup-dhcp:  Starting DHCP Client Daemon on eth0...
ifup-dhcp:  .
dhcpcd[14194]:  dhcpConfig:  ioct1 SIOCADDRT:  File exists
modify_resolvconf:  Service dhcpcd modified /etc/resolv.conf.  See info block in this file
dhcpcd[14194]:  infinite IP address at lease time.  Exiting
ifup:      eth0    device:  nVidia Corporation nForce2 Ethernet Controller (rev a1)
ifup:      eth0    configuration:  eth-id-00:01:80:40:3c:91
ifup-dhcp:  IP/Netmask:  192.168.2.2
ifup-dhcp:    / 255.255.255.0
ifup-dhcp:
ifstatus:    eth0   device:  nVidia Corporation nForce2 Ethernet Controller (rev a1)
ifstatus:    eth0   configuration: eth-id-00:01:80:40:3c:91
ifstatus-dhcp:    eth0  DHCP client NOT running
ifstatus-dhcp:  2:  eth0:  <BROADCASTMULTICAST,NOTRAILERS,UP>  mtu 1500 qdisc pfifo_fast qlen 1000
ifstatus-dhcp:  link/ether 00:01:80:40:3c:91 brd ff:ff:ff:ff:ff:ff
ifstatus-dhcp:  inet 192.168.2.2/24 brd 192.168.2.255 scope global eth0
ifstatus-dhcp:  inet6 fe80::201:80ff:fe40:3c91/64 scope link
ifstatus-dhcp:      valid_lft forever preferred_lft forever
ifstatus:  eht0 is up
ifstatus: 2: eth0: <BROADCASTMULTICAST,NOTRAILERS,UP>  mtu 1500 qdisc pfifo_fast qlen 1000
ifstatus:      link/ether 00:01:80:40:3c:91 brd ff:ff:ff:ff:ff:ff
ifstatus:      inet 192.168.2.2/24 brd 192.168.2.255 scope global eth0
ifstatus:      inet6 fe80::201:80ff:fe40:3c91/64 scope link
ifstatus:      valid_lft forever preferred_lft forever
ifstatus:      eth0 IP address:  192.168.2.2/24
ifstatus-route:  Configured routes for interface eth0:
ifstatus-route:  169.254.0.0 - 255.255.0.0 eth0
ifstatus-route:  Active routes for interface eth0:
ifstatus-route:  192.168.2.0/24 proto kernel scope link src 192.168.2.2
ifstatus-route:  169.254.0.0/16 scope link
ifstatus-route:  default via 192.168.2.1
ifstatus-route:  1 of 1 configures routes for interface eth0 up
logger:  END OF YAST2 INTERNET TEST


some additional notes:  the eth0   configuration: eth-id-00:01:80:40:3c:91 matches what the router sees.

Thanks for any words!

dt

0
Darrell Thomas
Asked:
Darrell Thomas
1 Solution
 
Darrell ThomasAuthor Commented:
Ha... while typing the log in above, the answer came to me.  The linux box doesn't like the dhcp lease time of "forever".  Changed it to lease time of "two weeks" and it works.

I'd like to leave this post on in case anyone else has the same problem.

dt
0
 
EE_AutoDeleterCommented:
darrellthomas,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now