?
Solved

Compiling Apache with mod_ssl cannot find modile 'ssl'

Posted on 2006-05-15
8
Medium Priority
?
322 Views
Last Modified: 2010-03-04
I'm compiling Apache 1.3.34 with an updated openssl 0.9.8b and mod_ssl 2.8.25-1.3.34 to fix the open_ssl vulnerability.  The Linux is 7.2.  I'm getting the error "No such module named 'ssl'" when I go to compile mod_ssl using the following command:
 ./configure --with-apache=../apache_1.3.34 --with-ssl=../openssl-0.9.8b --prefix=/usr/local/apache.  I've tried putting in different paths, copying the mod_ssl.c and mod_ssl.h to various directories.  I just don't know what it wants.  I'm not an advanced user . . .
0
Comment
Question by:sightandsound
  • 4
6 Comments
 
LVL 10

Expert Comment

by:sleep_furiously
ID: 16685125
Did you run the configure in mod_ssl source package before you tried to run the one for Apache?
0
 

Author Comment

by:sightandsound
ID: 16685141
I was running ./configure --with-apache=../apache_1.3.34 --with-ssl=../openssl-0.9.8b --prefix=/usr/local/apache from within the mod_ssl install directory.
0
 

Author Comment

by:sightandsound
ID: 16685270
If I just try to compile Apache with the --enable-module=ssl I get the same error so it must have something to do with just Apache.  There is a modules/ssl directory within the apache install folder.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 

Author Comment

by:sightandsound
ID: 16685361
If I change the --enable-module=ssl to include the path ... --enable-module=modules/ssl I get a different message:
./configure: module_modules/ssl=yes: No such file or directory
The 'yes' response seems to be indicating that it is finding the ssl module, but now there is another error.
0
 
LVL 6

Accepted Solution

by:
bimal_linux earned 500 total points
ID: 16688049
Hi,

You may try latest apache and mod_ssl packages.
Refer this:
http://marc2.theaimsgroup.com/?l=apache-modssl&m=101757741802176&w=2

For latest packages, try: http://www.modssl.org/ . Try the "current versions" out there.

Regards,
Bimal Mankara
0
 

Author Comment

by:sightandsound
ID: 16693533
Using the latest versions fixed everything!  The ones I were using were not that old, but it made a big difference.  Thanks.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
The title says it all. Writing any type of PHP Application or API code that provides high throughput, while under a heavy load, seems to be an arcane art form (Black Magic). This article aims to provide some general guidelines for producing this typ…
Planning to migrate your EDB file(s) to a new or an existing Outlook PST file? This video will guide you how to convert EDB file(s) to PST. Besides this, it also describes, how one can easily search any item(s) from multiple folders or mailboxes…
Stellar Phoenix SQL Database Repair software easily fixes the suspect mode issue of SQL Server database. It is a simple process to bring the database from suspect mode to normal mode. Check out the video and fix the SQL database suspect mode problem.
Suggested Courses
Course of the Month3 days, 13 hours left to enroll

600 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question