• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 284
  • Last Modified:

Win2k3 not serving .aspx pages

Won't serve aspx pages on initial website, or new ones, but will serve html pages.  Is this a regsvr32 issue?  I haven't tried with .net 1.1, but all the sites being loaded are 2.0
0
nihannet
Asked:
nihannet
1 Solution
 
TheCleanerCommented:
Have you installed ASP.net through add/remove programs, windows components?
0
 
nihannetAuthor Commented:
of course...and I've also run the regsvr32 utility to register the 2.0 framework.
0
 
TheCleanerCommented:
Well, I'll start with the very basics:  http://support.microsoft.com/?id=315122

Also, what is the error you get?  Can you turn off friendly error messages in IE and post the exact error here?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
nihannetAuthor Commented:
with custom errors set to Off:


The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
--------------------------------------------------------------------------------

Please try the following:

Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
Click the Back button to try another link.
HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

first :
 If you are using the IE then use the following configure to see actual error not friendly error.
   Internet explorer > Tool >Internet Options > Advanced > Turn off Show friendly HTTP error

Now check and you can see actuall error now .

2. You need to set the application website to use .NET 2.0.  In your error
message, it's trying to use version 1.1.

Install .net 2 on your system

control panel> Add remove program> window component > IIS and install

Add webextensions under IIS > webextension and allow
0
 
nihannetAuthor Commented:
This question can be closed.  Noone was close.

Application Hosting was incorrectly installed.  After removing and reinstalling, it worked fine.
As a side note, I had to run the regsvr32 solution that's pasted all over the net AFTER the fact.
0
 
TheCleanerCommented:
eh...sorry nihannet, I had to leave and didn't see the topic again until today.  Glad you got it worked out.
0
 
ee_ai_constructCommented:
PAQ / Refund
ee_ai_construct, CS Moderator
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now