• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 178
  • Last Modified:

upgraded from 2K to XP Pro cannot connect to network

After upgrading a win200 computer on a network to win XP Pro SP2, I had to find the drivers for my network adaptor before it would connect to anything.  After doing that, I was able to connect to the internet through the network.

However, I cannot connect to any of the other computers or to the printer that is on them.

I tried to transfer the settings of another XP Pro computer on the network to this one, but that did not help.

I ran ipconfig and I am able to ping the XP computer, but that computer cannot ping the one with the problem.

On the view workgroup computers window, I only see this computer.

No other computers see this one on their list.
I disabled the windows firewall, but that did not help.
I ran the network setup wizard to no avail.

What could be wrong, what can I do?

HELP!!!!
0
Eliotk
Asked:
Eliotk
1 Solution
 
b0lsc0ttCommented:
Eliotk,

Make sure that the workgroup name (Network properties -> Network Identification) is the same as the other computers in the network (workgroup).  Also under Network properties, choose Properties for the local area connection and make sure that "Client for Microsoft Networks" and "File and Printer Sharing" are installed.  They should be listed in the same box that show the TCP/IP Protocol.

Are you running any other firewall software?  Disabling Windows Firewall will not make a difference if you are running Norton Internet Security, ZoneAlarm, etc.  If you are using firewall software then I actually recommend that you set up your network to be "allowed" or "excepted" from the rules of the firewall.  Ask me for details about this if you are running thirdparty firewall software.

If you still have a problem then run "ipconfig /all" on this computer and another one on the network.  Compare the results and let us know.


b0lsc0tt
0
 
EliotkAuthor Commented:
The network name is the same, there is no firewall service running, and the items you wanted in the properties are there.

I ran ipconfig /all and here are the differences:

My node type is unknown whereas the other one says hybrid
DHCP is not enabled on the other one.  It IS on mine.
Autoconfiguration is enabled on mine, not even listed on the other.
DNS server:  first one is identical, my second is my router, other is completely different.

Should I try to make them the same?

How?
0
 
scrathcyboyCommented:
An upgrade like this of network settings doesnt always work just right.  But it is only 5 minutes to repair, viz:

1.  go into windows networking and remove all protocols but TCP/IP.
2.  Go into device manager and remove the networking adapter.  Reboot.
3. when the system redetects the network card, it will ask you to setup the network.
4.  do that, and add back in all the protocols you were using in the previous setup, incl. DNS, gateway, etc.
5.  Share drive and make sure windows file and print sharing is enabled.
6.  Join the right domain or workgroup, using a new computer name, not old one.
7.  Browse for the computers, and create hotlinks to them.  You are done.
0
 
EliotkAuthor Commented:
I will try that, but I am not really sure what protocols we were using under 2000.  Should I check the protocols that are listed in the network properties of the other computer that is running xp?
0
 
sarangk_14Commented:
Hi Eliotk,

   Kindly post the "complete" results of the IPCONFIG/ALL for the Problem PC as well as one working PC. It should show the IP address, Subnet Mask, Default Gateway, DNS Servers, etc.
    Also try out the following things:
    1. First and foremost, is there a DHCP server in your network? if all the other working PCs have IP addresses configured manually, it's quite unlikely that you do. In this scenario, please assign to this PC an IP address that does not conflict with any other PC.
    2. try and ping the problem PC with it's IP address. If this is a success, use "PING -a" followed by the IP address of the problem PC to see if the IP address is getting resolved to a computer name.
    3. try and connect to other computers and printers using their IP addresses.

Please do the needful and keep us posted on the results.

Best regards,
sarangk_14.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now