[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 719
  • Last Modified:

ISCSI storage services "unauthorized access denied"

Hi guys, I'm installing a new blade server for a client, NW 6.5 SP5. The install failed on part of the product setup but I don't want to do it again as it took about 8 hours to copy from CD! So, I stopped it and netware comes up OK, is inserted into Edir, and seems fine. Problems though with first Imanager (to install the licences), and apache, tomcat and ldap. I've manually installed (response times are fine now ???) Apache, Tomcat, LDAP, Console1, ISCSI target, Novell Netstorage, Imanager, Nsure UDDI server. Seemed to go OK.  Got Imanager going and installed the Server licence. Cool. However, in Rmanager, the icons are missing. The defaut web page does not work on the server (HTTP://192.168.1.23 ) and when, in Imanager, we select storage services, then ISCSI services I get "Action failure Unauthorised access denied"  

Seems to me that apache/tomcat and maybe LDAP have some config problems - I had to set the IP addresses for the Appache, and imanager from rmanager - ipaddress management.

Anyone got any ideas about where to start to;

1.Get the default web page going
2. Sort out the Icon prob in Rmanager
3. Get the ISCSI prob fixed

I know that's a lot. Sorry. help would be really appreciated.
Thanks
Matt
0
mattpaulin
Asked:
mattpaulin
  • 5
  • 4
1 Solution
 
ShineOnCommented:
Are your certs OK?  Run a PKIDIAG...
0
 
mattpaulinAuthor Commented:
Hi ShineOn,

Thx for your reply. Sorry, should have put that in - tried that, no change.
I've given up and am biting the bullet and re-installing the server. For some wierd reason loading speed is much better.... Don't know why!
I just did a basic install, and the rmanager icons are there. Imanager works. But not the basic apache/netware default web page - and the apache2 nlm, although in the autoexec.ncf file, does not remain resident???

Cheers
Matt
0
 
mattpaulinAuthor Commented:
AND ISCSI Still won't connect, Unauthorised!!!
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
ShineOnCommented:
Did you use the same server name as before?  Did you remove the server from eDirectory before reinstalling?  Does this server hold a replica?  Is there more to the ISCSI error message besides the verbiage, like maybe an error code or reason code or some such?
0
 
ShineOnCommented:
It seems there's still a problem with the security infrastructure somewhere along the line.  See this TID, describing your iSCSI error:

http://support.novell.com/cgi-bin/search/searchtid.cgi?10098136.htm

Make sure it's communicating OK with the rest of the tree, especially the server that's the CA for the tree, that the PKIS components are all loading OK, the license is associated to the server (by the way, the license doesn't have to be installed ON the server, you just have to make sure the license object is associated TO the server - what you need at install time is >a< NICI encryption key, which you could conceivably get from any server license diskette) and so on.

Is it possible that the encryption key wasn't installed right, or wasn't the right strength (40-bit or 56-bit export rather than 128-bit domestic?)
0
 
mattpaulinAuthor Commented:
Hi ShineON, thanks again. After a night off, things seem clearer! There is a certificate prob. When I run PKIDIAG on the new server, pick option 4, then 6, get two errors;
error -603 creating SSL certificateIP
error -603 creating SSL certificateDNS
So I'm looking in the right area. Any thoughts?
Thanks
Matt
0
 
mattpaulinAuthor Commented:
Sorry, should have answerd yr questions as well

Did you use the same server name as before? Yes
Did you remove the server from eDirectory before reinstalling? Yes
Does this server hold a replica?  Yes
Is there more to the ISCSI error message besides the verbiage, like maybe an error code or reason code or some such? No, sorry.

Cheers
Matt
0
 
mattpaulinAuthor Commented:
OK, Just as well I had the night off. The -603 errors were caused as I had not deleted the old certs from Edir! Did that, ran PKIdiag, recreated the certs. Restarting the server as I write this. Hope all is OK now....
0
 
ShineOnCommented:
Actually, I did give "the answer" as it apparently was a certificate services issue.  Comment 16691773 has a link to a document describing the issue exactly, so even though my first comment was on track (recommending PKIDIAG, which is what the Asker did to fix the problem,) that comment had the "real" answer.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now