• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1424
  • Last Modified:

TS RDP won't load/install local printer. loaded drivers, enabled LPT redirect

I have 4 Windows 2003 servers used for Terminal services with load balancing.  I can't get a local printer on the RDP client show up in the remote session.  I am able to add it to my exchange server without any problems.  I have tried 2 different comptuers and printers and can't add it to the terminal servers, but can on the exchange server.

I have loaded the printer drivers on the server as you have to to get a client printer to show up.  I made sure they had on the client that the printer was enabled on RDP.  On the server, LPT port mapping is enabled.  I have checked the group policy and tried every combination and changed it back to get the printer would show up.  I have tried everything that microsoft has that I could find and on this website.  I am at a lost as to what is going on.  I have checked the registry even to find a hint.  

Any help is welcomed.
0
cknoderer
Asked:
cknoderer
  • 4
  • 4
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Sound like you have checked most everything.  

You will probably want to review this guide which can help you troubleshoot:

The Ultimate Guide to Terminal Server Printing
http://www.brianmadden.com/content/content.asp?ID=62

Jeff
TechSoEasy
0
 
bilbusCommented:
Is it a usb printer?

does it use a DOT4 port?

DOT 4 ports are harder to map, you need to enable all ports on the TS

http://support.microsoft.com/default.aspx?scid=kb;en-us;q302361
0
 
cknodererAuthor Commented:
Bilbus,

Thanks for the help, but, I had tried this one with no luck.  Even using a laserjet 6L doesn't show up on the TS clients.  It does on another server.  I am still looking into TechsoEasy's pointer.  Gotta love the busy life.  What makes it funnier, it's the CFO's home computer that is making it a higher 'priority'.  It does effect users though.
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You stated that LPT Port mapping is enabled, but what about Client Printer Redirection?  I think you should check that in your Terminal Server Properties as well as any group policy that may be applied.  You can check the GP's with gpresult command on the server.  

See http://technet2.microsoft.com/WindowsServer/en/Library/17d44d9a-cf4b-4a6a-94ec-093cb5f8b2b71033.mspx?mfr=true for all of the client settings.

Jeff
TechSoEasy
0
 
cknodererAuthor Commented:
I need to add another note.  The option to block the windows printer mapping has a check in it and grayed out.  I think this is the ultimate cause.  I looked to find where I could enable (reenable?) this or at least get the check out so that it can redirect.  The audio mapping is also grayed out and I can't get that option to show either.  The GP is not configured.  The registry settings are the same as the other servers on the domain.  I can't find anything on the internet that might be of reference.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
If this is grayed out on the USER properties, then you need to adjust it on the Terminal Server properties.  Open Administrative Tools > Terminal Services Configuration > Connections > RDP-TCP > Properties > Sessions TAB

Make sure that the Override boxes aren't checked... if you want individual settings, or leave them checked to keep managing from this level.  Then click on the Client Settings TAB to select what you need.

Jeff
TechSoEasy
0
 
cknodererAuthor Commented:
The grayed out stuff is on the terminal server properties itself.  I'm not sure on where to at least get the check out of the windows printer mapping.  I'm not worried about it being grayed out.  It's one of settings.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The next level up from there would be Remote Access Policies in RRAS.  You have to keep going up a level to figure out where it's being blocked.  You might find that easier to do in AD Sites & Services (I think that's where you'd find the delegation to Remote Access Policy).

Jeff
TechSoEasy
0
 
cknodererAuthor Commented:
I'll give it a try.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now