Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 463
  • Last Modified:

Input Out of Range When Booting Fedora 5

I have a PC with Fedora 5 on it.  When it boots, it appears that the screen resolution is too high for the monitor I'm using as vertical lines appear and a message appears stating "Input Out of Range".  I have a 15" NEC Flatscreen (LCD 1560V).  The system doesn't automatically change the resolution for me, so I'm not able to see the login screen to login to Fedora.

Is there a way to modify the resolution setting without booting into the operating system?
0
1albstrom1
Asked:
1albstrom1
  • 4
  • 3
  • 3
1 Solution
 
slow1000Commented:
You need to modify your /etc/X11/xorg.conf file, to use a different resolution or refresh rates.

You could do this by using a live cd, booting into text only mode, or similar workarounds. (your preference)

0
 
1albstrom1Author Commented:
How do I boot into text mode?
0
 
slow1000Commented:
If you use grub, at the boot screen, highlight the correct selection, then press 'e'.  This places Grub in the edit mode.  Three lines should appear.  Select the line that starts with kernel, press 'e' again, and add "linux 3" to the end of this line, then press enter.  Pressing "b" should then boot into text-only mode.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
nedvisCommented:
"...so I'm not able to see the login screen to login to Fedora...."

Let Fedora 5 boot ( even if you cannot see the boot process message and login screens) and get it to go until hard-disk acitivity stops - assuming Fedora has booted to the login screen).
Then press  Ctrl+Alt+1   keys to get the login screen in text mode.
Login as root ( I assume you remember root password) and type :
init 3    
in order to swich from Runlevel 5 to Runlevel 3
which  gives root access to text mode
from where you can reconfigure xorg ( video driver, screen resolution,monitor frequency,moyuse, keyboard etc.) by changing the   /etc/X11/xorg.conf  file.

Command to issue is:

xorgconfigure

which is xorg text based setup program usually located in /usr/X11/bin folder so you can type full path:
/usr/X11/bin/xorgconfigure
 as well.
Carefully read prompts and follow instructions displayed on the screen ( in text mode) and use conservative approach ( do not push to high when selecting display modes - select more realistic ones) to get to the point where you can finally boot Fedora 5 in full GUI ( Graphical user mode ) even with not best screen resolution, from where  you can then use other tools to tweak display setting further more by running system-config-display  from terminal linux console.

nedvis


 


0
 
1albstrom1Author Commented:
Unfortunately, none of these options have worked as I cannot get Fedora to boot into text mode.  Pressing Ctl-Alt-1 does nothing.  Adding Linux3 to the end of the kernel boot line did not work either -- it just boots normally - not into text mode.  
0
 
slow1000Commented:
nedvis meant Ctl-Alt-F1.  If you decide to append the option to the kernel boot line, it has to be "linux 3"  -- no caps, with a space, and no quotes.  If "linux 3" doesn't work, try "linux 1".  
0
 
1albstrom1Author Commented:
I was able to get to the text mode using Ctl-Alt-F1.  Now I cannot find xorgconfigure.  It is not in the /usr/X11/bin directory nor in any other that I can tell.  Is it supposed to be installed with the operating system or is it an add-on?
0
 
nedvisCommented:
Hi, 1albstrom1 ,
 I really appologize for misleading instructions: I forgot that Fedora Core 5 is using xorg v.7 and RedHat specific configuratuion scripts. (It horrible mistake, I'm sorry)
*****************************************************************************
 Here is what you can do to fix the monitor syncronisation problem.
 Boot as you did that before and press Ctl-Alt-F1  ( THANK YOU slow1000 for clarifying the keystroke sequence I've mistiped ). Once you get into text mode login screen login as root and type ( this is where I was wrong previously) :

              system-config-display    --reconfig

This will bring the basic 640 X 480 or 800X 600 pixels graphical screen with the tool you can use to choose correct video card/driver, monitor and screen resolution.
You'll hopefully be able to get at least very basic graphical UI .

nedvis


 
 
0
 
nedvisCommented:
   "Now I cannot find xorgconfigure.  It is not in the /usr/X11/bin directory nor in any other that I can tell.  Is it supposed to be installed with the operating system or is it an add-on?"
    Sure you were unable to find the file I've specified in one of my previous posts because Fedora ( as a RedHat's test-bed distro)  is using RedHat developed and maintained system configuration scripts , very often obuscating original (in this  case Xorg )  files, tools , default folder locations etc.
   That's why I gave you  misleading instructions ( at least they dont work on RH and Fedora) but they do their job very well on my Slackware based Vector Linux 5.1.1 SOHO.
   Provoket by your question ( I quoted in this post) I had to remove my Vector Linux hard-disk and to insert Fedora Core 5 hard-disk.  Once I booted in Fedora GUI  I  realised you were right so I had to dig deeper just to find what I wrote already strange Fedora's implementation of xorg ( as explained in chapter 21. X Window System (Graphics)  of Fedora Core Release Notes : http://fedora.redhat.com/docs/release-notes/fc5/release-notes-ISO/ )

  I'm sorry for bothering you with all these  explanations but I feel sorry for wasting your time by providing you with inacurate and misleading instructions.
   At least I learned something new.
  Sincerely
   nedvis
 
0
 
nedvisCommented:
                             Good news for you  1albstrom1
If you can get your Fedora system to boot in minimal/basic graphic mode ( with e.g. 640X480 or even better in 800X600 screen resolution)  there is and GUI tool you can find when you click on
                      KDE Start button  -->   System   -->    Display  menu
In Display Settings window  click on Hardware tab and then on Monitor type Configure button.
You can scroll down to NEC section and you will find your LCD monitor  listed besides other NED MultiSyncLCD 1560 series models ( with extensions  M , NX , V , V+ and VM ).
Once you select correct monitor tyope  Fedora's Xorg will give you more choices to select from ( screen resolutions, refresh rates, color depths etc ).

good luck
nedvis

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now