Redhat 9 (Shrike), vsftpd Can authenticate, but no write permissions

I can't figure out what happened to my ftp server

My users can authenticate, but they have no write permississions in there home directories.  They do have write permissions when telneting into the shell.

Any ideas?

James
XhalmanAsked:
Who is Participating?
 
DarthModCommented:
PAQed with points refunded (125)

DarthMod
Community Support Moderator
0
 
pablouruguayCommented:
che the umask in the vsftpd.conf
0
 
XhalmanAuthor Commented:
local_umask=022
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
pablouruguayCommented:
its ok.  but for in case rename this line.
0
 
m1tk4Commented:
check

write_enable

option. If you don't have it in your vsftpd config, add it with

write_enable=YES

since the default is NO. If it is there and set to yes, connect to your FTP using a command line client (ftp.exe on windows, for example) and try to PUT a file manually. See what the output is and post it here.
0
 
XhalmanAuthor Commented:
I changed to
local_umask=077

It works now.  Is this an alright setting?

write_enable=YES already, that was my first thought.

0
 
pablouruguayCommented:
yes. a test to do:

login with USER2 ancd try to write files in home of USER1
0
 
XhalmanAuthor Commented:
My mistake, that didn't solve the problem.

The problems was actually my ISA server.  By default it doesn't allow write access for FTP.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.