• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 992
  • Last Modified:

Linksys R042 VPN

Experts,

I am perplexed...

I have 2 remote locations (home office / remote office) and two linksys r042 VPN routers.  Now, after configuring the tunnel between the two routers, I am able to access ip addresses / printers from both locations, but can not access any domain resources (ie. join a domain, look at the share drive / view networked computers).  But when I put the computer back on the home network everything works fine...

It seems as though for some reason, I can do everything through the VPN tunnel, but domain resources / the ability to join the domain gets snuffed out.

Has anyone had a similar issue?

0
sailing42
Asked:
sailing42
  • 2
1 Solution
 
Rob WilliamsCommented:
A common problem with VPN's is NetBIOS names are not broadcast over the VPN, making many of the features you are referring to not available. There is a broadcast NetBIOS names option on the VPN configuration advanced section, but take note that this doesn't seem to work well and occasionally causes a few services not to work. You can however resolve a lot of nae issues using DNS, LMHosts files, WINS and so forth. Below is a list of options you may want to try, to see if you can resolve these issues. As for browsing Network Neighborhood, you will probably need a WINS server but all else should be "repairable"

NetBIOS name solutions and workarounds:
1) Use the IP address (of the computer you are connecting to) when connecting to devices such as;   \\123.123.123.123\ShareName   or map a drive at a  command prompt using  
 Net  Use  U:  \\123.123.123.123\ShareName
2) An option is to use the LMHosts file which creates a table of IP's and computer names. LMHosts is located in the Windows directory under c:\Windows (or WINNT)\System32\Drivers\Etc\LMHosts.sam , instructions are included within the file. Any line starting with # is just a comment and is ignored. Open the file with Notepad and add entries for your computers as below;
192.168.0.101      CompName       #PRE
Hit enter when each line is complete (important), then save the file without a file extension. To be sure there is no extension ,when saving enclose in quotations like "LMHosts". Now when you try to connect to a computer name it should find it as it will search the LMHosts file for the record before connecting.
More details regarding LMHosts file:
http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/windows/2000/server/reskit/en-us/cnet/cnfd_lmh_QXQQ.asp
The drawback of the LMHosts file is you have to maintain a static list of computernames and IP addresses. Also if the remote end uses DHCP assigned IP's it is not a feasible option. Thus in order to be able to use computer names dynamically try to enable with some of the following options:
3) if you have a WINS server add that to the network cards configuration
4) also under the WINS configuration on the network adapter make sure NetBIOS over TCP/IP is selected
5) try adding the remote DNS server to your local DNS servers in your network card's TCP/IP configuration
6) verify your router does not have a "block NetBIOS broadcast" option enabled (see note above regarding RV042)
7) test if you can connect with the full computer and domain name as  \\ComputerName.domain.local  If so, add the suffix DomainName.local to the DNS configuration of the virtual private adapter/connection [ right click virtual adapter | properties | TCP/IP properties | Advanced | DNS | "Append these DNS suffixes (in order)" | Add ]
0
 
rcasteelCommented:
There are several things that can cause this, but one of the most common is the name resolution issue.  If you are running w2k and newer, you should have a DNS server or two.  If you have multiple DNs servers, be sure the windows domain zones are set to replicate.  If this does not happen, you may not be able to resolve names that are dynamic.

If you are using legacy clients that use NetBIOS naming, you must use WINS and perform appropriate push/pull configurations if you have multiple DNS servers.

A common issue with VPNs is that both ends of the tunnel use the same subnet  i.e. 192.168.x.x .  You must properly subnet each end of the tunnel.  I do not think this is teh issue because other IP traffic seems to work for you.

You should not need LMHOSTS files if you use WINS.  You do not need WINS unless you are using older clients (NT4.0 and older)
0
 
sailing42Author Commented:
Updated the file on the computers and everything is working swimmingly!  -  Thanks a million
0
 
Rob WilliamsCommented:
Glad it worked out for you sailing42.
Thanks,
--Rob
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now