Anonymous Website Access....  User issues

Posted on 2006-05-16
Last Modified: 2008-02-26
I have a website running on windows server 2003.

I setup some ftp accounts for FTP access, and I gave them modify/read/execute permissions for the web directory.

I also have the typical IUSR_HOSTNAME user that is setup by default to handle anonymous web access

I also setup an InternetGuest Group and IGuest User

When i go into the directory security of my website (through IIS manager), It asks me which account to use for anonymous access.

If I input one of my FTP accounts, then my website is viewable.
If I input IUSR_HOSTNAME, the website is not viewable (401.1 error - invalid credentials)
If I input IGuest, the website is not viewable (401.1 error - invalid credentials)

Just for fun, I promoted IGuest - I went into windows explorer and set the directory security settings there to allow modify/read/execute for InternetGuest users.
So, from my point of view it looks like IGuest and FTPUSERS have the same 'security' settings for this folder (the web folder)

Through the Local Security Policy Settings, I verified that IGuests have network access -- funny thing -- FTPUSERS aren't listed.

Any tips on how I can get IUSR_HOSTNAME or IGuest to work for anonymous access? I don't like having to put my FTP users in there (who have modify access!)

Question by:oxygen_728
    LVL 23

    Accepted Solution


    If this doesn't work, your IUSR_Hostname account probably doesn't have the correct permissions. Go to the IIS admin tool and check to see where your default website points to (which directory), then go to this directory and see the permissions that are granted to the IUSR_Hostname account. They should at least be read... Try setting this permissions if not allready there..

    Else, your best option (if this is possible though) i to reinstall IIS, this will take a lot less time and all permissions will be set accordingly to the Microsoft standard..

    Author Comment


    The IUSR_Hostname has read/execute permissions in the home directory.

    Also, the IIS installation is fresh already...

    Thanks for your help, any other tips?


    Author Comment

    The answer to my question is:

    In my fresh installation of Windows Server 2003 SP1, It is necessary for the user to be used for anonymous website access to have a password. I had purposely setup that user to not have a password (blank). Setting a password fixes it.


    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Suggested Solutions

    I have never ceased to be amazed how many problems you can encounter on a fresh install of a Windows operating system.  This is certainly case in point& Unable to complete ANY MSI installation.  This means Windows Updates are failing and I can't …
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    25 Experts available now in Live!

    Get 1:1 Help Now