• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 622
  • Last Modified:

sendmail newbie - utterly lost !! -

hi

i'm seriously struggling with setting up a network at home - so much for ambition !!

i have a fedora core 5 box acting as a PDC with a RAID 1 array and am using mdadm to monitor the array

i need to send mdadm alerts via email but can't get it to work ............ here's the setup

PDC
static IP: 192.168.0.80
hostname: boomslang

i have a Smoothwall box (internal IP 192.168.0.1) which does DHCP for the rest of the network

to test the sendmail (which mdadm uses for the alerts) i use

echo "testing neill mail" | mail -s "testing" neill
(neill is a user on the PDC)

in /etc/aliases i have the entry
neill: sysadmin@myISP.com

sysadmin is set up as a mailbox at my ISP and i can send and receive fine from that mailbox (using t'bird from an XP machine)

when i run the sendmail test as root ithe PDC i get a 550 error as below: (email addresses edited)

***************************************************************

The original message was received at Tue, 16 May 2006 23:35:20 +0100
from localhost.localdomain [127.0.0.1]

   ----- The following addresses had permanent fatal errors -----
sysadmin@myISP.com
    (reason: 550-Verification failed for <root@localhost.localdomain>)
    (expanded from: <neill@localhost.localdomain>)

   ----- Transcript of session follows -----
... while talking to mx.core.plus.net.:

>>>>>> DATA

<<< 550-Verification failed for <root@localhost.localdomain>
<<< 550-REJECTED: Cannot route message
<<< 550 Sender verify failed
550 5.1.1 sysadmin@myISP.com... User unknown
<<< 503 valid RCPT command must precede DATA



Reporting-MTA: dns; localhost.localdomain
Received-From-MTA: DNS; localhost.localdomain
Arrival-Date: Tue, 16 May 2006 23:35:20 +0100

Final-Recipient: RFC822; neill@localhost.localdomain
X-Actual-Recipient: RFC822; sysadmin@myISP.com
Action: failed
Status: 5.1.1
Remote-MTA: DNS; mx.core.plus.net
Diagnostic-Code: SMTP; 550-Verification failed for <root@localhost.localdomain>
Last-Attempt-Date: Tue, 16 May 2006 23:35:20 +0100



Subject:
testing
From:
root <root@localhost.localdomain>
Date:
Tue, 16 May 2006 23:35:20 +0100
To:
neill@localhost.localdomain

testing neill mail

****************************************************************************

i get a similar error if i run the mdadm test command

mdadm --follow --scan --daemonise --delay=10 --test


this means zip to me !! ;(

i'm clearly missing something obvious but i've read some sendmail FAQs, docs and the like and am now simply more confused than ever

anyone able to help me out please ?

neill
0
babysnake
Asked:
babysnake
  • 2
1 Solution
 
babysnakeAuthor Commented:
ok

a long noght reading through the forums gives me this ....

my ISP cannot resolve root@localhost.localdomain ... fair enough

so it rejects the mail as 'unrouteable'

how do i get round this ?

(i accept i get the message, insofar as i get an error with the message attached, but aesthetics and education demand i fix this - or is it unfixable in this environment ?)
0
 
anfiCommented:
The remote host refuses to accept messages from sender without internet reachable domain [localhost.localdomain]. The check has been widely added as one of anti-spam prevention measures.

Make your hosts know and report its proper internet name.

http://www.sendmail.org/m4/whoami.html
0
 
babysnakeAuthor Commented:
thanks anfi

i'll try that
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now