• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 295
  • Last Modified:

No ping-2 routers and static routes-I give up!

Hello,
I am installing a new network and am testing it in my office before I actually deploy it.  I have 2 cisco 2621 routers (‘hub_router’ and ‘spoke1’) attached via T-1 crossover cable.   The ‘spoke1’ router has a cisco 2950 switch attached and a neoware linux thin client is attached to that.  All this is attached to a UNIX server.  The server is old, the LAN card is 10BASE2 to a hub and the router is connected there.

I can ping both routers and the thin client from the server.  From the thin client, I can ping both routers and the server.  From ‘hub_router’ I can ping the server and the thin client. The problem is that I cannot ping the server from the ‘spoke1’ router.  The thin client can’t start the application software until the server has been manually pinged.  I figure these last two pieces of information are related.

I haven't focused much on the unix server as it can ping the remote router (although not the serial link).  I also haven't focused on the switch as my guess is that the problem starts before the switch comes into the picture.

I am self-studying for my CCNA so understand if some of the configurations and subnets are not optimized - or if the solution is real obvious. There will be no internet connectivity so I haven’t focused much on security.  sh run, ip route and arp are shown below for both routers.  Let me know if you need anything else. Thank you in advance.

hub_router#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname hub_router
!
enable secret 5 $1$jidx$DDrfOP1IYW2h8VMEQ36RE.
enable password 7 03055F060F0170
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 description friday1
 ip address 128.222.1.221 255.255.0.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.1 255.0.0.0
 encapsulation ppp
!
interface FastEthernet0/1
 description Connection to Local LAN
 no ip address
 duplex auto
 speed auto
!
ip classless
ip route 172.16.0.0 255.255.0.0 10.0.0.2
no ip http server
!
!
line con 0
 transport input none
line aux 0
 modem InOut
 transport input all
 flowcontrol hardware
line vty 0 4
 password 7 0117070A5A5F541F2E45401D
 login
!
end

hub_router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
S    172.16.0.0/16 [1/0] via 10.0.0.2
C    128.222.0.0/16 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.2/32 is directly connected, Serial0/0
C       10.0.0.0/8 is directly connected, Serial0/0
hub_router#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  128.222.1.221           -   0004.dd82.2f60  ARPA   FastEthernet0/0
Internet  128.222.1.254           5   0800.1b20.8d4b  ARPA   FastEthernet0/0



spoke1#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname spoke1
!
boot system flash aaa0421.bin
enable secret 5 $1$5MXf$O/OFIYzqp0OhNAm6HD1001
!
memory-size iomem 15
ip subnet-zero
!
!
!
 !
 !
 !
 !
 interface FastEthernet0/0
 ip address 172.16.1.1 255.255.0.0
 no ip directed-broadcast
!
interface Serial0/0
 ip address 10.0.0.2 255.0.0.0
 no ip directed-broadcast
 encapsulation ppp
 service-module t1 clock source internal
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
!
ip classless
ip route 128.222.0.0 255.255.0.0 10.0.0.1
no ip http server
!
!
line con 0
 transport input none
line aux 0
 modem InOut
 transport input all
 speed 19200
 flowcontrol hardware
line vty 0 4
 password admin
 login
!
no scheduler allocate
end

spoke1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR, P - periodic downloaded static route
       T - traffic engineered route

Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0/0
S    128.222.0.0/16 [1/0] via 10.0.0.1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/8 is directly connected, Serial0/0
C       10.0.0.1/32 is directly connected, Serial0/0
spoke1#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.1.1              -   0030.194d.f3a0  ARPA   FastEthernet0/0
Internet  172.16.1.2             16   00e0.c556.5712  ARPA   FastEthernet0/0
spoke1#

0
wyatt3
Asked:
wyatt3
1 Solution
 
lrmooreCommented:
I think you simply need a static route on the server
network 172.16.0.0/16 --> 128.222.1.221
0
 
pjtemplinCommented:
Quote: The thin client can’t start the application software until the server has been manually pinged.  I figure these last two pieces of information are related.

Why can't a manual ping from the thin client be used to start the application software?

Does the server have a default route pointing to the address of hub router's Ethernet port?  If not, you should either add a default route, or a static route for 10/8 pointing to the address of hub router's Ethernet port.

When you ping the server from the router, the router creates the ICMP echo packet with a source address (by default) of the serial interface, which is in 10/8.  When the server receives it, it sends an ICMP echo reply packet to 10.0.0.2; if it doesn't know how/where to route this, the reply will fail.
0
 
wyatt3Author Commented:
Thank you to both who replied. The problem was corrected by adding a static route on the server to 10.0.0.2.

Prior to posting the question, I had entered a static route in the server to 172.16.1.2 (the switch).  The gateway for that was hub_router (128.222.1.221).

The thin client is set up to automatically start it's application software.  It still doesn't do that.  The first try to contact the server is unsuccessful, but the second one is.  Since the heart of the question I asked has been answered, I am accepting the answer.  I will work more on the switch configuration and post another question if I am unable to eliminate that problem.

Thank you again to both.  I am early in my network experience and it is nice to a source of such knowledgeable assistance!
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now