?
Solved

dell perc3 raid 1 primary disk failure now what?

Posted on 2006-05-17
17
Medium Priority
?
733 Views
Last Modified: 2007-12-19
Hi experts,
I have a dell workstation 530
perc3 set at raid 1
the primary disk failed so now the machine will not boot.
went into the perc utilitiy and saw that the primary has failed.
I don't have another drive to replace the dead one.
can I run off the mirrored drive until the new one arrives?
the mirror drive just has an offline option.
I can't take the dead one offline it just gives me online or rebuild.
I could in the utility remove the drive from the adapter and I assume
that it would take over? I don't see much on dells site on what to do
I have read on the boards here that once its replace it will automatically
rebuild which is checked but it going to be a couple of days till the replacment
drive arrives.
thanks again.
0
Comment
Question by:phishman1000
  • 8
  • 5
  • 2
  • +1
17 Comments
 
LVL 12

Expert Comment

by:fruhj
ID: 16704593
Are you sure it was at Raid 1?
the perc should auto failover to the backup drive without any intervention on your part.
Then when the new one arrives, just put it in and the perc will re-mirror.

So aside from replacing the drive as soon as possible, and hoping the other drive doesn't fail during that time, there isn't much to do.
0
 

Author Comment

by:phishman1000
ID: 16704864
according to the utlity its raid 1,

kind of weird tho' I thought maybe had to break the mirror first.
but in the perc util all it has is that disk0 has failed and disk 1
is online. The other thing I was thinking was to switch drives but I
didn't know if that was going to create more problems?
0
 
LVL 8

Expert Comment

by:dlongan
ID: 16705227
You should be able to swap drives around but ALWAYS label them before you move them.  You also may need to re-assign the scsi ID from 1 to 0 on the good drive.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
LVL 88

Expert Comment

by:rindi
ID: 16707006
Have you tried just removing the bad drive and then rebooting?
0
 

Author Comment

by:phishman1000
ID: 16709314
hey guys,
i'll give dlongan a try first,
thanks
0
 
LVL 12

Expert Comment

by:fruhj
ID: 16714984
Phishman,

  Is the machine functioning? If so - LEAVE IT ALONE!!!!
  Wait till you get the replacement drive, and put it in, then make sure it rebuilt ok.

  You might be able to swap drives, but I don't see that giving you any benefit at all, and if you do it wrong, you could loose everything.  It is not worth it.
   
0
 

Author Comment

by:phishman1000
ID: 16734915
fruhj,
nope the box is not functioning.
I'm just waiting for the drive to get here then I'm going to have the perc
rebuild the raid.
I just wanted to know if it could just run off the one drive and to ask someone with more
experience with them.
fortunatly I have most of the data on another drive it just had the OS and Apps on
the raid.
thanks everyone I'll let you know the outcome once I get the drive in which should be anyday now....LOL
phishman out
0
 
LVL 88

Expert Comment

by:rindi
ID: 16736443
Sure it should work with the other drive. just remove the bad one like I suggested earlier. There is no point in leaving the bad drive inside.
0
 

Author Comment

by:phishman1000
ID: 16746830
hey guys,
I might have screwed up.
installed new drive, then went into the perc webios.
it still saw the primary drive as failed the other drive was online.rebooted
saw that primary still failed and went into physical drive properties and checked online
which it did but did not give me the option to rebuild? the disk was degraded now back as
optimal. both drives on the adapter are online
so now when I boot it says primary disk not found
but 1 logical disk online, I'm I hosed?????
0
 

Author Comment

by:phishman1000
ID: 16747522
and update.
just did a consisty check and it failed tried to rebuild and it failed with the
new drive??? so now my guess is maybe hardware failure since the it is raid 1
it didn't reboot off the mirror drive.
so my thinking is bad PERC 3/DC card or bad cable?
0
 
LVL 8

Expert Comment

by:dlongan
ID: 16750042
phishman1000

When you installed the new drive, did you ensure all jumpers on the new drive were correct based on the old drive?

When you tried to boot off the secondary did you set the scsi ID to 0 on that drive?
0
 

Author Comment

by:phishman1000
ID: 16752273
dlongan,
well I did what you said and still no love.didn't see the jumpers on the underside of the drive...doh!
its and old dell 530 with a perc3/dc card my next guess is to
try upgrading the fimware on the perc card.
very frustrating but learning alot....lol
its weird on dells site they say the card is raid 0,
but in the webconfig its raid 1????? maybe they (dell) are right?
sorry for my newbness
0
 
LVL 8

Expert Comment

by:dlongan
ID: 16752455
So you tried to boot the secondary disk using scsi ID 0 and the primary disk disconnected?

FYI the PERC3/DC is OEM LSI MegaRAID Elite 1600

http://www.lsilogic.com/files/docs/marketing_docs/storage_stand_prod/raid/elite1600pb.pdf

It can handle RAID 0,1,3,5,10,30, and 50.

I am a little confused when you mention "webconfig" do you really mean using the bios configuration setup screen for the controller?
0
 

Author Comment

by:phishman1000
ID: 16753811
yes, the bios config on the controller.
weird just for sh!ts and giggles,
reboot with the recovery cd (xp pro) it sees the c: partition is there but unknown file system???
I put a new IDE HD hoping just to install the OS on it but it wants to delete the C: partition on the scsi
before I can continue....
I'm really at a lost now....
thanks for you help dlongan
0
 
LVL 8

Accepted Solution

by:
dlongan earned 2000 total points
ID: 16753939
Take the scsi hard drives out, in the system bios you will need to tell it to use the IDE controller as your boot controller and then boot with the xp disk and build your os on the IDE drive.

After you have the sys up on xp with IDE, you should then be able to connect the secondary drive up and see what's left of it.

The 530 I believe also has an integrated SCSI controller, you may want to to just us that to see whats on the secondary drive (after you install xp on the IDE)
0
 

Author Comment

by:phishman1000
ID: 16754063
yeah thats what I'm in the process of doing I have to get this box back online
thanks for everyone's help
I'll have to get back to it one of these days.....lol
phishman out!
0
 
LVL 8

Expert Comment

by:dlongan
ID: 16754355
good luck, hope it all works out.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Suggested Courses
Course of the Month13 days, 12 hours left to enroll

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question