• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 483
  • Last Modified:

3560 switch & 4506 switch

I have a 4506 switch that is configured with an IP address of 172.16.2.2.
Vlans have been created for Voice.  example vlan10001
Several host computers are connected to it and can talk to my network.

We also have a Motorola Vangard router set to 172.16.1.1

I have a 3560 switch that I want to configure with an IP address 172.16.2.15.
This switch will be setup to have several printers attached.

What will be the best solution to get this to work?

0
learn2earn
Asked:
learn2earn
  • 9
  • 9
1 Solution
 
Scotty_ciscoCommented:
I would trunk the VLANS between the 2 switches if you want voice and data on the 3560 if not just create the data VLAN to the 3560 and cross connect it to a port in the 4506 in the same data vlan.

Thanks
Scott
0
 
learn2earnAuthor Commented:
I have never setup a VLAN what commands should I write.
0
 
Scotty_ciscoCommented:
in which switch and what code are you running?  
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
learn2earnAuthor Commented:
In the 3560 ver 12.2 with 48 ports.. I want to set up Port 48 as my VLAN.
0
 
Scotty_ciscoCommented:
ok from the switch# type the following
vlan data
switch(vlan)# should come up
switch(vlan)# vlan XXX the vlan you want
switch(vlan)# exit

if it yells at you it is because the VTP is not setup properly if this is the case do the following

switch#show vtp status

if it says client then you can not add a vlan until you make it a server

switch#vlan data
switch(vlan)#vtp server

then follow the above rules

depending on what vlan the other IP address is on you may want to create a vlan interface

Thanks
Scott
0
 
learn2earnAuthor Commented:
This the confige from the 4506

HQSW-01#show vtp status
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 8
VTP Operating Mode              : Server
VTP Domain Name                 : ''
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x4F 0x84 0x88 0xB8 0xBD 0x1D 0x0E 0x09
Configuration last modified by 172.16.2.2 at 5-10-06 14:08:11
Local updater ID is 172.16.2.2 on interface Vl101 (lowest numbered VLAN interfac

I want to connect the 3560 to it.. I guess because it is setup as a Server.
0
 
Scotty_ciscoCommented:
The easiest way then is to turn the 3560 into client mode and trunk between the 2 switches.... This may be a bit nasty but follow the instructions I gave you previously on how to set the switch to  VTP server and set it to client and to a VTP domain "

That should put you in the same domain and it should listen to VTP info from the 4506.

What version of code is the 4506 running?

Thanks
scott
0
 
learn2earnAuthor Commented:
The 4506 is running Ver 12.2
0
 
learn2earnAuthor Commented:
I just configured this on the 3560.

Switch_Main#show interface fa0/48 switchport
Name: Fa0/48
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 101 (VLAN0101)
Trunking Native Mode VLAN: 101 (VLAN0101)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: 101
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
0
 
Scotty_ciscoCommented:
now when you do a show VLAN on the 3560 do you see the VLAN's that you want?  If so you are good.

Thanks
Scott
0
 
learn2earnAuthor Commented:
should I be able to ping between both switches?

If so I am not able to.

I am using a cross over cable between both switches.

I ran a show cdp neighbors and it can see the 4506 switch.

I can not ping from the 4506 either.
0
 
Scotty_ciscoCommented:
What vlan and IP is each switch? and when you go into the 3560 can you see the same vlan's that you see with the 4506?

Thanks
Scott
0
 
learn2earnAuthor Commented:
Yes I can see the Vlans that are set up on Both ( VLAN101 )

3560 172.16.2.15 255.255.0.0

4506 172.16.2.2 255.255.0.0

Should I use a straight-through cable to link to two ports up ?
0
 
Scotty_ciscoCommented:
No this should be a cross-over should be the only way that you get a link.

you should not have a problem pinging between the switch.

Thanks
Scott
0
 
learn2earnAuthor Commented:
3560 switch

Switch_Main1#
00:50:59: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEt
hernet0/48 (101), with HQSW-01.dcfcu.org GigabitEthernet2/45 (1).

Name: Fa0/48
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 101 (VLAN0101)
Trunking Native Mode VLAN: 101 (VLAN0101)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
0
 
Scotty_ciscoCommented:
I would assume your questioning the error message?

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t3/cdpadds.htm#26115

that will describe it best .... if you are trunking make sure that you have set the management VLAN native.

Thanks
Scott
0
 
learn2earnAuthor Commented:
I fixed the issue my self.

I had to assign an IP address to the VLAN. you did not tell me that.
Below is what I was looking for;however you have been a great help!!

3560 configurations

switch#vlan data
switch(vlan)#vlan 101
switch#config t
switch(config)#int vlan 101
switch(config-if)#ip addr 172.xx.xx.xx 255.255.0.0
switch(config-if)#no shut
switch(config-if)exit
switch(config)#int fa0/48
switch(config-if)#switchport mode access
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#switchport trunk allowed vlan 101
switch(config-if)#end
switch#show vlan
cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                             active     Fa0/2, Fa0/3, Fa04, Fa05
                                                          Fa0/6, Fa0/7, Fa08, Fa09
                                                          Fa0/10, Fa0/11, F0012
2    VLAN0101                         active    fa0/48
0
 
Scotty_ciscoCommented:
sorry about that .... sometimes I tend to assume certain things.  should have been more clear.

Thanks
Scott
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 9
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now