• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 561
  • Last Modified:

rpc over http on satellite

I have set up sbs 2003 with rpc over http yes service packs all applied.

1 particular member of the organisation uses all type of connections including satellite to connect.  This method of connecting to the exchange server is extreemly unreliable at best.  Most times the user can receive email, howver sending is out of the queston, I have set up a SMTP connection to get around this.  On a bad day you just cant make a connection long enough to get email.

I understand that satellite providers compress packets so VPN ans SSL tunnels just are not realistic so the qustion is

Is there a way to connect via RPC of HTTP not HTTPS (without the SSL) and if so would this solve my problem.

I am aware of the registry hack to turn off ssl in exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy
Add a new REG_DWORD called: AllowAnonymous
Set the value = 1 (Meaning Enabled)

However how do you tell outlook 2003 not to use ssl ?

Thanx

James.
0
jimby222
Asked:
jimby222
  • 2
  • 2
1 Solution
 
SembeeCommented:
There is supposed to be an article in the KB on how to set it - but I have never found it.

However I wouldn't dream of deploying the feature without SSL, certainly not on satellite. I have deployed RPC over HTTPS on a satellite connection and it has worked fine.

One thing you might want to think about is changing Outlook to work in the old fashioned way. Instead of cached mode, configure it to use offline folders and then set to do a send/receive every five minutes.

Simon.
0
 
jimby222Author Commented:
OK, I accept that I will have to stick with SSL.

I have turned cached mode off in outllok and set up offline folders.  Outlook now take a considerable amout of time to open as it look for the server before it connects.  Then has the same problem connecting to the server?

Is there more to be done ?

Thanx

James.
0
 
SembeeCommented:
Change the option so that Outlook starts offline. It should come up immediately.

Simon.
0
 
jimby222Author Commented:
Thank You Simon, in the end the answer was to get bigpond the satelite provider to remove the double nat on the sat configuration which didnt work for rpc over http until a vpn connection was made.  Defeating the purpose of rpc over http but a solution for the one location that this client goes to often.

Thanx

James
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now