Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 449
  • Last Modified:

Changing Subnet Mask

Okay here was my first post
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21703081.html

Right now we have a subnet of 255.255.255.0.  That includes all of or hardware and DHCP.  I was going to go the route that they said and change the subnet to 255.255.254.0 so I can have 192.168.0.1-192.168.1.254.  My DHCP will take the 192.168.0.1 range and my hardware will stay in the 192.168.1.1 range.  I know the only thing that I need to change for my hardware is there subnet to 255.255.254.0.  The question that I have at hand is how do I change my cisco switchs subnet.  

I have a few Cisco Catalyst 3500 series and I'm that used to setting these up.  I was just wondering what the command was when I telnet into the switch to change there subnet mask.

Also I have a Cisco PIX 506 that I was wondering if I would have to configure this for the new subnet.  I did not originaly set up the firewall and I have never messed around with it.  Honestly I'm more comfortable messing around with the switch then the firewall.

And if this whole situation is bonkers then give me a clue on what I should do.

One other thing is that we currently do not use any VLANs or routers in our network.  It is made up with all switches.
0
jwittkopf
Asked:
jwittkopf
  • 4
  • 3
  • 3
2 Solutions
 
SilentezCommented:
It depends of switch mode... If it works in simple layer 2 mode and have no ip address, so you don't need to change anything.
If it works as layer 3 mode, then you must change mask of all ip on switch.
Ip can be attached to VLAN or to port.

If it is attached to VLAN 1:
Switch>ena
Switch#conf t
Switch(conf)#int VLAN 1
Switch(conf-vlan)#no ip address <current ip> <current mask>
Switch(conf-vlan)#ip address <new ip> <new mask>
Switch(conf-vlan)#exit
Switch(conf)#exit
Switch#copy run start

If it is attached to port fastethernet 0/12:
Switch>ena
Switch#conf t
Switch(conf)#int fast 0/12
Switch(conf-vlan)#no ip address <current ip> <current mask>
Switch(conf-vlan)#ip address <new ip> <new mask>
Switch(conf-vlan)#exit
Switch(conf)#exit
Switch#copy run start
0
 
Keith AlabasterEnterprise ArchitectCommented:
The concept that has been suggested to you is fine as long as you do it across the board. You will likely also have servers with static addresses etc that do not use dhcp that will need manually changing.

On both the 506 and 3500 you will find entries for the internal interfaces.
For example, the 506 will have something like...
ip address inside 192.168.0.254 255.255.255.0
You will need to enter in the following changing the mask as you need it:
# conf t
# ip address inside 192.168.0.254 255.255.254.0

If your switches are managed devices via tcpip, you will also need to change their net masks as well

Regards
Keith
0
 
jwittkopfAuthor Commented:
To Silentez
I know our switches are manageable by means of IP address.  I don't know if this makes them layer 3 then or what.  As far as them set up as port or VLANs I don't really know for sure.  More than likely they just set an ip address to them and kept everything else as default on the switches.

To Keith
I relize that I'm going to need to change the mask on every static address that we have.  Thanks for the firewall command as I don't know hardly anything about a PIX.  

I'm just hoping this is going to go smooth for me.  I will be doing this project next saturday so I'm trying to get the most info on it as I can.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Keith AlabasterEnterprise ArchitectCommented:
Not sure where you are. I am on UK time and will be online most of Saturday so if necessary, just post and we can respond. No, this does not 'make' them layer 3; the IP address is just for the management. they MAY be layer 3 anyway of course :)

Cheers
keith
0
 
jwittkopfAuthor Commented:
I'm in the Midwest of USA...Central time.  But I won't be doing this until the 27 unless the Boss wants it done on the 20th.

Thanks,
Jeff
0
 
SilentezCommented:
@jwittkopf, try this:

Switch>ena
Switch#show run

This will give you your current config. So look it through and paste here part of config with your current IP address. It will help to determine where this ip configured.
0
 
jwittkopfAuthor Commented:
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 192.168.1.200 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.1.3
snmp-server engineID local 0000000902000006D736C740
snmp-server community private RW
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1


It looks like all of the ports are just default..if you need more of this config sheet I will post more of it
0
 
Keith AlabasterEnterprise ArchitectCommented:
Just standard config as you say
# conf t
# int vlan1
# ip address 192.168.1.200 255.255.254.0

# exit
# wr m
0
 
SilentezCommented:
@jwittkopf, you are using VLAN1, so just use my config for VLAN. :)
0
 
jwittkopfAuthor Commented:
Sorry been very busy to respond to this.  I'm still having issues on changing my subnet but i think I finally got to the bottom of it.  We have an AS/400 and that thing doesn't really like it when it has to change subnet masks.  I think this weekend I will finally be able to get everything going.  I'm going to split the points between the two of you.  Thanks for all the help this should go fairly well this weekend.

Jeff
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now