• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2979
  • Last Modified:

Removable Hard Drive not Showing Up. Help

I have a removable 120GB USB hard drive that I use to backup some of my data on my server that does not get backed up off site.  I have never had an issue untill today.  When the drive is plugged in it shows up in my computer with a red question mark on it.  When I go into Disk management handled by Dell Openmanage it shows Disk 1 Healthy Status Ready, Capacity 114 GB unalocated space 2.70 GB.  If I right click on that and go to properties is reconizes everything.  Now under disk 1 it shows New Volume Y, the status is healthy and unalocated space is 111.7 gb.  I made the drive letter Y and formated the drive using NTFS and left the name as New volume.  If I right click on this and go to properties it says filesystem unknown and free space 0 and used space 0.

I have marked the partition as active and formated it and changed the drive leter.  All won't allow the drive to be used.

Any ideas?
0
jamessa
Asked:
jamessa
  • 8
  • 3
  • 3
  • +1
1 Solution
 
jamessaAuthor Commented:
BTW, I just plugged in a removable thumb drive and the same thing is happening with it.
0
 
ISoulCommented:
Have you tried plugging it into different USB ports on the machine? Does the same thing happen?
0
 
jamessaAuthor Commented:
I have tried plugging it into all USB ports.  I may just need to reboot the server, but I can not do that till after hours.  I have never seen anything like this.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
PUNKYCommented:
Try plug in other system to make sure the usb drives are working properly?
0
 
jamessaAuthor Commented:
Drive works fine on my XP machine and another server.
0
 
PUNKYCommented:
Also, make sure your OS is up-to-dated service packs as well as the dell patches.
0
 
jamessaAuthor Commented:
OS is up to date.  I am not sure about Dell patches, but it has always worked and then just stopped.
0
 
ISoulCommented:
Yeah, it might just be one of those things that a simple reboot will fix. I would first try that after hours tonight and if that doesn't solve the problem, then continue troubleshooting from there.
0
 
jamessaAuthor Commented:
OK, I have rebooted and that did not work.   It is something with the server.  I plugged in my card reader and it is doing the same thing.  Do you think the USB drivers are corrupt?
0
 
PUNKYCommented:
OK. It is something wrong with USB ports .... chance you can reboot and get in BIOS see if it is enabled (just make sure). Then, if it is set in bios, you will need to re-install drivers for it.
0
 
jamessaAuthor Commented:
It is working.  I am waiting till after hours to reinstall drivers.  The Disk Manager sees and reconizes the removable drive.  It sees the space, can format it and all.  It even tell me the brand of the removable drive.
0
 
jamessaAuthor Commented:
When I say it is working I don't mean my problem is solved, just that the USB ports are not dead or disabled.
0
 
ISoulCommented:
When you go to the Device Manager, does everything show up as being fine?
0
 
nobusCommented:
here some things to try :
-in device manager, under view, click show hidden devices; then, delete ALL usb entries and reboot and test
-or this : navigate to :  HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
Delete All of the \DosDevices\ ... values corresponding to external usb drives/keys/thumbdrives etc
0
 
nobusCommented:
and if the problem is recent, you can try a system restore to a previous date
0
 
jamessaAuthor Commented:
OK, get this.  I wanted to see if the USB is hosed so I plugged in a USB mouse.  Worked fine.  Then I replaced the USB cable o nthe hard drive and BAM!  There is my drive!  I do not understand it whatso ever.  We were thinking it was the cable, BUT it worked fine on other computers and a card reader and a USB thumb drive was acting the same was.   WEIRD!
0
 
nobusCommented:
usb is not a very stable protocol - that's the answer . . .
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 8
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now