• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3196
  • Last Modified:

Activesync error: Your account does not have permission to sync

I am getting the above errordurig the connnection state on the device when I try to wirelessly sync using Activesync on a PPC.  It was working at one time - then I was messing around with permissions and IIS and can't figure out what I did!  Anyone have any insight?

Full error:
Your account does not have permission to sync with your current settings.  Contact your Microsoft Exchange Administrator.
An error occcured and scheduled snyuchronization had to be disabled.  Tos tart synchronizing on a schedule again, use the Mobile schedule tab in Activesync options.

Error code:  HTTP_403

Exchange2003 SP2
PPC2003

(SSL is not enabled at this time)
0
sruddock
Asked:
sruddock
  • 4
  • 3
2 Solutions
 
victornegriCommented:
Check  your IIS logs to see what your PPC is accessing and then check the permissions on that location. You may also need to make sure that the authentication methods you have activated in IIS coincide with what the PPC supports.
0
 
rentoncCommented:
Activesync can be disabled and enabled on a per user basis on the exchange server, usually it is enabled by default but you can check in exchange system manager - global settings - mobile services (i think this is the loation) to see if anything has chenged here.  
The error message doesnt look like an  IIS error as they are usually  http_500 errors from experience

hope this helps
0
 
sruddockAuthor Commented:
Thanks for your reply.  I have verified that Activesync is enabled globally.  
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
sruddockAuthor Commented:
fyi, authentication method is set to:
Enable Anonymous access and Integrate Windows Autentication.

In the IIS log file all i see is my username trying to access my inbox...I did notice that althought the server time is correct...the time reports in the log file are incorrect - could this be causing a problem?

(I have confirmed that this useraccount can access OWA fine)
0
 
victornegriCommented:
The IIS logs are probably using GMT. Could you post some of the IIS logs?
0
 
sruddockAuthor Commented:
I went ahead and uninstalled IIS as I am thinking that there was some corruption in my activesync virtual directories.  according to the MSFT documentation, when I reinstall IIS and reboot the server, the default virtual directories (Exchange, ExchWeb, Microsoft-Server-ActiveSync, OMA AND Public) should be recreated but they weren't.  So now I don't have any of these virtual directories!  

Any suggestions!?
0
 
sruddockAuthor Commented:
I successfully reinstalled IIS and unfortunately am still having the same problem.  When I look in the Event logs I see the following activesync error:

An error occurred while accessing the Active Directory for user [Internet Guest Account]. Information cannot be retrieved from Active Directory due to an unknown error. Verify that the Exchange ActiveSync Server can communicate with Active Directory, and that the user has a valid account

Not much info in there...anyone know how to investigate further or what to do next?
0
 
victornegriCommented:
You may want to reset the password on your IUSR_COMPUTERNAME account and retype it in IIS. You may want to set this user account as an AD User instead of a local user.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now