ORA-12514:TNS:listener does not currently know of service requested in connect descriptor

I had the install up and running months before my network was moved to a different location.  This is Oracle 10g Personal Edition, so of course it required a Loopback Adapter.  When I moved the ip address of my home network got shuffled around.  I had to diable the loopback adapter to get interenet service.  I have created another loopback adapter with an ip addres I believe to be free on my network.  

I am trying to use the SQL*Plus utility, and it gave this error: ORA-12514:TNS:listener does not currently know of service requested in connect descriptor.

In my services:

the tns listerner is started

My tnsnames.ora:
# tnsnames.ora Network Configuration File: C:\oracle10g\ora92\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

LMS =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = EMERALD)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = LMS)
    )
  )

CS335 =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = emerald)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = cs335)
    )
  )

EXTPROC_CONNECTION_DATA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    (CONNECT_DATA =
      (SID = PLSExtProc)
      (PRESENTATION = RO)
    )
  )


my listener.ora:
# listener.ora Network Configuration File: C:\oracle10g\ora92\network\admin\listener.ora
# Generated by Oracle configuration tools.

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = C:\oracle10g\ora92)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = EMERALD)(PORT = 1521))
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
  )

cpursley1979Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
actonwangCommented:
>>  I had to diable the loopback adapter to get interenet service.

      Why did you disable that? You don't need to, you can use loopback adapter while you use internet connection. look at this:

     http://blogs.msdn.com/virtual_pc_guy/archive/2005/10/04/477195.aspx

   1. On the host operating system go to 'Control Panel'
   2. Go to 'Network Connections'
   3. Right click on the network connection that you use for Internet connectivity and select 'Properties'
   4. Click on the 'Advanced' tab
   5. Check the option to 'Allow other network users to connect through this computer's Internet connection'
   6. If you have multiple network adapters you will need to also specify that you are sharing the Internet connection with the Microsoft Loopback Adapter.
   7. Click 'OK'

Acton
0
 
actonwangCommented:
bring your loopback adaptor back and enable the internet connectoin as above and you should be back to where you were.

Acton
0
 
paquicubaCommented:
You need to startup the instance, see below:

SQL> conn /as sysdba
Connected.
SQL> shutdown immediate
Database closed.
Database dismounted.
ORACLE instance shut down.


Try to connect to SQL*Plus:

ERROR:
ORA-12514: TNS:listener does not currently know of service requested in connect
descriptor


SQL> startup
ORACLE instance started.

Total System Global Area  167772160 bytes
Fixed Size                  1247876 bytes
Variable Size              79693180 bytes
Database Buffers           79691776 bytes
Redo Buffers                7139328 bytes
Database mounted.
Database opened.

Enter user-name: paqui
Enter password:

Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
With the Partitioning, OLAP and Data Mining options

PAQUI@PROD >   <<--------- I'm connected
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
cpursley1979Author Commented:
In the advance tab I set the ip address for the loopback adapter as 192.168.0.5 even though my computers ip is 192.168.0.1.3  Is this wrong?
0
 
actonwangCommented:
>>192.168.0.1.3
     ? is it 192.168.0.13

      look at the aritcle, if you are using xp, you might need to switch your home network to 192.168.1.xx or others
0
 
cpursley1979Author Commented:
I did what tose direction on the loopback adapter saidand I get a warning that my internet connection is intermitant
0
 
paquicubaCommented:
Is your instance up and running?

0
 
actonwangCommented:
you only turn the option on net work connecion you use for internet connection NOT on loopback adapter:


>>Right click on the network connection that you use for Internet connectivity
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
paquicubaCommented:
The loopback address must be updated here:

Add a line to the C:\windows\system32\drivers\etc\hosts file

IP_address   hostname

I.E.

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

180.15.10.128         123.mysite.com.
192.168.100.100      paquicuba.mysite.com.
0
 
actonwangCommented:
he could still keep the original loop back adaptor there ...
0
 
cpursley1979Author Commented:
You helped a bunch, solution was as you said to bring back the loop back adapter and change the right click on loopback adapter in Network Connections and goto properties > Configure > Advanced Tab > change the 'medium' to the item in the drop down box to ARCNET and give the item 'Network Address' a value outside the range on the router.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.