Windows 2003 DNS server is giving me an “Associated pointer (PTR) record cannot be created” error.

I have our web server on the same network as the workstations in the office.  I am using a local DNS Server(Windows 2003) so everyone in the office can access our website by adding mydomain.com and point it to internal server.  But when I go to add mail.mydomain.com and the mx records I get this error.  (The IP for mail.mydomain.com is not local)

“Associated pointer (PTR) record cannot be created, probably because the referenced reverse lookup zone cannot be found.”

I realize that this has to do with using a local DNS server and not a GLOBAL DNS Server.

My question is how do I go about adding mail.mydomain.com?


Thanks
Richard ComitoDirector of ITAsked:
Who is Participating?
 
Keith AlabasterEnterprise ArchitectCommented:
OK, so the Exchange server only sends therefore it does not need a local MX record. The MX record is for receiving emails only. This (the MX record) is being provided by your external DNS provider on the public internet.

This is one of the difficulties of having the internal domain names the same as the external domain name (as I am sure you are now painfully aware).

What you COULD try is to add an entry for mail.lastagealliance.com into the local hosts file on the Exchange server point ing it to the external address. As the hosts file is checked before dns, this may work for you.

Not sure if you would have to stop and start the exchange services (might even need a reboot) for it to kick in though
0
 
Jay_Jay70Commented:
Hi GabicusC,

do youa ctually have a rlz configured? i have seen it when there is no zone there

the record still gets created in the FLZ yes?
0
 
Richard ComitoDirector of ITAuthor Commented:
Jay_Jay70 thanks for your reply.

no I do not have an rlz configured for this zone.  With the flz I would get the error then yes it would create the host(a) but would not create the mx at all.  I get this error when trying to do the MX record "A new record can not be created.  Name is invalid"

Gabicus
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Jay_Jay70Commented:
you need to configure a reverse lookup zone for your domain
0
 
Richard ComitoDirector of ITAuthor Commented:
I am having trouble with the rlz.  This is what i have for the flz.

Zone is:
mydomain.com
then with in mydomain.com I have
Name                    type
mail                      host(a)  ip is to the outside
www                    host(a)  ip is internal
same as parent     SOA
same as parent     NS

I tried to set up a Primay zone in the rlz with:
mydomain.com
but i get an error that the zone already exsits.  I then try with mail.mydomain.com with no luck.

What am I doing wrong with the rlz?

Thanks again for you help,

Rich
0
 
Jay_Jay70Commented:
just right click on your current host records, and select create pointer, it should auto update your RLZ
0
 
Richard ComitoDirector of ITAuthor Commented:
I have put a pointer into the rlz internal Network Class for the mydomain.com with the full Name being mail.mydomain.com.  I also as able to put in the MX Records and the CNAME; however my Exchange server is still not sending out to mydomain.com addresses.  All other emails are going out fine.

I am not sure if I put everything in correct.  Is there a way to check and make sure that I have everything in properly?
0
 
Jay_Jay70Commented:
hmm i am not sure on the intricasies with exchange as i dont get to deal with ofiten - its all managed interstate

what happens when send your email? does it just fail?
0
 
Richard ComitoDirector of ITAuthor Commented:
Everything works fine when I send from my outlook.  But when I go to the Exchange sever and look at the que  I see all my emails are still sitting in the lastagealliance.com folder.  When I try a force connection it connects but nothing goes out.  All the other domains in the que have been going out with no problem.
0
 
Jay_Jay70Commented:
hmm let me see if i can get some additional help

0
 
Keith AlabasterEnterprise ArchitectCommented:
0
 
Jay_Jay70Commented:
you can try flushing your dns cache

ipconfig /flushdns
0
 
Keith AlabasterEnterprise ArchitectCommented:
Thats a good call.
On the dns server, open the dns service.
in the mmc, make sure you have checked the advanced view tab so that you see the dns cache entries
Clear this cache (there is an option in the menu)

How are you creating the reverse lookup zone?
0
 
Richard ComitoDirector of ITAuthor Commented:
Sorry for the delay.  I have had one of those days.

Jay_Jay70 and keith_alabaster,

I flushed the DNS and I am still holding everything in my exchange que for lastagealliance.com.

The DNS Report is mine.

As for the reverse lookup zone I did not create anything but the pointer.  There was a folder already there for my IP class "0.168.192.in-addr.arpa".  In this folder is where I created the new pointer by right clicking then selecting create new pointer.
0
 
Keith AlabasterEnterprise ArchitectCommented:
OK, thats cool. You want to point out the state of your external dns to whoever is looking after it for you though as this will not be helping your cause.

Can I ask why you want the MX record internally?
As your workstations aand the server are already on the domain, what are you expecting it to do for you?



0
 
Richard ComitoDirector of ITAuthor Commented:
Keith_alabaster,

Thanks for getting back to me.

I have an Exchange server on the same internal network with my workstation and web server.  I am using this Exchange server to send out on but not receive.  I am using a 3rd party company to receive all of my emails.  Everything is going out except emails going to lastagealliacne.com.  All of those are just sitting in the que and are not able to do a reverse look up because I have lastagealliance.com pointing to my internal DNS.  I have to have my Exchange server DNS pointing to the internal DNS because of the Active Directory.  I am not able to resolve mail.lastagealliance.com on the Internal DNS.   I have added a host(a) record to the flz for mail.lastagealliance.com with the proper outside IP. But it still did not work.  That is where the adding a ptr to rlz came in and is where I am at right now with trouble shooting this issue.
0
 
Richard ComitoDirector of ITAuthor Commented:
this line should read:

 All of those are just sitting in the que and are not able to do a reverse look up because I have lastagealliance.com in my internal DNS.
0
 
Richard ComitoDirector of ITAuthor Commented:
Keith_alabaster,


Yes you are right very painful.  I will try what you suggested.  For now I am off to the Mountians with my kids.  I will let you know on sunday how it goes with the server.

Thanks again for your help.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Sure. Have a good weekend, I'll be here

regards
Keith
0
 
Richard ComitoDirector of ITAuthor Commented:
Keith,

I finally have had a chance to get back to this. I assume I need to add the information to the LMHOSTS.SAM file.

This is what I entered then I rebooted.

64.202.165.92      mail.lastagealliance.com

is this the correct format?

Rich
0
 
Keith AlabasterEnterprise ArchitectCommented:
No, the lmhosts.sam is actually a sample (example) copy of the lmhosts file. This is used for netbios type lookups such as those performed by a WINS server. If that were the file to be edited, you would then sabe it just as lmhosts.

What we need to do is use the file just called hosts  
Make sure you do not save it with any extension such as .sam, or .txt

The syntax you have used is perfect.
0
 
Richard ComitoDirector of ITAuthor Commented:
Unfortunately that did not work.  I not sure what option I have left.
0
 
Keith AlabasterEnterprise ArchitectCommented:
on the box, if you type in nslookup mail.lastagealliance.com what do you now get?
0
 
Richard ComitoDirector of ITAuthor Commented:
I get:

Server:     lasa-serv1.lasa.com
Address:   192.168.0.50

Name:      mail.lastagealliance.com
Address:   64.202.165.92

I did this on a server that is named lasa-serv3 and not lasa-serv1 like what is named in the results of nslookup.
0
 
Keith AlabasterEnterprise ArchitectCommented:
No, that is fine. The results are simply telling you that lasa-ser3 asked lasa-serv1 to get the results.

Is lasa-serv3 the email server that is having the problem?
0
 
Richard ComitoDirector of ITAuthor Commented:
Keith,

Yes lasa-serv3 is my Exchange server.  But I have found some other issue on this journey that I have undertaken.

I brought in a friend to help me and at this point it has become clear that I have some legacy issue that are messing up my network beyond my exchange server.  The main issue being that my internal domain lasa.com and is a domain that we do not own.  So when we did an nslookup from outside on mail.lastageallaicne.org we see that the full name coming back was mail.lastagealliance.com.lasa.com and would point to a server I do not have control over.  I am now faced with the joy of renaming my internal domain to lastageallince.com from lasa.com.  Because this is a new issue I am going to open up a new question.

I am going to split the point between you and jay_jay70.  jay_jay70 answered the first part of the question and you helped me out with the rest.  I thank you both for all your help.

Rich
0
 
Jay_Jay70Commented:
Thankyou Rich, although you forgot to split the points with Keith :)

you can post a question in community support asking for it to be reopened so that you can split the points, either that or Keith may be able to as Page Editor

good look with your project
0
 
Richard ComitoDirector of ITAuthor Commented:
Keith,

I am so sorry I just hit the wrong link and did not hit the split points link.  Do know if there is a way I can change it so that I can split the points?

If not, I apologize because you have been a very big help to me.

Rich
0
 
Keith AlabasterEnterprise ArchitectCommented:
Yes, I have the tools to reopen the question although I wouldn't do it here.

Thanks
keith
0
 
Keith AlabasterEnterprise ArchitectCommented:
OK, thank you.

As I was involved in the call, it wouldn'thave been right if I had unaccepted the answer even though you suggested it. It is appreciated.

Regards
keith
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.