• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2240
  • Last Modified:

Can't Upload To FTP SERVER?!?

I'm setting up FTP on a local box here, and everything works great except it can't be uploaded to!  


I'm using filezilla server, and it's behind a NAT'ing firewall. It doesn't matter whether I'm in active or passive mode. No matter what, when trying to upload, it says "Error 550 Requested Action Not Taken"


0
Brandon81
Asked:
Brandon81
  • 4
  • 3
  • 3
  • +2
3 Solutions
 
carl_legereCommented:
you have to tell the software to use a fixed set of ports for data, usually 10000-10100 and then forward that range trough the router IN ADDITION to port 21 udp.
then clients who are behind nat themselves will need to use pasv
0
 
centrepcCommented:
carl seems to really know what he is talking about by his levels of expertise but everytime I setup ftp servers behind a firewall I need to forward ports 20 and 21 tcp.  When only 21 is forwarded it works fine in passive mode but If not in passive you get the error 550 when 20 is not forwarded.  

This is using IIS FTP so maybe filezilla is different.  I would think all ftp servers would be the same just for compatibilty reasons.  


These are the commands in my cisco router to forward the ports to my server
ip nat inside source static tcp 192.168.x.xx 21 65.119.19x.xx 21 extendable
ip nat inside source static tcp 192.168.x.xx 20 65.119.19x.xx 20 extendable
0
 
carl_legereCommented:
I just hate setting up FTP, clients can't talk me into it these days.  I use secure web upload or WEBDAV possibly.
You may have better luck than me!
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
centrepcCommented:
Are you able to download files.  You may also want to check the folder persmissions and the permissions in the ftp server and make sure the user have write access
0
 
scrathcyboyCommented:
remove the firezilla -- it has to be interfering in the port 25 FTP transfer.  

Get it out and test it without that firewall.  Why are you running a frewall on FTP?
That does NOT make any sense at all, an FTP server must be free of port 25 + restrictions.
0
 
cwilluCommented:
I'd double check that filezilla is set up to allow uploads;  I recall the permissions being a bit finicky, and uploads are definately blocked out of the box.
0
 
Brandon81Author Commented:
Ports 4000-5000 are forwarded in the firebox firewall and hard-set in filezilla for the passive ftp ports. Also ports 20-21 are forwarded in the firewall.

I've tried using the filezilla and IIS FTP, both show the same problem even while logged in as admin, so I'm assuming this is a firewall issue? The upload permissions for write access are definately set.








0
 
cwilluCommented:
Dumb question, but can you check that:

 - You can upload from the same box as is running the server (i.e., ftp localhost)
 - You can upload from another box on the same network as the server (not over nat)
0
 
centrepcCommented:
What router/firewall do you have.  They are known bugs with many linksys, and even cisco routers regarding ftp,  you made need to apply a new firmware or patch to an IOS,  

Sometimes on the linksys you need to enable port triggering for the same ports that are being forwarded.  

0
 
Brandon81Author Commented:
Great suggestion trying it from inside the network.


-  It worked perfectly from inside on another PC


The router/firewall is a Watchguard Firebox III.  I'm hating this thing it makes my life so much more complicated.
0
 
Brandon81Author Commented:
Freaking A.


I had to call Watchguard support and there was a stupid-ass checkbox deep within the settings that by default was making ftp sessions read-only.

0
 
Brandon81Author Commented:

Can I split points to cwillu centrepc and Carl legere/?
0
 
carl_legereCommented:
"making ftp sessions read-only."
that has to be the dumbest router setting there is.  Indeed I hate the overly complicated firewalls, prefer Cisco where life is just about as simple or complex as YOU make it.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now