• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 454
  • Last Modified:

Router & Hub problems

Hi,

One of my clients has a Zyxel ADSL modem/router and, until today, had a Netgear wireless access point plugged into one of the LAN ports of the modem router which served 3 PCs. There is also another computer which is wired directly to the modem/router.

Due to the nature of their business they had a lot of interference on wireless network and have decided to go for a more stable wired connection. So they replaced the Netgear wireless access point with a 3com 5 port hub.

Now all PCs, except the one directly connected to the router/modem, say "Limited Or No Connectivity" for the wired NIC card.

When the PCs are swapped (one the three problem ones with the one directly connect to the modem/router) each of them work, indicating the problem is the hub...?

I have tested all of the cables and all are fine.

All of the lights flash on the hub and would appear NOT to be faulty.

I have ran all the usual network troubleshooting methods, is it likely to be a problem with the configuration of the router/modem and the hub or is it more likely the hub is faulty?

If anyone could shed any light on this I would be very grateful.
0
sam_norian
Asked:
sam_norian
  • 9
  • 4
  • 2
  • +3
3 Solutions
 
dutchclanCommented:
does the new switch have a "DHCP" running?

Usually the "limited or no connection" pops up when there is no "IP" configured for the NIC.

On the "Netgear Wireless Access Point" im sure it has a build in DHCP server. Wich actually configures all the machines given the config in that Accesspoint. On the 3Com im not so sure.

Please check if it has its buildin DHCP server if so Enable and configure it..

Else configure the machines manually...

-regards
Chris
0
 
brakk0Commented:
What if you plug the uplink port of the hub into the port the working computer is connected to. Then connect all 4 computers to the hub.

I assume the hub has an uplink port? If not, are you using a crossover cable to connect it to the router?
0
 
sam_norianAuthor Commented:
dutchclan, there is no mention of a DHCP server, so I assume not.

brakk0, very good point I will check they are using a crossover cable as there is no uplink port on this hub.

I will try both suggestions and come back tomorrow.

Thanks very much.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
pyroman1Commented:
One other thing to check.  When they were using wireless the router was not seeing the other computers MAC addresses, it wasonly seeing the WAP.  If MAC address filtering was turned on at the router then those computers may connect but will not be assigned an IP address.
0
 
mikebernhardtCommented:
I would agree that the DHCP is the problem, except that any PC connected directly to the Zyxel seems to work.

Run ipconfig /all on the PC that's directly connected to the Zyxel. Does it have a private IP or a public one? If it's public then DHCP is being provided by the ISP, not the router. If it's private then the Zyxel is already providing DHCP.

So if it's private, the likely problem is the connection between the hub and the router (crossover cable?). If it's public, then the router is not doing NAT and it's passing the DHCP requests to the ISP. The others would then be failing because the ISP won't assign them addresses. In that case you need another router that does DHCP and NAT.
0
 
sam_norianAuthor Commented:
Pyroman, please could you elaborate slighty, I think this may be a possibility.

mikebernhardt, The router is definately providing the IP addresseses.

I am now all most certain they have used a straight cable (or hub without uplink).

Thank you for all of your suggestions, I shall look into them when I visit the client tomorrow and post my feedback.
0
 
dutchclanCommented:
> dutchclan, there is no mention of a DHCP server, so I assume not.

It was just a suggestion in an effort to help you out thats all ;-). And rather check then assume, assumptions are tricky..

Its so easy "overlooking" something, so if not the case scrap it from the possibilities list :D

Regards, Chris
0
 
sam_norianAuthor Commented:
Hi,

dutchclan, I have looked further into this and it is only the the router/modem that has the DHCP, thanks for the suggestion though.

I have have now checked (and replaced) the cable between the router/modem and the hub and it is definately crossover.

I am now completely stuck for clues!
0
 
naveedbCommented:
"When the PCs are swapped (one the three problem ones with the one directly connect to the modem/router) each of them work, indicating the problem is the hub...?"

Can you use different port on hub and router to connect? Can you replace the hub? See if you can get one which has the option to autodetect straight/crossover configuration to test.
0
 
sam_norianAuthor Commented:
I have now replaced the hub (and tried all ports on both the router/modem and hub)...and still no joy!
0
 
naveedbCommented:
Lets start from the beginning; This is your configuration:

DSLLINE-->MODEM/ROUTER -- HUB -- PC2, PC3, PC4
                                   \--> PC1

PC1 works fine, PC2-4 don't unless you connect them directly where PC1 is currently connected, correct?

What is your internal subnet, assuming it is 192.168.1.0 and PC1 is 192.168.1.2, can you assgn PC2-4 192.168.1.2-4 and see if you can ping each other?
0
 
sam_norianAuthor Commented:
naveedb,

Yes this is all correct.

The internal subnet is 192.168.1.1, the DCHP pool starts from 192.168.1.30 and is limited to 30.

The working PC (the one plugged into the modem/router) is always given 192.168.1.33.

When trying to manually assign an IP addresses to PC2-4 Windows shows the message "IP address already in use", I have tried IPs from 192.168.1.30 up 40 and have received the same message everytime!

There is no other equipment/PCs connected other than that stated so I cannot understand why the DHCP is refusing the IP addresses.
0
 
naveedbCommented:
Interesting, can you disable DHCP on the MODEM/ROUTER and try again with static IP Addresses? I am wondering if there is something wrong with Leasing options.
0
 
sam_norianAuthor Commented:
naveedb, I am unsure if you are able to disable the DHCP on the router, I will check and report back.
0
 
sam_norianAuthor Commented:
Before the change of equipment PCs 2-4 were sharing files and a printer-, even though the connection still has "limited or no connectivity" they are still able to share files and the printer.

0
 
sam_norianAuthor Commented:
I have disabled DHCP and assigned all addresses manually but still no joy!
0
 
pyroman1Commented:
Sorry about the delay, I wasn't checking this forum over the weekend.

You requested I elaborate on the MAC filtering.  First, I reread your original post and the posts since and have come to see that this cannot be the case as you are able to use the other PCs if they are connected directly to the modem/router.  MAC filtering would simply stop the other computers from receiving an IP address or using the netowrk unless their MAC address was on the approved list.  You can sometimes see this option on routers under an advanced tab.

Let me make sure I am understanding you correctly.  When you had DHCP enabled all computers received an IP address in the form 192.168.1.X?  But only the computer connected directly to the modem/router was able to connect to the Internet?
0
 
naveedbCommented:
When you enabled manual IP Addresses, were they able to ping each other?
0
 
sam_norianAuthor Commented:
pyroman1, Only the PC directly connected was allocated an IP, all the other PCs had no IP address at all (not even an automatic private address).

naveedb, I did not get a chance to check this as I have now fixed the problem;

I disabled the DHCP on the modem/router and restarted all the equipment then re-enabled/configured the DHCP and it now works perfectly!

Thank you all very much for all your help.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 9
  • 4
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now