Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

PPTP Client through PIX 515

Posted on 2006-05-19
2
Medium Priority
?
485 Views
Last Modified: 2013-11-16
I have a few users that work at my location 2 - 3 days a week and need to access their company's VPN while they are here (behind a PIX 515 running v6.3(3)).  I used to use 1-1 IP mapping with ACLs enabling PPTP and gre which worked just fine, but over the past month we have had a few more users added to the mix that need the same access to their company's VPN, and with a limited number of external IP addresses, I was looking for a better way to accomplish this.  I did some reading and found that we didnt have the fixup protocol pptp 1723 enabled, but I am still not having any luck connecting to their company's VPN.  The client establishes the initial connection but it will not verify the password.  I have posted my config below.  Any help would be greatly appreciated.

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password **************** encrypted
passwd **************** encrypted
hostname hd
domain-name hd.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.YYY.0 HDW
name 64.204.61.141 SCSCServer
name 192.168.XXX.7 TS1
name 207.68.230.52 EXT_VPN_2
name 207.68.230.53 EXT_VPN_1
name 192.168.XXX.177 DT
access-list inside_outbound_nat0_acl permit ip any 192.168.XXX.224 255.255.255.224
access-list inside_outbound_nat0_acl permit ip 192.168.XXX.0 255.255.255.0 HDW 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.XXX.224 255.255.255.224
access-list outside_cryptomap_20 permit ip 192.168.XXX.0 255.255.255.0 HDW 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap warnings
logging facility 16
logging device-id hostname
logging host inside 192.168.XXX.3
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 61.103.92.61 255.255.255.240
ip address inside 192.168.XXX.253 255.255.255.0
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN1 192.168.XXX.250-192.168.XXX.251
ip local pool VPN 192.168.XXX.244-192.168.XXX.249
pdm location 192.168.XXX.0 255.255.255.0 inside
pdm location 192.168.XXX.10 255.255.255.255 inside
pdm location TS1 255.255.255.255 inside
pdm location 192.168.XXX.0 255.255.255.0 outside
pdm location HDW 255.255.255.0 outside
pdm location SCServer 255.255.255.255 outside
pdm location 192.168.XXX.224 255.255.255.224 outside
pdm location 192.168.XXX.3 255.255.255.255 inside
pdm location EXT_VPN_1 255.255.255.255 outside
pdm location EXT_VPN_2 255.255.255.255 outside
pdm location DT 255.255.255.255 inside
pdm location 192.168.XXX.239 255.255.255.255 inside
pdm logging warnings 100
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 61.103.92.49 192.168.XXX.10 netmask 255.255.255.255 0 0
static (inside,outside) 61.103.92.51 TS1 netmask 255.255.255.255 0 0
static (inside,outside) 61.103.92.53 DT netmask 255.255.255.255 0 0
conduit permit icmp any any
conduit permit tcp host 61.103.92.49 eq www any
conduit permit tcp host 61.103.92.49 eq smtp any
conduit permit tcp host 61.103.92.51 eq 3389 any
conduit deny tcp any eq 8594 any
conduit deny udp any eq 8594 any
conduit permit gre any host EXT_VPN_1
conduit permit gre any host EXT_VPN_2
outbound   1 deny 0.0.0.0 0.0.0.0 9996 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 9996 udp
outbound   1 deny 0.0.0.0 0.0.0.0 5554 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 5554 udp
outbound   1 deny 0.0.0.0 0.0.0.0 4444 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 4444 udp
outbound   1 deny 0.0.0.0 0.0.0.0 5190 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 5190 udp
outbound   1 deny 0.0.0.0 0.0.0.0 1863 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 1863 udp
outbound   1 deny 0.0.0.0 0.0.0.0 5050 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 5050 udp
outbound   1 deny 0.0.0.0 0.0.0.0 5101 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 5101 udp
outbound   1 deny 0.0.0.0 0.0.0.0 1234 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 1080 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 1080 udp
outbound   1 deny 0.0.0.0 0.0.0.0 1234 udp
outbound   1 deny 0.0.0.0 0.0.0.0 6667 tcp
outbound   1 deny 0.0.0.0 0.0.0.0 6667 udp
apply (inside) 1 outgoing_src
route outside 0.0.0.0 0.0.0.0 61.103.92.62 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.XXX.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.XXX.3 PIX.cfg
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 64.232.223.82
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 64.232.223.82 netmask 255.255.255.255 no-xauth no-config-mode
isakmp keepalive 10
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup test address-pool VPN
vpngroup test dns-server 192.168.XXX.6 192.168.XXX.22
vpngroup test default-domain hd.loc
vpngroup test backup-server 192.168.XXX.6 192.168.XXX.22
vpngroup test idle-time 1800
vpngroup test password ********
vpngroup Admin address-pool VPN1
vpngroup Admin dns-server 192.168.XXX.6 192.168.XXX.22
vpngroup Admin default-domain hd.loc
vpngroup Admin backup-server 192.168.XXX.6 192.168.XXX.22
vpngroup Admin idle-time 1800
vpngroup Admin password ********
telnet 192.168.XXX.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:******************************
: end
[OK]
0
Comment
Question by:hdutton
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 16719353
>PIX Version 6.3(3)
>fixup protocol pptp 1723

The fixup is supposed to let internal users access external servers via PPTP, but there is a flaw in the fixup that is fixed in 6.3(4) and the latest 6.3(5)
0
 

Author Comment

by:hdutton
ID: 16741738
Thanks for the quick reply, we are currently out of warranty, I am working on renewing our warranty and then I will upgrade from version 6.3(3) to 6.3(5).  I will post back with the results.  Thanks again.
0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses
Course of the Month12 days, 8 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question