• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1557
  • Last Modified:

Getting "The print spooler service is not running" Win2k3 domain, XP Boxes

Server:
Windows 2003 AD, Exchange 2003, Symantec Ent. 10, Backup Exec 10, Print Server.  PLENTY OF HDD SPACE, PLENTY OF RAM.
Workstations:
HP Notebook nx6125 Win XP Pro, fully updated through Microsoft Updates, 1GB RAM, Plenty of Hard Drive space.
HP L2000 WinXP Pro, fully updated, 1GB RAM, Plenty of HDD space.
Users:
All 'Domain Users'
Network:
Gigabit network, CAT6, 4 3COM 3870 Switches Stacked.
In-house users = approx 55
DHCP, DNS
Printers:
2 Konica-Minolta CF3102 with Fiery
2-HP1100, HP1200, HP1300, Lexmark C522, & an unplugged HP4500 (Printer still installed in server)

Problem:  
I have a couple of users who when they print the computer sometimes seems to print but nothing comes out of the printer and sometimes they get an dialog box that states "Your file could not be printed due to an error on \\10.10.1.20\Bizhub CF3102 Second Floor on Ne02:.  There are several possible reasons:"
Checked the spooling service and it is still running.  Starting and stopping service does not help.  Right clicking on the printer under Printers & Faxes gives an error messages that states "The print spooler service is not running".
When this occors I can also no log into that server from that workstation.  If I click on Start -> Run -> \\servername it prompts for a username and password (which it shoudln't do).  At that point I can't log in as the user or as the administrator as it just bounces the box back as if there is an authentication error.
A reboot doesn;t work.

If I could assign 5000 points to this one I would.  
0
Indy_IT_Admin
Asked:
Indy_IT_Admin
1 Solution
 
Joseph HornseyPresident and JanitorCommented:

Well, I know that you say that you have plenty of HDD space on the server, but I'd recommend double-checking HDD space on C:\.  Network print jobs are stored on the print server's hard drive at %SystemRoot%\System32\Spool.  If the hard drive fills up, the print server won't rpint jobs.

Here are other things I would try:

1. Completely uninstall the printer from the server (including the driver).
2. Reinstall the printer, but do not share it.
3. Test your printing from the server.
4. If all's well, share it out to the network again.

Post back with results.

<-=+=->
0
 
IsigowCommented:
You may also want to check and see if it is always a certain application or set of applications that they have trouble printing too. We tried using the HP 2700 series here and when it was printed to from certain applications it would cause similar issues to what you described here, but all the way up to crashing the print spooler on the machine, the server or both. HP's response was that the printer we were using was not classified to print that type of information (PS vs PCL) and we should look into purchasing a different print in order to fix the problem.

Isi
0
 
Indy_IT_AdminAuthor Commented:
HHD on C:/ is 36GB
Others can still print when the couple of users cannot.

Couple of questions before I go and do something this drastic:
I have over 50 users that use the shared printer in the exact same way and have no problems what so ever.  If I log on as a different user I can print and access the domain controller with no issues.  I have double checked permissions and the only group they have in common is Domain Users which everyone has.  They are all local admins on their WinXP Pro notebook.
I don't think it is in the printer, I think it is in the authentication with the domain since I loose the ability to connect with the server.
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
Indy_IT_AdminAuthor Commented:
It is all apps.  Can't even go into printer properties.  That is when I get the "Printer spooling service is not running" error.
I don't think it is truly a spooler issue.  I think it is a domain authentication issue but I don;t know where to start.  I have checked the Event Viewer on the DC and have had no luck finding any errors related in any way to this.
0
 
Joseph HornseyPresident and JanitorCommented:

Sorry - didn't notice that it was specific to a handful of users.

Have you tried completely uninstalling and reinstalling the printer from their machines?

Also, I had a user running into a similar problem yesterday.  It was due to CPU usage being near 100% due to some spyware.

<-=+=->
0
 
Indy_IT_AdminAuthor Commented:
Will check into spyware though I dont think this is it because it is happening with a newly installed unit.

Can uninstall printer but can't get back to domain/print server on network to install printer again.  Just get authentication dialog box and cannot log in as user, myself, or administrator.  Almost like it forgets how to get to that server.  Can still get to other server on network.  Also, I don;t think I would get authentication box if it couldn't see the server.  It has to find the server, present credientials, and then when creds are not okay, server requests them and authentication box shoud pop up.  At least thats what I learned in Kindergarten.  lol
0
 
Joseph HornseyPresident and JanitorCommented:

Check your Event Log (especially the System Log).  Look for errors regarding "trusted connection", "COMPUTERNAME$", or similar things.  Look for these on the server as well as on the client (on the server, it may be in the Active Directory logs).  I bet that the trusted connection is corrupted.  If you see those errors, joing the client to a workgroup and then go to the server (in Active Directory Users & Computers) and reset the client computer account (right-click on account and select "Reset" or whatever) and then join the client back to the domain.

See if this fixes it.

<-=+=->
0
 
cschipperCommented:
try to delete the printer with the kyocera printer deleter which completely removes the printer drivers in the spooler directory and registry settings and reinstall it.

http://amistad.kyocera.co.uk/pages/info/kdl/utilities.asp?Mode=Query&Type=Driver%20Deleter%20Utility

0
 
scrathcyboyCommented:
support.microsoft.com/?kbid=314876
lpr.brooksnet.com/printingspooler.html
members.shaw.ca/bsanders/FAQPrinting.htm
http://support.microsoft.com/kb/158042/EN-US/
http://support.microsoft.com/kb/308028/EN-US/
http://support.microsoft.com/kb/314085/EN-US/

Those links will sove it.  Usually it requires some registry fixes, but not always.
0
 
Indy_IT_AdminAuthor Commented:
Found the fix from a friend who returned my HELP email I broadcasted.

SplinterCell5894 was the only one in the same ballpark as the solution.  Apparently the GUID had become corrupted.  The ONLY fix that I found that woudl work was to take the following steps:

1.  Dis-join the computer from the domain.
2.  Delete the Doc & Settings folder from the user.
3.  Delete the computer object in AD
4.  Re-join the computer to the domain.
5.  Add the printers.

I guess I was very supprised that almost everyone focused on the printer aspect of the problem and not that server connectivity was also comprimised at the same time.  At any rate it was fixed and because I don't know how to split or reduce points SplinterCell5894 gets the booty.

Thanks for the help!
0
 
Joseph HornseyPresident and JanitorCommented:

I love it when I get the booty!!!!

Wait... are we talking about the same thing?

:-)


Wow.  I've never seen it where you actually had to delete their profiles.  Thanks for sharing the fix.

<-=+=->
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now