Cisco VPN Client To PIX 501 no Default Gateway

Posted on 2006-05-19
Last Modified: 2013-11-16
Hi guys having trouble trying to Configure my Cisco pix, I establish VPN tunnel but i get no gateway. Any help will be appriciated , Thanks in advance.

I Also want to be able to establish the VPN tunnel from Work and be still able to go online.

Ethernet Adapter

Ip address =
Subnet      =
Gateway    =
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password C0IwyJydMqZ2Ba2U encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list inbound permit tcp any interface outside eq telnet
access-list inbound permit tcp any interface outside eq 3389
access-list inbound permit icmp any any echo-reply
access-list 105 permit icmp any any echo-reply
access-list 105 permit icmp any any source-quench
access-list 105 permit icmp any any unreachable
access-list 105 permit icmp any any time-exceeded
access-list 105 permit icmp any any
access-list 105 permit tcp any interface outside eq 3389
access-list 102 permit ip
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 0 0
nat (inside) 1 0 0
static (inside,outside) tcp interface telnet telnet netmask 0 0
static (inside,outside) tcp interface 3389 3389 netmask 0 0
access-group 105 in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup groupmarketing idle-time 1800
vpngroup Work address-pool vpnpool1
vpngroup Work dns-server
vpngroup Work default-domain
vpngroup Work split-tunnel 102
vpngroup Work idle-time 1800
vpngroup Work password ********
telnet inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
: end
Question by:josenetwork
    LVL 79

    Accepted Solution

    >vpngroup Work split-tunnel 102
    With split-tunnel enabled you won't get a default gateway. Your PC will still use its regular default.
    While connected, look at result of C:\>route print

    >but i get no gateway
    You won't. Open the VPN Client, Status page, look at protected networks list. You should see and nothing else. This means that any traffic coming from your PC going to that subnet will be encrypted through the VPN tunnel. All other traffic will go out your regular default gateway/internet connection.

    >I Also want to be able to establish the VPN tunnel from Work and be still able to go online.
    I don't follow this part. If you're at work, you're behind this PIX - correct?
    If you're behind this PIX, you can't establish a VPN tunnel back to the outside of this PIX.
    If you're anywhere else on the internet you should be able to establish a VPN tunnel and still be able to get anywhere else on the Internet.

    Suggest adding this line to the PIX config:
      isakmp nat-traversal 20

    Then re-apply the isakmp to the interface
     isakmp enable outside

    That command will allow you to connect from behind  your own NAT router.

    Author Comment

    Thanks lrmoore what you suggested worked, Thanks for the quick responce.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
    I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now