• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 210
  • Last Modified:

httpd Reactivation error, help!!

Hello!   Everyone, my personal Server at home for development of PHP and CGI programs downed.   I don't know how to reactivate.   It used to get back by the following two commands, but this time they don't work.   How can I fix it?   Help me!

[mkido@icho mkido]$ su - root
Password:
[root@icho root]# /etc/rc.d/init.d/httpd stop
Stopping httpd:                                            [FAILED]
[root@icho root]# /etc/rc.d/init.d/httpd start
Starting httpd:                                            [FAILED]
[root@icho root]#

0
mkido
Asked:
mkido
  • 3
  • 2
1 Solution
 
ahoffmannCommented:
please have a look at your error_log
you find the path and the name to this file in your httpd.conf (ServerRoot and ErrorLog directive)
0
 
mkidoAuthor Commented:
Thank you, ahoffmann!   I will look at.
0
 
mkidoAuthor Commented:
I looked at,

  /etc/httpd/logs/error_log

It was huge.   I noticed the error happens during running a .php file which access a big external file for analysis.   It swelled up to,

   2147483647  bytes = 2.1 GB

I couldn't scroll it by "more" nor other editors.   All error_log are the same,

   Use of uninitialized value in pattern match (m/ /) at /var/www/cgi-bin/TEST/cgi49.pl

Anyway, I tried to refresh the WEB-server packages by Add/Remove packages.   Unfortunately, even after reloading of WEB-server packages, httpd doesn't function.   So, I will reload the entire OS, and I think that is easy.   What do you think?   It's my personal setting, so it's O.K. to do that.

0
 
ahoffmannCommented:
> I couldn't scroll ..
sounds like your kernel and filesystem ist 2GB-aware but not your tools
You have to install 2GB-aware tools

> Use of uninitialized value in pattern match (m/ /) at /var/www/cgi-bin/TEST/cgi49.pl
this sounds more like a perl program where you did not check proper your variables before using them
I recommend to use -w in hashbang line and/or
  use strict;
to identify such problems
0
 
mkidoAuthor Commented:
After re-loading the Linux OS, it gets back to work.    httpd and Web browser.   OS loading takes about only 1 hour, this way worked conveniently.  

Now, I run (.pl) and .php files at the command lines, so that I can avoid big mistakes while I am looking at the response in the screen.   Then I convert them to the final CGI or PHP files for WEB interaction.    
   $ php   script.php

0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now