• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 368
  • Last Modified:

No packets flowing over point to point frame relay

Hello experts, I have a problem I am setting up a partial mesh point to point frame relay network. I have the main site and the first site connected via the pvc I can ping the serial0/0.1 interface on the remote router fine and I can actually telnet into the remote router just fine from the main router. My problem is actual packets of data going from the ethernet interface from one location to the other ethernet interface. Below are my configs. Also teh main router has internet thru an ADSL connection directly into the router using WIC-1ADSL (Works fine).

++++++++++++++++++++++++++++++++Main Router+++++++++++++++++++++++++++++++++++++++++++++

Current configuration : 2206 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname central
!
boot-start-marker
boot-end-marker
!
enable password 7 12140419130C0916737D767A
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip dhcp excluded-address 15.0.0.0 15.0.0.245
!
ip dhcp pool 1
   network 15.0.0.0 255.255.255.0
   default-router 15.0.0.1
   dns-server 68.94.156.1 68.94.157.1
!
ip audit po max-events 100
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe
!
!
interface Ethernet0/0
 description connected to EthernetLAN
 ip address 15.0.0.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description connected to Westside
 ip address 200.1.1.1 255.255.255.252
 frame-relay interface-dlci 22 IETF
!
interface Serial0/0.2 point-to-point
 description connected to Northeast
 ip address 200.1.2.1 255.255.255.252
 frame-relay interface-dlci 20 IETF
!
interface Serial0/0.3 point-to-point
 description connected to Eastvalley
 ip address 200.1.3.1 255.255.255.252
 frame-relay interface-dlci 21 IETF
!
interface ATM0/1
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname xxxxxxxx@sbcglobal.net
 ppp chap password 7 101F5B4A514244
 ppp pap sent-username xxxxxxxxxxx@sbcglobal.net password 7 091D1C5A4D5041
!
!
ip nat inside source list 1 interface Dialer1 overload
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 15.0.1.0 255.255.255.0 200.1.1.2
ip route 15.0.2.0 255.255.255.0 200.1.2.2
ip route 15.0.3.0 255.255.255.0 200.1.3.2
!
!
access-list 1 permit 15.0.0.0 0.0.0.255
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password 7 151F0A02052D2E3671656770
 login
line aux 0
line vty 0 4
 password 7 03095A050708245E175F4B57
 login
!
!
end


+++++++++++++++++++++++++++++++Remote Router++++++++++++++++++++++++++++++++++++++++++++



!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Westside
!
boot-start-marker
boot-end-marker
!
no logging console
enable password 7 060B0E2F4D490C0B5C414059
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
ip audit po max-events 100
!
!
!
!
!
!
interface Ethernet0/0
 description connected to EthernetLAN_1
 ip address 15.0.1.1 255.255.255.0
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 service-module t1 timeslots 1-6
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description connected to central
 ip address 200.1.1.2 255.255.255.252
 frame-relay interface-dlci 16 IETF
!
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
!
!
line con 0
 exec-timeout 0 0
 password 7 1308161C0A0B013872727A61
 login
line aux 0
line vty 0 4
 password 7 070220424F0E1C174E44595E
 login
!
!
end


0
amanytx
Asked:
amanytx
  • 8
  • 7
  • 5
1 Solution
 
Don JohnstonInstructorCommented:
Since you can telnet from one router to the other, that confirms frame relay and IP is functional between the two routers.

What happens if you traceroute from an end station at the remote location to the ethernet interface of the router at the main location?

-Don
0
 
lrmooreCommented:
Post result of "show frame-relay pvc" from both sides
Post result of "show ip int brief" from both sides
0
 
Don JohnstonInstructorCommented:
Also, "show frame-relay map" from both sides.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
amanytxAuthor Commented:
To answer donjohston's question, I get a time out if I ping from a workstation connected to the remote router trying to ping the main router's int0/0  
0
 
amanytxAuthor Commented:
++++++++++++++++++++++main router+++++++++++++++++++++++++++++++++++++++++++++++++


Password:
central>enable
Password:
central#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            2            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 20, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0.2

  input pkts 0             output pkts 6            in bytes 0
  out bytes 1272           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 6         out bcast bytes 1272
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 13:52:43, last time pvc status changed 13:52:25

DLCI = 21, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0.3

  input pkts 0             output pkts 7            in bytes 0
  out bytes 1328           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 7         out bcast bytes 1328
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 13:50:15, last time pvc status changed 13:49:34

DLCI = 22, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 5185          output pkts 5914         in bytes 627066
  out bytes 635562         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1079      out bcast bytes 244856
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 13:53:41, last time pvc status changed 13:02:37


central#sh ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
Ethernet0/0                15.0.0.5        YES manual up                    up

Serial0/0                  unassigned      YES NVRAM  up                    up

Serial0/0.1                200.1.1.1       YES NVRAM  up                    up

Serial0/0.2                200.1.2.1       YES NVRAM  down                  down

Serial0/0.3                200.1.3.1       YES NVRAM  down                  down

ATM0/1                     unassigned      YES NVRAM  up                    up

Virtual-Access1            unassigned      YES unset  up                    up

Dialer1                    70.135.173.254  YES IPCP   up                    up

central#




central#sh frame-relay map
Serial0/0.1 (up): point-to-point dlci, dlci 22(0x16,0x460), broadcast, IETF
          status defined, active
Serial0/0.2 (down): point-to-point dlci, dlci 20(0x14,0x440), broadcast, IETF
          status defined, inactive
Serial0/0.3 (down): point-to-point dlci, dlci 21(0x15,0x450), broadcast, IETF
          status defined, inactive
central#



P.S. Remeber circuits 2 and 3 are not installed on the remote sides yet so it is expected for them to show they are down

++++++++++++++++++++++++++++++++++++++Remote+++++++++++++++++++++++++++++++++++++++++
Password:
Westside#sh frame-relay pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 5978          output pkts 5248         in bytes 639196
  out bytes 632224         dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 813       out bcast bytes 231413
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 13:12:45, last time pvc status changed 13:08:40
Westside#

Westside#sh ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
Ethernet0/0                15.0.1.1        YES manual up                    up

Serial0/0                  unassigned      YES NVRAM  up                    up

Serial0/0.1                200.1.1.2       YES NVRAM  up                    up

Westside#

Westside#sh frame-relay map
Serial0/0.1 (up): point-to-point dlci, dlci 16(0x10,0x400), broadcast, IETF
          status defined, active





0
 
Don JohnstonInstructorCommented:
I didn't ask about a ping. I asked what happens when you "traceroute". That way we can see where the packet is being dropped.

-Don
0
 
amanytxAuthor Commented:
This is the traceroute going from main to remote
Main e0/0 ip is 15.0.0.1 remote's ip is 15.0.1.1

Password:
central#traceroute 15.0.1.1

Type escape sequence to abort.
Tracing the route to 15.0.1.1

  1 200.1.1.2 12 msec 12 msec 12 msec
  2 200.1.1.1 24 msec 20 msec 20 msec
  3  *  *  *
  4  *  *  *
  5  *  *  *
  6  *  *  *
  7  *  *  *
  8  *  *  *
  9  *  *  *
 10  *  *  *
 11  *  *  *
 12  *  *  *
 13  *  *  *
 14  *  *  *
 15  *  *  *
 16  *  *  *
 17  *  *  *
 18  *  *  *
 19  *  *  *
 20  *  *  *
 21  *  *  *
 22  *  *  *
 23  *  *  *
 24  *  *  *
 25  *  *  *
 26  *  *  *
 27  *  *  *
 28  *  *  *
 29  *  *  *
 30  *  *  *
central#
0
 
Don JohnstonInstructorCommented:
That's strange... A traceroute from Central to Westside is showing a first hop of Westside's frame-relay interface (expected) and a second hop of Cental's frame interface (totally unexpected) and then nothing.

Can you do a traceroute from an end station at the Central site to the ethernet interface of the Westside router?

Also verify that the routing tables are correct (show ip route) for both routers.

-Don
0
 
lrmooreCommented:
Can you post "show ip route" from Westside?
0
 
amanytxAuthor Commented:
I will not be able to do a traceroute from a workstation until monday as the office is closed.
 +++++++++++++++++++++++++++++++central ip route++++++++++++++++++++++++++++++++++++++++
central>enable
Password:
central#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     70.0.0.0/32 is subnetted, 1 subnets
C       70.135.173.254 is directly connected, Dialer1
C    200.1.1.0/24 is directly connected, Serial0/0.1
     10.0.0.0/32 is subnetted, 1 subnets
C       10.20.30.40 is directly connected, Dialer1
     15.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       15.0.0.4/30 is directly connected, Ethernet0/0
S       15.0.3.0/24 [1/0] via 200.1.3.2
S       15.0.2.0/24 [1/0] via 200.1.2.2
S       15.0.1.0/24 [1/0] via 200.1.1.2
S*   0.0.0.0/0 is directly connected, Dialer1
central#

+++++++++++++++++++++++++++westside+++++++++++++++++++++++++++++++++++++++++++++++

Westside#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.1.1.0/24 is directly connected, Serial0/0.1
     15.0.0.0/30 is subnetted, 1 subnets
S       15.0.1.0 [1/0] via 200.1.1.1
0
 
lrmooreCommented:
Westside's Ethernet port is not active. Is it even plugged into the LAN?
 Else you would see something like this on Westside:

C       15.0.1.0/24 is directly connected, Ethernet0/0


Given this IP on Central:
>ip address 15.0.0.1 255.255.255.0
>C       15.0.0.4/30 is directly connected, Ethernet0/0

I would expect to see this:
  C       15.0.0.0/24 is directly connected, Ethernet0/0
                   ^^^^
0
 
amanytxAuthor Commented:
Someone must have turned off the pc on westside. As far as central the e0/0 ip is 15.0.0.1. I saw this also. What do you make of this or will I have to wait until Monday to tunr on the pc's? As far as you can tell are the IP route tables correct?
0
 
lrmooreCommented:
Yes, as far as I can tell, the routing is OK. Is this PC plugged directly into the router, or on a switch? If the router is plugged into a switch, it should be up.
0
 
Don JohnstonInstructorCommented:
I think the masks on the e0/0 interfaces on both routers are incorrect. If I had to guess (which I do :-)), I would say that while configuring the routers, the same mask (/30) was used for the serial AND the ethernet interfaces.

Do a "show interface" or "show ip interface" on the ethernet interfaces to confirm.
0
 
lrmooreCommented:
It could also just be that the Ethernet interface has not been enabled
westside#conf t
westside(config)#interface fast 0/0
westside(config-if)#ip adress 15.0.1.1 255.255.255.0  <== make sure the mask is right
westside(config-if)#no shut  <== enable the interface
westside(config-if)#no keep  <== bring it up artificially if whatever it is connected to is turned off
westside(config-if)#exit
westside(config)#exit
westside#


BTW - you realize that 15.x.x.x is *not* a private IP address space and that if you ever want to visit any web sites or other internet sites hosted by HP.com - you can't. The 15.0.0.0 address space is owned by Hewlett Packard. The 200.0.0.0 range is assigned to the  Latin America/carrabean region

Highly suggest you pick something in the real private IP space such as 192.168.15.0, 192.168.16.0, 192.168.17.0, etc...


0
 
amanytxAuthor Commented:
The pc is plugged into the router directly as this is an upgrade and I was trying to keep everything as the original setup.

Yes I have the same submask on both. I am sorry I missed this I will correct on Monday.

I will change the IP space as you suggested again I took over for someone else and had to keep the same settings as this is an upgrade and they did not want to change the confi at all.

So in theory after I make these changes it should work correct?

Thanks again for everything
0
 
lrmooreCommented:
>So in theory after I make these changes it should work correct?

Yes, with fingers crossed....

0
 
amanytxAuthor Commented:
It worked fine! All 4 locations are up and talking to the main location. Now I just have to get the internet from the main location to the remotes thru the frame!

Thanks

Here is a copy of the working config at the main location


Current configuration : 2277 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname central
!
boot-start-marker
boot-end-marker
!
no logging console
enable password 7 12140419130C0916737D767A
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip dhcp excluded-address 192.168.101.1 192.168.101.245
!
ip dhcp pool 1
   network 192.168.101.0 255.255.255.0
   default-router 192.168.101.1
   dns-server 68.94.156.1 68.94.157.1
!
ip audit po max-events 100
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 description connected to EthernetLAN
 ip address 192.168.101.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 full-duplex
 no keepalive
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description connected to Westside
 ip address 200.1.1.1 255.255.255.252
 frame-relay interface-dlci 22 IETF
!
interface Serial0/0.2 point-to-point
 description connected to Northeast
 ip address 200.1.2.1 255.255.255.252
 frame-relay interface-dlci 20 IETF
!
interface Serial0/0.3 point-to-point
 description connected to Eastvalley
 ip address 200.1.3.1 255.255.255.252
 frame-relay interface-dlci 21 IETF
!
interface ATM0/1
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname elpasoymca@sbcglobal.net
 ppp chap password 7 101F5B4A514244
 ppp pap sent-username elpasoymca@sbcglobal.net password 7 091D1C5A4D5041
!
ip nat inside source list 1 interface Dialer1 overload
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.0.0.0 255.0.0.0 Ethernet0/0
ip route 192.168.102.0 255.255.255.0 200.1.1.2
ip route 192.168.103.0 255.255.255.0 200.1.2.2
ip route 192.168.104.0 255.255.255.0 200.1.3.2
!
!
access-list 1 permit 192.168.101.0 0.0.0.255
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password 7 151F0A02052D2E3671656770
 login
line aux 0
line vty 0 4
 password 7 03095A050708245E175F4B57
 login
!
!
end
0
 
lrmooreCommented:
Add "ip nat inside" to your serial sub-interfaces and add the remote subnets to acl 1
access-list 1 permit 192.168.102.0 0.0.0.255
access-list 1 permit 192.168.103.0 0.0.0.255
access-list 1 permit 192.168.104.0 0.0.0.255
inter serial 0/0.1
 ip nat inside
inter serial 0/0.2
 ip nat inside
inter serial 0/0.3
 ip nat inside
0
 
amanytxAuthor Commented:
Thank you very much. It worked like a charm from the remote locations. They have internet now
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now