Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 349
  • Last Modified:

I am unable to change windows firewall settings, they are faded

I have just repaired and updated windows xp pro to sp2 and reinstalled AVG Free Edition and no 3rd party firewalls.  When i go into windows firewall properties, the "on, exception, off" options are faded.  I can see that the off option is picked but i have no way of putting this firewall on, however windows does not warn me that i dont have a firewall installed...what can i do to enable this windows firewall. I really don't want to install a 3rd party firewall program.
0
YuJimmyC
Asked:
YuJimmyC
1 Solution
 
war1Commented:
Greetings, YuJimmyC !

1. You need to log into Windows as Administrator or have Administrator rights.

2. A group policy may be blocking Windows Firewall. Ask your IT Administrator to change it.

3. A setting in the registry may be change. Navigate the following key in the registry and change from 0 to 1.
HKEY_LOCAL_MACHINE<SOFTWARE<MICROSOFT<POLICIES<MICROSOFT<WINDOWS
FIREWALL<STANDARD FIREWALL


Best wishes!
0
 
YuJimmyCAuthor Commented:
Can you tell me where i can find this group policy thing? I really dont have anyone else that knows =T
0
 
ChrisMacleodCommented:
Group policy can be found in Control Panels (classic view) => administrative tools => local security policy.

You could also make sure the Windows Firewall/Internet Connection Sharing (ICS) service is started.  To do this:

Goto Start => Control Panels => click switch to classic view => click administrative tools => open services

In services find Windows Firewall/Internet Connection Sharing (ICS) and double click.  In the properties dialog set the startup type to automatic then click apply then click start.

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
war1Commented:
YuJimmyC,

If you are not in an Office environment, and you are the only using the computer, then the problem is not likely due to Group Policy.  Make the registry change that I posted above, and you should be able to install the Firewall.
0
 
scottjlloydCommented:
Most likely your previous firewall disabled one or more of the services for windows firewall service.  To check and see if this is the case do the following:
Run -> services.msc
when the program executes sort by name and find the services:  

Windows Firewall/Internet Connection sharing (ICS) service.  Right click choose properties and set startup type to automatic.  Then start the service, if it will not start see notes later in this comment.

Secutiry Center service.  Do the same with this service - right click choose properties and set startup type to automatic.  Start the service, if it will not start see same note.

Note:
Both of these services rely on other services that are most likely already on but in case the services will not start this is the likely reason.  Jere is the list of services that these two services depend upon and must be enabled for there services to work.

Security Center service  relies on: Remote Procedure Call (RPC) and Windows Management Instrumentation (WMI relys on RPC and RPC does not require any other services).  Set these to auto startup and start the services.

Windows Firewall relies on RPC, WMI and Network Connections - the first two you turned on, if necessary, as described in the previous paragraph.  So now all that is possible left is Network connections and that most is probably on as well but checking it can't hurt.

Most likely will will only have to enable Firewall or security center, I really doubt any other services are disabled but put in the steps just in case.  You should be able to access your firewall settings.  Good luck.

Scott J. Lloyd

0
 
war1Commented:
YuJimmyC,

We have not heard from you in awhile. Did any comment help you solve your problem? Do you have any more question? If an Expert helped you, please accept his/her answer above with an excellent or good grade.

Thanks, war1
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now