• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

replication problem between win2000 domain and win2003 domain

Hi All,

We have an old DC on w2k which was also the DNS, DHCP and WINS. recently i installed another server win2003 and promoted to be a DC which was successful also installed and confiugred the DNS on it win2003, planning was to eventually shift the AD from win2000 to newly built win2003. but i seems to be running in a problem and this problem was identified when i try to create a new user on my win2003 DC it fails with the following error


"windows cannot create the object "username" because:
The directory services was unabe to allocate a relative identifier"

I 've search alot in google and found the reported issue in KB on microsoft regarding the cause and resolution for it. now what microsoft is saying i don't believe that i totally fit in it as per the scenario, because they are taking about retore from the backup which is definitly not my case cux i ve a new computer on different OS.

even if go to NTDS setting and try to replicate i get the message "access denied".

please i need some guide line in it as i have a feeling "silience before storm", also i don't think so it would be partical to transfer FSMO to win2003 from win2000 and later find out that i am completely stuck that I cannot even create user accounts. One more think i don't even see the accounts created on win2000 in win2003 DC but this would be due to replication error i belive. Anyhow's please help me . thanks in advance
0
lomaree
Asked:
lomaree
  • 2
  • 2
1 Solution
 
Jay_Jay70Commented:
Hi lomaree,

can you confirm that the rid master is infact running and well, try running dcdiag on the 2003 server and netdiag on the 2000
0
 
lomareeAuthor Commented:
Hi All,


Just wanted to inform that the problem is solved, i demoted the new win2003 server and promote it back again and everything is good as it suppose to be. question is why did it happened ? what was the cause of it.
0
 
Jay_Jay70Commented:
my guess is an issue in contacting the RID master, if there was even a slight glitch in your promotion faze, and/or the machine simply lost contact with the RID master then it wouldnt surprise me that it couldnt allocate a RID
0
 
lomareeAuthor Commented:
maybe it could be the case.
0
 
CetusMODCommented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now