How to Install Netgear WG511 v. 2 PC Card under Fedora Core 4 (on Thinkpad A31)

Posted on 2006-05-21
Last Modified: 2007-12-19
I am running Fedora Core 4 (2.6.11-1.1369_FC4) on a Thinkpad A31.  I am new to Linux, and I have been trying for months to get a wireless card working.  I bought a Netgear WG511 v2 (made in China), because I heard it was widely compatible.  Can anybody give me an outline of the steps I need to follow?  FYI, I have never compiled a kernel or used PC cards under Linux.   Thanks in advance for any suggestions.
Question by:cs76737
    LVL 3

    Expert Comment

    do the following to get the card working

    1)Go to ATrpm (  and download . type " rpm -Uvh" to install the package.

    2) Now search the ATrpm Fedora driver list ( and make sure you get the correct rpm to match ur kernel  "uname -a". Make sure you click on the "madwifi-kmdl-" rpm that matches both your processor and kernel.  type "rpm -Uvh" to install it .

    3) reboot the system

    4) Go to Desktop in your FC4 top panel. Select "System settings" then "Network". Type in your root password when asked and you will be taken to graphic menu that will list your network cards. In my case my laptop has an ethernet card and the wireless card. Until I installed Madwifi as described above the wireless card was not listed.

    5) The wireless card is now listed under "Devices", in my case under the ethernet card. Check the box to the left next of the wireless card and press the "Activate" button.

    6) When you go to leave the network menu you will be asked to save the new settings. Press OK. You're almost there.

    7) Restart your computer.


    Author Comment

    Thank you for the post.  One quick question before I start.  The website you reference in #2 states the driver works for "Atheros chipsets".  I was told the WG511 v2 card from Netgear has a PRISM chipset.  Do you have the same card as I do?  Are you sure MADWIFI supports WG511?  thanks again, Carsten
    LVL 3

    Expert Comment

    Give a try ,I think it should work. If it doesn't work ,you can easily uninstall the packages " rpm -e <package name>" ...After installation see if  you get any error messages in /var/log/messages

    Author Comment

    Sundeep, thank you for the help.  I am stuck on STEP 2.  The output from "uname -a" is below:
    Linux localhost.localdomain 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 i686 i386 GNU/Linux

    There appears to be no "madwifi-kmdl-" rpm that matches my kernel.  Is that correct?  What can I do?
    LVL 3

    Accepted Solution

    yeah I have seen it just  now ....don't go for those rpms , as yours is prism chipset
    check this out
    1.) First, check out that your wireless card is supported by

    2.) Download the proper firmware add-on release. This is not a firmware update for the card, but a microcode add-on which has to be loaded everytime your system starts up. Your card firmware won´t be changed.
    take firmware add-on release.

    3.) Check your pcmcia daemon is running from startup. If not, just type "chkconfig pcmcia on" an restart your system.

    4.) Copy your firmware add-on to the /lib/firmware directory. The
    directory already exists !
    If the directory is not there, take a look at the firmware path stated in
    the /etc/hotplug/firmware.agent script.

    Example: /etc/hotplug/firmware.agent

    ----------------- snip ----------------
    # directory of the firmware files
    ----------------- snap ----------------

    5.) Rename your firmware add-on from "" to "isl3890".

    6.) Edit your /etc/modprobe.conf. In my case, the wireless card points to eth1. Change the alias: alias eth1 islpci_cb

    Example: /etc/modprobe.conf

    ------------- snip ---------
    alias eth0 e100 # build-in ethernet adapter
    alias eth1 islpci_cb # netgear wg511 pcmcia adapter
    ------------- snap ---------

    7.) Restart your system and check with "lsmod" the existence of the prism driver.

    Then after restart, goto system tools>internet configuration Wizard, config your access point and such to match. NOTE: you have to apend '0x' in the front the HEX wep passphase.

    hope this helps

    Author Comment

    Thank you for the instructions.  Sorry for taking so long to reply, but I was traveling on business.  I followed all your steps, and it still doesn't work.  Here are some facts:

    1.) I got the firmware add-on, and the /lib/firmware directory existed already.  The firmware.agent file already pointed to this directory.

    2.) When I ran "chkconfig --list | grep pcmcia", I got the following:
    pcmcia          0:off   1:off   2:on    3:on    4:on    5:on    6:off

    One thing that is peculiar is that the card doesn't even appear to be powered.  No lights.  No sound from my Thinkpad that PC cards are running.  I get that sound under Windows, and the card runs fine under Windows.  Is this a potential problem?

    3.) Here is the output from lsmod:
    Module                  Size  Used by
    radeon                 76609  1
    drm                    70101  2 radeon
    parport_pc             28933  1
    lp                     13001  0
    parport                40585  2 parport_pc,lp
    autofs4                29253  2
    rfcomm                 42333  0
    l2cap                  30661  5 rfcomm
    bluetooth              56133  4 rfcomm,l2cap
    sunrpc                167813  1
    pcmcia                 29025  4
    video                  15941  0
    ibm_acpi               15997  0
    button                  6609  0
    battery                 9413  0
    ac                      4805  0
    md5                     4033  1
    ipv6                  268097  8
    yenta_socket           21449  3
    rsrc_nonstatic         12737  1 yenta_socket
    pcmcia_core            50909  3 pcmcia,yenta_socket,rsrc_nonstatic
    uhci_hcd               35152  0
    shpchp                 94405  0
    hw_random               5973  0
    i2c_i801                8781  0
    i2c_core               21569  1 i2c_i801
    snd_intel8x0m          19589  0
    snd_intel8x0           34689  1
    snd_ac97_codec         75961  2 snd_intel8x0m,snd_intel8x0
    snd_seq_dummy           3653  0
    snd_seq_oss            37057  0
    snd_seq_midi_event      9153  1 snd_seq_oss
    snd_seq                62289  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device          8781  3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss            51185  0
    snd_mixer_oss          17857  1 snd_pcm_oss
    snd_pcm               100169  4 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
    snd_timer              33605  2 snd_seq,snd_pcm
    snd                    57157  12 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
    soundcore              10913  1 snd
    snd_page_alloc          9669  3 snd_intel8x0m,snd_intel8x0,snd_pcm
    e100                   47297  0
    mii                     5441  1 e100
    floppy                 65269  0
    dm_snapshot            17413  0
    dm_zero                 2113  0
    dm_mirror              26029  0
    ext3                  132553  2
    jbd                    86233  1 ext3
    dm_mod                 58101  6 dm_snapshot,dm_zero,dm_mirror

    Any ideas?  

    Author Comment

    Another update...
    (1) I called Netgear and gave them the card's serial number & specs.  They told me the chipset is "Intersil/Frisbee" -- not PRISM.  However, I have seen on several websites that Frisbee and Prism are compatible/indentical.  One more wrinkle:  when I run "lspci", it says "Ethernet Controller: Marvell Technology Group LTD.: Unknown device 1faa.  This leads me to believe the chipset is actually by Marvell.  Clearly NetGear is no help at all.  They suck.

    (2) I decided to trust the output from "lspci", so I started installing ndiswrapper.  NDISWRAPPER compiled fine, but I keep getting "invalid driver" when I try to load the driver using: "ndiswrapper -i WG511v2.INF".  

    (3) This leaves me with a card that is still not running, and I'm not sure where to go next.  I have now decided to blow away my entire installation.   I am going to install Fedora Core 5 (in the hopes that it might even identify the cards out-of-the-box).  If it does not, I will try installing NDISWRAPPER again.  

    Any thoughts would be very appreciated.  Thanks, Carsten

    Author Comment

    Resolved -- sort of.

    This problem took way too much of my time.  In the end, I went to the following website:

    I looked for a card that has PRISM54 GT chipset.  I found SMC 2835W was the cheapest at a local store.  I followed your instructions regarding PRISM.

    Thank you very much, Sundeep Gopal, for all the help.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now