Dell Optiplex flaky on boot - will boot from CD but not from floppy and intermittently from hard drive

I have a Dell Optiplex GX260 Pentium-4 at 1.4 GHz.  It has Windows XP Pro SP2 installed on the hard drive.  When I try to boot from the hard drive or a bootable floppy, I get a message from the BIOS that it can't boot (F1 to retry boot or F2 to enter setup program).  If I insert a bootable CD, it will boot from the CD.  I have flashed the BIOS with the latest from the Dell website and checked all the cables.  There is no "Select Default settings" in the BIOS, but it's set to a normal set of choices.  

If I put in a Windows 98 bootable install CD, the CD gives a choice 1.  Boot from hard drive or 2.  Boot from CD drive.  If I select "Boot from hard drive", it boots from the HD, but if I try to boot directly from the HD, the BIOS gives an error message.  If I insert a bootable floppy, the BIOS doesn't even try to boot from it (no noise from the floppy during the bootup process), it just complains F1 to retry boot or F2 to enter setup program.

Does anyone have an idea what is causing this and how to fix it?  Otherwise, I just have to leave a copy of the Windows 98 install CD in the CD drive an always use it to boot.  I hat to do such a kludge on a nice almost-new machine!
LVL 2
kaytonAsked:
Who is Participating?
 
jamietonerConnect With a Mentor Commented:
reset bios defaults with the jumper on the motherboard, here's a link that shows the location of the rtcrst jumper
http://support.dell.com/support/edocs/systems/opgx260/en/ug/advfeat.htm#1117484
0
 
nobusCommented:
try to connect the disk to the other IDE cable. does it still do it?
did you replace the IDE cable?
Is this only when booting cold, or does it the same on a restart ?
0
 
Danny ChildIT ManagerCommented:
sounds like the hard disk has a problem.  do you have a spare to try in it?  If so, try a sample XP install to it as a test.   If the hard disk is not responding in time when asked to boot, it may fail, but perhaps the w98 CD is a little more generous in the time that it allows.  

Is the floppy drive visible and working once XP is up and running?  If not, check that it is not disabled in the bios.  If it's enabled but not working, I'd think that it has a hardware fault.  

hth, Danny
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Danny ChildIT ManagerCommented:
Also, check the Boot Order in the BIOS, and that the floppy is not showing as disabled.
0
 
kaytonAuthor Commented:
Problem occurs whether rebooting or booting cold.  Only exception is that partway through a reinstall of XP, it will boot from the hard drive twice.

Tried moving to other IDE cable and replacing cable.  Same problem.  Tried different FDD and FDD cable.  Same problem.  Yes, the FDD and the HDD both show up in the BIOS and in XP once it boots.

Tried several different HDD.  Same problem.  

Tried every possible combination of boot order in the BIOS.  Same problem.  

Any more ideas??
0
 
nobusCommented:
can you try another disk? even a small one 2-10GB will do for testing
0
 
nobusCommented:
...then you'll be sure if it is the disk, or mobo or not.
0
 
Danny ChildIT ManagerCommented:
To clarify:
booting to the HD first **fails** every time.
booting to a w98 CD and then selecting the Boot From HD option **works** every time.
multiple HDs and cables have been tried.
multiple FDs have been tried.

So, I think the issue is mobo related.  Either there's a bios setting at fault, or it's a hardware issue.  Are there any settings for Quick Boot in the bios?  If so, disable them... These normally only affect memory tests, but hey...

Can you try one of your spare disks, and just set it to be bootable to DOS - even do this on a different pc and then move the disk over?  Trying to rule out whether your controllers have some problem writing to boot sectors...



0
 
kaytonAuthor Commented:
DanCH99- yes, to clarify those statements are correct.

Tried another HD - won't boot to it first.

I think it's a BIOS setting, but I've tried changing everything I could think of.  There is no "default" setting.  Quick boot is disabled.
0
 
nobusCommented:
Can you test this drive(s) on another PC?
0
 
mwnnjCommented:
hmmm,
could be:
1) regarding the hdd boot:
-check out in your bios setup if you can specify the boot order,using F2,there should be something regarding :
1. boot,2.boot ,3. boot device and select for your hdd the hdd0 option if such
-check out if there are some extra controllers on your motherboard:ide-controller and s-ata controller ,then specify the right one for your hdd as a primary
-check out the mbr on your harddrive,using the windows XP installation cd,but assuming you can boot from the wondows 98 inst cd i think this is NOT a problem,though:
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/bootcons_fixmbr.mspx?mfr=true
2)regarding the floppy issue:
-i assume it's the same problem:there is a mess with your boot order,should be as best something like:
1. boot -cd-rom
2.boot -floppy
3. boot device-hdd0
i think you can use the F12 key to select where to boot from,at least these is the setting on my Dell Precision 340 at work.
here is a documentation for your optiPlex:
http://support.dell.com/support/edocs/systems/opgx260/en/index.htm
here are the tech.specs:
http://support.dell.com/support/edocs/systems/opgx260/en/ug/specs.htm#1110653
ok ,so no s-ata support/controller.
and ,yes:
<F12>  displays a one-time boot menu that lets the user enter a device for a single boot (during start-up only)
Ok,try to study your BIOS carefully,there should be an option for the boot order,perhaps littel bit of hidden ...

cu
0
 
mwnnjCommented:
sorry,folks,
i was too late,so not trying to copy someone's suggestion!

Cheers!
0
 
kaytonAuthor Commented:
Thanks, jamietoner!  Setting the BIOS to the default settings did the trick - I just needed your help to figure out how to do it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.