This version of java does not support the classic compiler; upgrading to modern

This version of java does not support the classic compiler; upgrading to modern?

I  am getting the above error. Please let me know how to slove it.

I am tring to compile an existing java code using
ant "Apache Ant version 1.6.5"
JDK i am using is "jdk142_05"
Weblogic 8.1 sp4.

Please tell me how to slove this problem

thanks
Paul

ereaditechnologiesAsked:
Who is Participating?
 
CEHJCommented:
Try searching the Ant build file for 'classic' and removing it
0
 
Giant2Commented:
What do you see using
ant -verbose
0
 
objectsCommented:
in your ant script set the ant build property 'build.compiler' to modern
and/or set the compiler property in the javac task to modern
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.