[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1155
  • Last Modified:

Drive letter changed, now NTLDR is missing.

Well, the title about says it all.

I was playing WoW on my computer and it unexpectedly froze. When I restarted, the computer gave me an error message of "NTLDR is Missing".

I started the computer with the XP Pro CD in, and went into the recovery console. I noticed, however, when it gave me a list of my Windows installations, it was "D:\WINDOWS" instead of "C:\WINDOWS". I am suspecting that this is the cause of the missing NTLDR.

Any help is appreciated, below if my system specs:

Intel P4 Prescott 3.2gHz
1GB DDR-pc3200
1 - 16x DVD+/-R
1 - 120GB IDE HDD (slave)
1 - 200GB SATA HDD (master)
0
The_Computer_Guy
Asked:
The_Computer_Guy
  • 23
  • 15
  • 13
  • +1
2 Solutions
 
The_Computer_GuyAuthor Commented:
BTW, this is XP Pro SP2
0
 
victornegriCommented:
In recovery console, have you run "fixboot" and "fixmbr" yet?
0
 
The_Computer_GuyAuthor Commented:
no I have not... refresh my memory on the parameters please.
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
victornegriCommented:
Get into recovery console on the XP Pro CD. At the command line, just type "fixmbr" and "then type "fixboot". You can try one, reboot, and then try the other, and reboot, if you want. Fixmbr rewrites the master boot record with the installations of windows that it finds on your system. Fixboot recopies all the files necessary to start the boot process for windows (like ntldr.exe).

Just to make sure, you don't have a floppy or CD Rom in your drive right? Also unplug all external drives (i.e. memorysticks and external USB/Firewire drives).
0
 
victornegriCommented:
Oh,  you may want to check BIOS to make sure your boot order is IDE --> SATA and not the other way around.
0
 
victornegriCommented:
Whoops (I wish I could edit previous comments)... I meant SATA --> IDE and not the other way around (Master --> Slave). Or even remove IDE completely from your boot order.
0
 
The_Computer_GuyAuthor Commented:
Well, the computer booted fine with the IDE drive's power removed.

And yes, the boot priority is set correctly in the BIOS, but when the IDE is installed, I guess it tries to boot from that instead of the SATA. Unfortunately I cannot remove the IDE drive from the boot order.

And no, I do not have a floppy in the drive (although I have gone through numerous diagnostics in the past when all I had to do is remove the floppy :-P)

BTW, my board is a:
ECS PT800CE-A Rev 1.0A
0
 
victornegriCommented:
I would try the fixmbr and see if that helps. Hopefully it will rewrite your boot.ini file correctly. It will probably have to write a boot sector to your IDE drive so that it can find your windows install on your SATA drive. BTW, did you reformat your IDE drive recently?

0
 
The_Computer_GuyAuthor Commented:
I did not reformat recently.

Also, I am a bit worried about running a fixmbr.

In recovery console it sees only 1 drive/Windows install. Is that the drive (SATA) that I want to run the fixmbr on?
0
 
victornegriCommented:
Yes.
0
 
The_Computer_GuyAuthor Commented:
fixmbr did not help....
0
 
The_Computer_GuyAuthor Commented:
What's so strange about this issue is that out of the flippin' blue, the computer decides to start trying to boot from the wrong drive. No settings were changed prior to this issue.

0
 
Expert4XPCommented:
Can you copy /paste the contents of your c:\boot.ini file here.  It's possible the partition number points to the wrong partition for booting.  Here's a normal one:

[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn

You may have to change Windows Explorer to view hidden files, system files, in options if you don't already have that set.
0
 
The_Computer_GuyAuthor Commented:
I did a search, the only file I could find is "boot.ini.backup"

Perhaps my boot.ini was munched up by windows.
0
 
The_Computer_GuyAuthor Commented:
Also, when I go to save the boot.ini.backup to c:\boot.ini, it give me a "Replace File?" prompt, but the file cannot be viewed... weird
0
 
The_Computer_GuyAuthor Commented:
wow, if I go to run and type "notepad c:\boot.ini" it opens just fine....

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

That is the contents.
0
 
Expert4XPCommented:
Open Windows Explorer to c:\drive.  Click on Tools/Folder Options/View

Check "show hidden files..."
UNCheck "hide extensions..." and UNcheck "hide protected operating ..."

OK.  They should appear.
0
 
Expert4XPCommented:
do you see ntldr, and ntdetect.com and boot.ini there in c:\ root?

0
 
Expert4XPCommented:
Besides running fixmbr from the Recovery Console, did you run fixboot from the Recovery Console?
0
 
The_Computer_GuyAuthor Commented:
OK... I forgot to uncheck "Hide Protected Operating System Files"

The boot.ini is there and the contents were posted above.

Info that might be of use to you:

IDE Channel 0 Master = The 120GB IDE causing the problems.
IDE Channel 1 Master = DVD+/-RW
IDE Channel 2 Master = SATA drive Windows is installed on. (I set the SATA to IDE Mode when I installed windows)
0
 
The_Computer_GuyAuthor Commented:
"do you see ntldr, and ntdetect.com and boot.ini there in c:\ root?"
Yes

"Besides running fixmbr from the Recovery Console, did you run fixboot from the Recovery Console?"
Yes, to no avail.
0
 
The_Computer_GuyAuthor Commented:
Strange, in the recovery console, if the IDE drive is plugged in, the SATA shows up as drive "D:\", but when the IDE isn't plugged in, it shows up as "C:\"...

0
 
Expert4XPCommented:
I'm not positive about SATA, but on IDE the boot drive should be on Channel 0.

Recable yours so the boot is Channel 0
0
 
Expert4XPCommented:
>> Strange, in the recovery console, if the IDE drive is plugged in, the SATA shows up as drive "D:\", but when the IDE isn't plugged in, it shows up as "C:\"...

That's because it is booting from Channel 0 (your ide drive)
0
 
The_Computer_GuyAuthor Commented:
It is plugged into SATA channel 0, the BIOS assigned the channels for IDE/SATA channel relationships though.
0
 
Expert4XPCommented:
Well, I'm not sure why now, but for some reason, when your IDE drive is also connected, the bios seems to be booting from it (and giving your sata drive as d:).
0
 
Expert4XPCommented:
Maybe you should retry the fixmbr and fixboot, but unplug the IDE drive first.  
0
 
The_Computer_GuyAuthor Commented:
"Maybe you should retry the fixmbr and fixboot, but unplug the IDE drive first. "
Just did, no change :-(
0
 
Expert4XPCommented:
Sorry for the trial/error here.  With the IDE drive again disconnected, can you go into the Recovery Console for your sata drive?  Then try this:
bootcfg /list
bootcfg /rebuild

This should list the boot configurations that it sees and rebuild it.  Then see if XP boots (again leave IDE drive disconnected).
0
 
victornegriCommented:
See if there's a bios upgrade for your motherboard that will allow you to take the IDE channels out of the boot options.
0
 
Expert4XPCommented:
>> "do you see ntldr, and ntdetect.com and boot.ini there in c:\ root?"
Yes
>>

Just to re-confirm when you said "yes" above, was the IDE connected?  I just want to be sure you're ONLY looking at the sata drive.

Secondly, you're still getting ntldr missing message?
0
 
The_Computer_GuyAuthor Commented:
Just to re-confirm when you said "yes" above, was the IDE connected?  I just want to be sure you're ONLY looking at the sata drive.

Secondly, you're still getting ntldr missing message?

Yes to both...


0
 
The_Computer_GuyAuthor Commented:
but only NTLDR message when the IDE is plugged in.
0
 
Expert4XPCommented:
This is an honest question, don't take it the wrong way:  How are you able to see what is on your sata C: drive since you can't boot from it?  I can't visualize how you're looking at the c:\ root folder?
0
 
The_Computer_GuyAuthor Commented:
This is an honest question, don't take it the wrong way:  How are you able to see what is on your sata C: drive since you can't boot from it?  I can't visualize how you're looking at the c:\ root folder?

When the IDE drive is unplugged, the computer boots into windows just fine. I am only unable to boot when the IDE is plugged in.
0
 
Expert4XPCommented:
>> but only NTLDR message when the IDE is plugged in.

Sounds like it is complaining about not seeing the ntldr on your IDE drive.

victornegri, good idea.  Seems like the motherboard is stuck on the ide drive somehow.
0
 
The_Computer_GuyAuthor Commented:
I have the current BIOS version.
0
 
victornegriCommented:
Try this. Copy boot.ini, ntldr, and ntdetect.com to the root of your IDE drive. change your boot.ini to:

[boot loader]
timeout=15
default=multi(0)disk(1)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
0
 
victornegriCommented:
Err... actually try disk(0)rdisk(1)partition(1). Forgot that rdisk stands for the physical drive and disk stands for the scsi LUN
0
 
Expert4XPCommented:
>>
IDE Channel 0 Master = The 120GB IDE causing the problems.
IDE Channel 1 Master = DVD+/-RW
IDE Channel 2 Master = SATA drive Windows is installed on. (I set the SATA to IDE Mode when I installed windows)
>>

To recap a little, when you first installed Windows XP, it was on the SATA drive (set to IDE mode), but the IDE drive was present during the install/setup?

I'm wondering (thinking out loud here) that without your knowing it, XP was installed on d:?  Is that possible?

Other alternative is that now you have changed it from IDE model back to SATA mode?
0
 
The_Computer_GuyAuthor Commented:
">>
IDE Channel 0 Master = The 120GB IDE causing the problems.
IDE Channel 1 Master = DVD+/-RW
IDE Channel 2 Master = SATA drive Windows is installed on. (I set the SATA to IDE Mode when I installed windows)
>>

To recap a little, when you first installed Windows XP, it was on the SATA drive (set to IDE mode), but the IDE drive was present during the install/setup?

I'm wondering (thinking out loud here) that without your knowing it, XP was installed on d:?  Is that possible?

Other alternative is that now you have changed it from IDE model back to SATA mode?"

This is the same config I had it set as when I installed initially. I tried changing SATA from IDE mode to RAID, but it did not work. I know I installed windows on the correct drive because when the other drive is not present windows loads off of the SATA just fine, showing as drive C:\.
0
 
Expert4XPCommented:
Comment from victornegri
Date: 05/22/2006 05:31PM PDT
 Comment  
Err... actually try disk(0)rdisk(1)partition(1). Forgot that rdisk stands for the physical drive and disk stands for the scsi LUN

Interesting idea:  But do you think it should say rdisk(2) because his SATA drive is IDE Channel 2?  Also, how would he switch it so SATA was on Channel 0?  swap cables?  Maybe he got his cables mixed up at one time and now it's the wrong rdisk?
0
 
victornegriCommented:
Yeah, rdisk(2). Wasn't paying attention.

From the comments above, it looks like his motherboard has both IDE and SATA connectors but treats the SATA connectors as IDE channels.

The_Computer_Guy, you may have to re-run fixmbr and/or fixboot after copying the files I mentioned to the other drive.

The other option(s) is to get either an IDE to SATA converter or a SATA to IDE converter and get the SATA drive on a lower channel than the IDE drive. Or remove the IDE drive completely and put it in an external enclosure. Or use Ghost to clone your SATA drive onto your IDE drive and then use the SATA drive as the slave disk.



0
 
The_Computer_GuyAuthor Commented:
I am gonna give in and get an enclosure... I was just thinking that as I checked this page for an update (our brainwaves were in sync for a minute).

But I would really like to find out what caused this sudden problem. I am really irritated, the system was working perfectly for about 2 months, then out of nowhere it starts with this issue.

Grrr... I know the quick fix is to get an enclosure, and thats what I am going to do, but I will keep investigating the cause and I will add to this thread if I find anything else.
0
 
Expert4XPCommented:
Also, just a final thought.  Is your cd/dvd drive IDE?  Is it set to master?  And was the IDE hard drive also master?  Maybe there is documentation in the motherboard about booting order for your situation.

This has been an interesting (but frustrating) thread.  Good luck!
0
 
victornegriCommented:
I just can't believe that a mboard manufacturer would make it so that you can't select a sata drive to be the first boot device over an ide drive. It's like saying you can't buy a fuel-injected car because there are still cars with carburetors on the road.

Good luck.
0
 
The_Computer_GuyAuthor Commented:
Well, like I said, it was letting me do this just fine....
0
 
victornegriCommented:
I was reading a little about your mboard on ecs's website. Have you tried going into the sata raid config and setting a "boot array" even though  you don't have an array created?
0
 
The_Computer_GuyAuthor Commented:
I suppose it is worth a shot, as I have not yet forked out the $30 a USB enclosure is gonna cost me.
0
 
The_Computer_GuyAuthor Commented:
OK, I got it!!!

I should have tried this before, but hey, sometimes we don't think of the simplest things first.

I went ahead and re-flashed my BIOS with the same version, and low and behold, it worked. I guess my BIOS was corrupted somehow.
0
 
victornegriCommented:
Cool. Hopefully it doesn't happen again.
0

Featured Post

Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

  • 23
  • 15
  • 13
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now