Access to the path is denied

Posted on 2006-05-23
Last Modified: 2012-08-14
I have installed an ASP.NET application on my laptop that is running Windows XP Professional.
When I try to open the app I get the error message below.
I have granted access to anonymous users.
The solution mentioned, "To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access." does not work for me because in XP Pro there is no Security tab on the Propertis dialog box of the folder.

How do I resolve this problem?

Error details:

Server Error in '/iDesk' Application.

Access to the path 'c:\inetpub\wwwroot\iDesk\Log\ErrorLog2006-5-23.txt' is denied.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the path 'c:\inetpub\wwwroot\iDesk\Log\ErrorLog2006-5-23.txt' is denied.

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:

[UnauthorizedAccessException: Access to the path 'c:\inetpub\wwwroot\iDesk\Log\ErrorLog2006-5-23.txt' is denied.]
   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +2014563
   System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) +998
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access) +57
   iDesk.clsCommon.WriteErrToLog(String LogData) +385
   iDesk.clsCommon.ExecuteQuery(String QueryString) +344
   iDesk._Default.FillArenaComboBox() +62
   iDesk._Default.Page_Load(Object sender, EventArgs e) +64
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +47
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061


Question by:spaceplanner
    LVL 12

    Expert Comment

    Hi spaceplanner,

    Grant Read & Write permission on the directory (c:\inetpub\wwwroot\iDesk\Log\) to the IIS_WPG group.

    - Maddog

    Author Comment

    Hi Maddog,
    I have checked the folder and it is Read Only. I uncheck the attribute, Apply, OK. Then when I go back in it is chaecked again. How can I force Windows to accept the change?
    LVL 12

    Expert Comment


    Does the "Read-Only" checkbox has a greyish background?
    That means it is not really read-only.

    Have you tried adding permissions to the directory?
    LVL 7

    Accepted Solution

    what is your file system? NTFS ot FAT32?.. in case it is NTFS try going to the folder options and diabling simple file sharing..or try if u are getting the security tab in the safe mode. FAT32 does not have ths option

    Author Comment

    Not sure how to 'add permissions to the directory'

    the config file has  <identity impersonate="true"/>

    I have allowed anonymous access on all folders

    I have shared all folders with Read Write access

    what else should I do?

    thanks for your help

    Author Comment

    I do have NTFS file system and once I disabled the Simple file share I was able to share with everyone

    thanks for all your help


    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    In an ASP.NET application, I faced some technical problems. In this article, I list them out and show the solutions that I found.  I hope it will be useful. Problem: After closing a pop-up window, the parent page should be refreshed automaticall…
    Problem Hi all,    While many today have fast Internet connection, there are many still who do not, or are connecting through devices with a slower connect, so light web pages and fast load times are still popular.    If your ASP.NET page …
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…
    This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now