• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 213
  • Last Modified:

Apache within lan, not out

I have installed Apache/1.3.35 and PHP/4.4.2 on windows XP.  My computer is in DMZ and ports 80 and 1234 are forwarded to my computer.  I am connected to the internet.  My server runs and works perfect and fine within my lan.  However, no one outside of my lan can connect access my pages, they all time out after about 300 seconds (which is a parameter of httpd.conf).  AFter some research I found that my ISP, which is Optimum Online, blocks port 80.  So I changed the "Port" parameter to 1234 and tried this.  Tried to access with http://ip.add.re.ss:1234/.  Again, worked inside lan, not outside.  However, here is my dilemma.  I've read that browsing to http://localhost/ should yeild me my pages, within my lan, if I am using port 80 and if I'm using any other port, I should browse to it via http://localhost:xxxx/ where xxxx is the port number specified in httd.conf.  Recall that I have set the port to 1234, yet, when I browse to http://localhost/, it still works!  This leads me to beleive that my server is still listening on port 80 and not 1234, which means that it is still being blocking by my ISP outside of my lan.  Is there anything more that I must do to have apache listen on port 1234.  If not, why does http://localhost/ work when "Port" is set to 1234?  Thanks.
0
yattias
Asked:
yattias
2 Solutions
 
sleep_furiouslyCommented:
Could the page at http://localhost/ be served from browser cache?

In any case, a good (and free) utility to see what ports each process is using.  TcpView may help you investigate:

http://www.sysinternals.com/Utilities/TcpView.html

Also, Port directive is deprecated.  Though it still exists in Apache 1.3.x, it may be more straightforward to use Listen.
0
 
bimal_linuxCommented:
Hi,

IF your problem is the accessibility from outside, please check the default gateway settings of the webserver and make sure that it can access outside world. (Just a guess). The webserver should listen on its LAN ip address (not localhost). This would be another requirement for portworwarding. Try to tellnet to your public IPaddress port after the configuration to verify that its working..

Regards,
Bimal Mankara

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now